aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-09-04 21:45:20 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-09-04 21:45:20 +0800
commit39139f2ce83c1fd21654d5693daa8fd74c8ef3b0 (patch)
tree53df5847a689d77f4ef77acf01f5bc3b30ade6ea
parent4196588a684652d33533be4f62a4a431f30b4b47 (diff)
downloadfreebsd-ports-gnome-39139f2ce83c1fd21654d5693daa8fd74c8ef3b0.tar.gz
freebsd-ports-gnome-39139f2ce83c1fd21654d5693daa8fd74c8ef3b0.tar.zst
freebsd-ports-gnome-39139f2ce83c1fd21654d5693daa8fd74c8ef3b0.zip
A Plack Middleware for rate-limiting incoming HTTP requests.
WWW: http://search.cpan.org/dist/Plack-Middleware-Throttle/
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Plack-Middleware-Throttle/Makefile32
-rw-r--r--www/p5-Plack-Middleware-Throttle/distinfo3
-rw-r--r--www/p5-Plack-Middleware-Throttle/pkg-descr3
-rw-r--r--www/p5-Plack-Middleware-Throttle/pkg-plist12
5 files changed, 51 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b8d2c76bd2f6..48970e4ee58c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1111,6 +1111,7 @@
SUBDIR += p5-Plack-Middleware-JSConcat
SUBDIR += p5-Plack-Middleware-ReverseProxy
SUBDIR += p5-Plack-Middleware-Session
+ SUBDIR += p5-Plack-Middleware-Throttle
SUBDIR += p5-Plack-Server-AnyEvent
SUBDIR += p5-Plack-Server-Coro
SUBDIR += p5-Plack-Server-POE
diff --git a/www/p5-Plack-Middleware-Throttle/Makefile b/www/p5-Plack-Middleware-Throttle/Makefile
new file mode 100644
index 000000000000..7c602a3c2b71
--- /dev/null
+++ b/www/p5-Plack-Middleware-Throttle/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Plack::Middleware::Throttle
+# Date created: 04 Sep 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Plack-Middleware-Throttle
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension of rate-limiting incoming HTTP requests for Plack
+
+RUN_DEPENDS= \
+ p5-DateTime>0:${PORTSDIR}/devel/p5-DateTime \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-Moose>0:${PORTSDIR}/devel/p5-Moose \
+ p5-Plack>0:${PORTSDIR}/www/p5-Plack
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Plack::Middleware::Throttle.3 \
+ Plack::Middleware::Throttle::Daily.3 \
+ Plack::Middleware::Throttle::Hourly.3 \
+ Plack::Middleware::Throttle::Interval.3 \
+ Plack::Middleware::Throttle::Limiter.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Plack-Middleware-Throttle/distinfo b/www/p5-Plack-Middleware-Throttle/distinfo
new file mode 100644
index 000000000000..0fc3c6b62546
--- /dev/null
+++ b/www/p5-Plack-Middleware-Throttle/distinfo
@@ -0,0 +1,3 @@
+MD5 (Plack-Middleware-Throttle-0.01.tar.gz) = b9cb85dee32e3e7568e6e03424b899af
+SHA256 (Plack-Middleware-Throttle-0.01.tar.gz) = 309c97c874126d806884ab1e2073fe53c8de6d1be89b3d10bf155486277f0a38
+SIZE (Plack-Middleware-Throttle-0.01.tar.gz) = 47103
diff --git a/www/p5-Plack-Middleware-Throttle/pkg-descr b/www/p5-Plack-Middleware-Throttle/pkg-descr
new file mode 100644
index 000000000000..ef6d43e92f7c
--- /dev/null
+++ b/www/p5-Plack-Middleware-Throttle/pkg-descr
@@ -0,0 +1,3 @@
+A Plack Middleware for rate-limiting incoming HTTP requests.
+
+WWW: http://search.cpan.org/dist/Plack-Middleware-Throttle/
diff --git a/www/p5-Plack-Middleware-Throttle/pkg-plist b/www/p5-Plack-Middleware-Throttle/pkg-plist
new file mode 100644
index 000000000000..02b7a2aa3468
--- /dev/null
+++ b/www/p5-Plack-Middleware-Throttle/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Middleware/Throttle/.packlist
+%%SITE_PERL%%/Plack/Middleware/Throttle.pm
+%%SITE_PERL%%/Plack/Middleware/Throttle/Backend/Hash.pm
+%%SITE_PERL%%/Plack/Middleware/Throttle/Daily.pm
+%%SITE_PERL%%/Plack/Middleware/Throttle/Hourly.pm
+%%SITE_PERL%%/Plack/Middleware/Throttle/Interval.pm
+%%SITE_PERL%%/Plack/Middleware/Throttle/Limiter.pm
+@dirrm %%SITE_PERL%%/Plack/Middleware/Throttle/Backend
+@dirrm %%SITE_PERL%%/Plack/Middleware/Throttle
+@dirrmtry %%SITE_PERL%%/Plack/Middleware
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Middleware/Throttle
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Middleware