aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2013-11-02 17:41:06 +0800
committerkuriyama <kuriyama@FreeBSD.org>2013-11-02 17:41:06 +0800
commit394be05e53c4bd65f5d0f2d8fb56f233c9971451 (patch)
tree277f4d7f3776dde04c9bd86a21dc16967c3bf405
parent4dae38d313c48befad70b736ad998d30f16b1019 (diff)
downloadfreebsd-ports-gnome-394be05e53c4bd65f5d0f2d8fb56f233c9971451.tar.gz
freebsd-ports-gnome-394be05e53c4bd65f5d0f2d8fb56f233c9971451.tar.zst
freebsd-ports-gnome-394be05e53c4bd65f5d0f2d8fb56f233c9971451.zip
This module is more or less a bunch of heuristics for determining if a
given path is a development tree root of some kind. This has many useful applications, notably ones that require behaviours for "installed" modules to be different to those that are still "in development" WWW: http://search.cpan.org/dist/Path-IsDev/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Path-IsDev/Makefile24
-rw-r--r--devel/p5-Path-IsDev/distinfo2
-rw-r--r--devel/p5-Path-IsDev/pkg-descr8
-rw-r--r--devel/p5-Path-IsDev/pkg-plist72
5 files changed, 107 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f6a8ed54870e..1b933c20a2fd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2516,6 +2516,7 @@
SUBDIR += p5-Path-Class-File-Lockable
SUBDIR += p5-Path-Dispatcher
SUBDIR += p5-Path-Dispatcher-Declarative
+ SUBDIR += p5-Path-IsDev
SUBDIR += p5-Path-Iterator-Rule
SUBDIR += p5-Path-Resource
SUBDIR += p5-Path-Tiny
diff --git a/devel/p5-Path-IsDev/Makefile b/devel/p5-Path-IsDev/Makefile
new file mode 100644
index 000000000000..15c9137d0705
--- /dev/null
+++ b/devel/p5-Path-IsDev/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= Path-IsDev
+PORTVERSION= 1.000000
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:KENTNL
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to determine if path resembles dev source tree
+
+RUN_DEPENDS= \
+ p5-Class-Tiny>=0.010:${PORTSDIR}/devel/p5-Class-Tiny \
+ p5-File-HomeDir>0:${PORTSDIR}/devel/p5-File-HomeDir \
+ p5-Module-Runtime>0:${PORTSDIR}/devel/p5-Module-Runtime \
+ p5-Role-Tiny>0:${PORTSDIR}/devel/p5-Role-Tiny \
+ p5-Sub-Exporter>0:${PORTSDIR}/devel/p5-Sub-Exporter
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= modbuild
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Path-IsDev/distinfo b/devel/p5-Path-IsDev/distinfo
new file mode 100644
index 000000000000..c8222cda3a39
--- /dev/null
+++ b/devel/p5-Path-IsDev/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Path-IsDev-1.000000.tar.gz) = c744afd5f6b389a0bb93b5b76d8c4b271e6af2428ba61a32dc28143ef0bb1aaa
+SIZE (Path-IsDev-1.000000.tar.gz) = 179963
diff --git a/devel/p5-Path-IsDev/pkg-descr b/devel/p5-Path-IsDev/pkg-descr
new file mode 100644
index 000000000000..c98830de4f05
--- /dev/null
+++ b/devel/p5-Path-IsDev/pkg-descr
@@ -0,0 +1,8 @@
+This module is more or less a bunch of heuristics for determining if a
+given path is a development tree root of some kind.
+
+This has many useful applications, notably ones that require
+behaviours for "installed" modules to be different to those that are
+still "in development"
+
+WWW: http://search.cpan.org/dist/Path-IsDev/
diff --git a/devel/p5-Path-IsDev/pkg-plist b/devel/p5-Path-IsDev/pkg-plist
new file mode 100644
index 000000000000..2e27d3f68a9f
--- /dev/null
+++ b/devel/p5-Path-IsDev/pkg-plist
@@ -0,0 +1,72 @@
+%%PERL5_MAN3%%/Path::IsDev.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Heuristic::Changelog.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Heuristic::DevDirMarker.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Heuristic::META.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Heuristic::MYMETA.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Heuristic::Makefile.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Heuristic::TestDir.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Heuristic::Tool::Dzil.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Heuristic::Tool::MakeMaker.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Heuristic::Tool::ModuleBuild.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Heuristic::VCS::Git.3.gz
+%%PERL5_MAN3%%/Path::IsDev::HeuristicSet::Basic.3.gz
+%%PERL5_MAN3%%/Path::IsDev::NegativeHeuristic::HomeDir.3.gz
+%%PERL5_MAN3%%/Path::IsDev::NegativeHeuristic::IsDev::IgnoreFile.3.gz
+%%PERL5_MAN3%%/Path::IsDev::NegativeHeuristic::PerlINC.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Object.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Result.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Role::Heuristic.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Role::HeuristicSet.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Role::HeuristicSet::Simple.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Role::Matcher::Child::BaseName::MatchRegexp.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Role::Matcher::Child::BaseName::MatchRegexp::File.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Role::Matcher::Child::Exists::Any.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Role::Matcher::Child::Exists::Any::Dir.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Role::Matcher::Child::Exists::Any::File.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Role::Matcher::FullPath::Is::Any.3.gz
+%%PERL5_MAN3%%/Path::IsDev::Role::NegativeHeuristic.3.gz
+%%SITE_PERL%%/Path/IsDev.pm
+%%SITE_PERL%%/Path/IsDev/Heuristic/Changelog.pm
+%%SITE_PERL%%/Path/IsDev/Heuristic/DevDirMarker.pm
+%%SITE_PERL%%/Path/IsDev/Heuristic/META.pm
+%%SITE_PERL%%/Path/IsDev/Heuristic/MYMETA.pm
+%%SITE_PERL%%/Path/IsDev/Heuristic/Makefile.pm
+%%SITE_PERL%%/Path/IsDev/Heuristic/TestDir.pm
+%%SITE_PERL%%/Path/IsDev/Heuristic/Tool/Dzil.pm
+%%SITE_PERL%%/Path/IsDev/Heuristic/Tool/MakeMaker.pm
+%%SITE_PERL%%/Path/IsDev/Heuristic/Tool/ModuleBuild.pm
+%%SITE_PERL%%/Path/IsDev/Heuristic/VCS/Git.pm
+%%SITE_PERL%%/Path/IsDev/HeuristicSet/Basic.pm
+%%SITE_PERL%%/Path/IsDev/NegativeHeuristic/HomeDir.pm
+%%SITE_PERL%%/Path/IsDev/NegativeHeuristic/IsDev/IgnoreFile.pm
+%%SITE_PERL%%/Path/IsDev/NegativeHeuristic/PerlINC.pm
+%%SITE_PERL%%/Path/IsDev/Object.pm
+%%SITE_PERL%%/Path/IsDev/Result.pm
+%%SITE_PERL%%/Path/IsDev/Role/Heuristic.pm
+%%SITE_PERL%%/Path/IsDev/Role/HeuristicSet.pm
+%%SITE_PERL%%/Path/IsDev/Role/HeuristicSet/Simple.pm
+%%SITE_PERL%%/Path/IsDev/Role/Matcher/Child/BaseName/MatchRegexp.pm
+%%SITE_PERL%%/Path/IsDev/Role/Matcher/Child/BaseName/MatchRegexp/File.pm
+%%SITE_PERL%%/Path/IsDev/Role/Matcher/Child/Exists/Any.pm
+%%SITE_PERL%%/Path/IsDev/Role/Matcher/Child/Exists/Any/Dir.pm
+%%SITE_PERL%%/Path/IsDev/Role/Matcher/Child/Exists/Any/File.pm
+%%SITE_PERL%%/Path/IsDev/Role/Matcher/FullPath/Is/Any.pm
+%%SITE_PERL%%/Path/IsDev/Role/NegativeHeuristic.pm
+@dirrm %%SITE_PERL%%/Path/IsDev/Role/Matcher/FullPath/Is
+@dirrm %%SITE_PERL%%/Path/IsDev/Role/Matcher/FullPath
+@dirrm %%SITE_PERL%%/Path/IsDev/Role/Matcher/Child/Exists/Any
+@dirrm %%SITE_PERL%%/Path/IsDev/Role/Matcher/Child/Exists
+@dirrm %%SITE_PERL%%/Path/IsDev/Role/Matcher/Child/BaseName/MatchRegexp
+@dirrm %%SITE_PERL%%/Path/IsDev/Role/Matcher/Child/BaseName
+@dirrm %%SITE_PERL%%/Path/IsDev/Role/Matcher/Child
+@dirrm %%SITE_PERL%%/Path/IsDev/Role/Matcher
+@dirrm %%SITE_PERL%%/Path/IsDev/Role/HeuristicSet
+@dirrm %%SITE_PERL%%/Path/IsDev/Role
+@dirrm %%SITE_PERL%%/Path/IsDev/NegativeHeuristic/IsDev
+@dirrm %%SITE_PERL%%/Path/IsDev/NegativeHeuristic
+@dirrm %%SITE_PERL%%/Path/IsDev/HeuristicSet
+@dirrm %%SITE_PERL%%/Path/IsDev/Heuristic/VCS
+@dirrm %%SITE_PERL%%/Path/IsDev/Heuristic/Tool
+@dirrm %%SITE_PERL%%/Path/IsDev/Heuristic
+@dirrm %%SITE_PERL%%/Path/IsDev
+@dirrmtry %%SITE_PERL%%/Path