aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-02-14 12:38:17 +0800
committermarcus <marcus@FreeBSD.org>2004-02-14 12:38:17 +0800
commit3a2e6ab17d6f8a629a7949ebdcd85063e81952e7 (patch)
tree435ad904a5e89384c06515ac66233db77906a59a
parente6e99de914192d689fa09a357163efb32577b5ba (diff)
downloadfreebsd-ports-gnome-3a2e6ab17d6f8a629a7949ebdcd85063e81952e7.tar.gz
freebsd-ports-gnome-3a2e6ab17d6f8a629a7949ebdcd85063e81952e7.tar.zst
freebsd-ports-gnome-3a2e6ab17d6f8a629a7949ebdcd85063e81952e7.zip
Add ossp-uuid, a ISO-C API and command line utility for generating DCE 1.1
and ISO/IEC 11578:1996 compliant Universally Unique Identifiers (UUIDs). It supports DCE 1.1 variant UUIDs of version 1 (time and node based), version 3 (name based), and version 4 (random number based). PR: 62810 Submitted by: Kimura Fuyuki <fuyuki@nigredo.org>
-rw-r--r--misc/Makefile1
-rw-r--r--misc/ossp-uuid/Makefile25
-rw-r--r--misc/ossp-uuid/distinfo2
-rw-r--r--misc/ossp-uuid/pkg-descr7
-rw-r--r--misc/ossp-uuid/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 0eceedbcb55f..9b1c59fb2a32 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -265,6 +265,7 @@
SUBDIR += nwrite
SUBDIR += opencyc
SUBDIR += orville-write
+ SUBDIR += ossp-uuid
SUBDIR += p5-Array-Compare
SUBDIR += p5-Array-IntSpan
SUBDIR += p5-Array-PrintCols
diff --git a/misc/ossp-uuid/Makefile b/misc/ossp-uuid/Makefile
new file mode 100644
index 000000000000..9101739ecef0
--- /dev/null
+++ b/misc/ossp-uuid/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: OSSP uuid
+# Date created: 12 February 2004
+# Whom: Kimura Fuyuki <fuyuki@nigredo.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uuid
+PORTVERSION= 0.9.7
+CATEGORIES= misc devel
+MASTER_SITES= ftp://ftp.ossp.org/pkg/lib/${PORTNAME}/
+PKGNAMEPREFIX= ossp-
+
+MAINTAINER= fuyuki@nigredo.org
+COMMENT= An ISO-C API and CLI for generating Universally Unique Identifiers
+
+CONFLICTS= e2fsprogs-*
+
+USE_LIBTOOL_VER= 15
+INSTALLS_SHLIB= yes
+
+MAN1= uuid-config.1 uuid.1
+MAN3= uuid.3
+
+.include <bsd.port.mk>
diff --git a/misc/ossp-uuid/distinfo b/misc/ossp-uuid/distinfo
new file mode 100644
index 000000000000..e734abeb1f83
--- /dev/null
+++ b/misc/ossp-uuid/distinfo
@@ -0,0 +1,2 @@
+MD5 (uuid-0.9.7.tar.gz) = aaa5a57d462685003f41f39366bb475a
+SIZE (uuid-0.9.7.tar.gz) = 332641
diff --git a/misc/ossp-uuid/pkg-descr b/misc/ossp-uuid/pkg-descr
new file mode 100644
index 000000000000..2d91941c6806
--- /dev/null
+++ b/misc/ossp-uuid/pkg-descr
@@ -0,0 +1,7 @@
+OSSP uuid is a ISO-C application programming interface (API) and
+corresponding command line interface (CLI) for the generation of DCE
+1.1 and ISO/IEC 11578:1996 compliant Universally Unique Identifiers
+(UUID). It supports DCE 1.1 variant UUIDs of version 1 (time and node
+based), version 3 (name based) and version 4 (random number based).
+
+WWW: http://www.ossp.org/pkg/lib/uuid/
diff --git a/misc/ossp-uuid/pkg-plist b/misc/ossp-uuid/pkg-plist
new file mode 100644
index 000000000000..7e3f308dce6d
--- /dev/null
+++ b/misc/ossp-uuid/pkg-plist
@@ -0,0 +1,7 @@
+bin/uuid
+bin/uuid-config
+include/uuid.h
+lib/libuuid.a
+lib/libuuid.la
+lib/libuuid.so
+lib/libuuid.so.1