aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-17 19:54:10 +0800
committererwin <erwin@FreeBSD.org>2005-12-17 19:54:10 +0800
commit3b315bc69ffb23ca4fc259eec63201c8d698d181 (patch)
treeb32e0106b2ec42a0236da7afeeeca644a57ab1c6
parent441ad42a3b9f6a0d95e2db2cada679aadfafc745 (diff)
downloadfreebsd-ports-gnome-3b315bc69ffb23ca4fc259eec63201c8d698d181.tar.gz
freebsd-ports-gnome-3b315bc69ffb23ca4fc259eec63201c8d698d181.tar.zst
freebsd-ports-gnome-3b315bc69ffb23ca4fc259eec63201c8d698d181.zip
A perl module that implements the tiger hash, which is believed to be secure
and runs quickly on 64-bit processors. WWW: http://search.cpan.org/dist/Digest-Tiger PR: ports/90537 Submitted by: Gabor Kovesdan
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Digest-Tiger/Makefile24
-rw-r--r--security/p5-Digest-Tiger/distinfo3
-rw-r--r--security/p5-Digest-Tiger/pkg-descr4
-rw-r--r--security/p5-Digest-Tiger/pkg-plist8
5 files changed, 40 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 6fbb608cfdb6..b851ae51d8d7 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -341,6 +341,7 @@
SUBDIR += p5-Digest-SHA1
SUBDIR += p5-Digest-SHA2
SUBDIR += p5-Digest-SHA256
+ SUBDIR += p5-Digest-Tiger
SUBDIR += p5-Digest-Whirlpool
SUBDIR += p5-Email-Obfuscate
SUBDIR += p5-File-Scan
diff --git a/security/p5-Digest-Tiger/Makefile b/security/p5-Digest-Tiger/Makefile
new file mode 100644
index 000000000000..1479b77b3889
--- /dev/null
+++ b/security/p5-Digest-Tiger/Makefile
@@ -0,0 +1,24 @@
+# Ports collection Makefile for: p5-Digest-Tiger
+# Date created: 17 Dec 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Digest-Tiger
+PORTVERSION= 0.02
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for Tiger hash algorithm
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::Tiger.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Digest-Tiger/distinfo b/security/p5-Digest-Tiger/distinfo
new file mode 100644
index 000000000000..13fb6c0d93c3
--- /dev/null
+++ b/security/p5-Digest-Tiger/distinfo
@@ -0,0 +1,3 @@
+MD5 (Digest-Tiger-0.02.tar.gz) = f72ea5b048b87300f5c906ecc3fb436e
+SHA256 (Digest-Tiger-0.02.tar.gz) = 998de6f43ddd95a9c6bed3cd534ecdce4c8d8ca5bec182e7a69fd92257e16dbf
+SIZE (Digest-Tiger-0.02.tar.gz) = 19872
diff --git a/security/p5-Digest-Tiger/pkg-descr b/security/p5-Digest-Tiger/pkg-descr
new file mode 100644
index 000000000000..a9d0e361ea0f
--- /dev/null
+++ b/security/p5-Digest-Tiger/pkg-descr
@@ -0,0 +1,4 @@
+A perl module that implements the tiger hash, which is believed to be secure
+and runs quickly on 64-bit processors.
+
+WWW: http://search.cpan.org/dist/Digest-Tiger
diff --git a/security/p5-Digest-Tiger/pkg-plist b/security/p5-Digest-Tiger/pkg-plist
new file mode 100644
index 000000000000..c11e6a33c704
--- /dev/null
+++ b/security/p5-Digest-Tiger/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Digest/Tiger.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Tiger/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Tiger/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Tiger/Tiger.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Tiger/Tiger.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Tiger
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Digest/ 2>/dev/null || true