aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortrasz <trasz@FreeBSD.org>2009-01-13 05:30:36 +0800
committertrasz <trasz@FreeBSD.org>2009-01-13 05:30:36 +0800
commit3b47ba1d1eb4d014a32c93b7d8e22f76a4374906 (patch)
treeddcba1a72352036fadc531b74143a9459b2dbfaf
parent5a13654ebc9adba76ff0e569ceda7c16bf67fb3a (diff)
downloadfreebsd-ports-gnome-3b47ba1d1eb4d014a32c93b7d8e22f76a4374906.tar.gz
freebsd-ports-gnome-3b47ba1d1eb4d014a32c93b7d8e22f76a4374906.tar.zst
freebsd-ports-gnome-3b47ba1d1eb4d014a32c93b7d8e22f76a4374906.zip
Remove dependency on ports version of libpcap; it's no longer needed
and causes build problems for qemu-devel. Submitted by: David O'Brien <obrien@FreeBSD.org> (slightly modified)
-rw-r--r--emulators/simh/Makefile11
-rw-r--r--emulators/simh/files/patch-makefile10
2 files changed, 9 insertions, 12 deletions
diff --git a/emulators/simh/Makefile b/emulators/simh/Makefile
index ce649a96960a..f55edd59797e 100644
--- a/emulators/simh/Makefile
+++ b/emulators/simh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= simh
PORTVERSION= 3.8.0
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://simh.trailing-edge.com/sources/
DISTNAME= ${PORTNAME}v38-0
@@ -18,10 +19,9 @@ USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -qoa
USE_GMAKE= yes
MAKEFILE= makefile
+MAKE_ENV= USE_NETWORK=1
NO_WRKSUBDIR= yes
-OPTIONS= NETWORK "Enable Sim_Ether module (and ports libpcap)" on
-
BIN_FILES= altair altairz80 gri h316 hp2100 i1401 i1620 i7094 ibm1130 \
id16 id32 lgp nova pdp1 pdp10 pdp11 pdp15 pdp4 pdp7 pdp8 pdp9 \
s3 sds vax vax780
@@ -35,13 +35,6 @@ SUB_FILES+= pkg-message
.include <bsd.port.pre.mk>
-# XXX How do we know that libpcap.a is really the correct >0.9.x version?!
-.if defined (WITH_NETWORK)
-RUN_DEPENDS= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
-BUILD_DEPENDS= ${RUN_DEPENDS}
-MAKE_ENV= USE_NETWORK=1
-.endif
-
pre-patch:
@${MKDIR} ${WRKSRC}/BIN
diff --git a/emulators/simh/files/patch-makefile b/emulators/simh/files/patch-makefile
index 66343f2b6806..cf2ad70c1a2e 100644
--- a/emulators/simh/files/patch-makefile
+++ b/emulators/simh/files/patch-makefile
@@ -1,6 +1,6 @@
--- makefile.orig 2008-06-06 15:00:46.000000000 +0200
-+++ makefile 2008-07-22 23:16:54.000000000 +0200
-@@ -9,10 +9,10 @@
++++ makefile 2009-01-12 21:12:48.000000000 +0100
+@@ -9,13 +9,13 @@
ifneq (,$(findstring darwin,$(OSTYPE)))
OS_CCDEFS = -D_GNU_SOURCE
else
@@ -12,4 +12,8 @@
+ CC += ${CFLAGS} $(OS_CCDEFS) -I .
ifeq ($(USE_NETWORK),)
else
- NETWORK_OPT = -DUSE_NETWORK -isystem /usr/local/include /usr/local/lib/libpcap.a
+- NETWORK_OPT = -DUSE_NETWORK -isystem /usr/local/include /usr/local/lib/libpcap.a
++ NETWORK_OPT = -DUSE_NETWORK -lpcap
+ endif
+ else
+ #Win32 Environments