aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-12-06 23:33:01 +0800
committermiwi <miwi@FreeBSD.org>2008-12-06 23:33:01 +0800
commit3d489b46e89c1781da2e08553096b80b58d6fe76 (patch)
treeb3b642e52e63c7872946564b6dcbded02a529cba
parentf01597247b3084ab39a5cebba6b240a6385cbea4 (diff)
downloadfreebsd-ports-gnome-3d489b46e89c1781da2e08553096b80b58d6fe76.tar.gz
freebsd-ports-gnome-3d489b46e89c1781da2e08553096b80b58d6fe76.tar.zst
freebsd-ports-gnome-3d489b46e89c1781da2e08553096b80b58d6fe76.zip
A UTF8 layer for IO, ByteStrings and Strings. The utf8-string package provides
operations for encoding UTF8 strings to Word8 lists and back, and for reading and writing UTF8 without truncation. WWW: http://github.com/glguy/utf8-string/ PR: ports/129427 Submitted by: Samy Al Bahra <sbahra at kerneled.org>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/hs-utf8-string/Makefile37
-rw-r--r--textproc/hs-utf8-string/distinfo3
-rw-r--r--textproc/hs-utf8-string/pkg-descr5
-rw-r--r--textproc/hs-utf8-string/pkg-plist26
5 files changed, 72 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 7e2ccf027bc1..4ea815e25ede 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -208,6 +208,7 @@
SUBDIR += hs-bytestring-csv
SUBDIR += hs-haxml
SUBDIR += hs-stringsearch
+ SUBDIR += hs-utf8-string
SUBDIR += hsb-aspell
SUBDIR += htdig
SUBDIR += html
diff --git a/textproc/hs-utf8-string/Makefile b/textproc/hs-utf8-string/Makefile
new file mode 100644
index 000000000000..b673bf48c9e6
--- /dev/null
+++ b/textproc/hs-utf8-string/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: utf8-string
+# Date created: December 4, 2008
+# Whom: Samy Al Bahra <sbahra@kerneled.org>
+#
+# $FreeBSD$
+
+PORTNAME= utf8-string
+PORTVERSION= 0.3.3
+CATEGORIES= textproc haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/ \
+ http://carte.kerneled.org/mirror/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= sbahra@kerneled.org
+COMMENT= Haskell UTF8 layer for IO, ByteStrings and Strings
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+CABAL= ${LOCALBASE}/bin/runghc Setup.lhs
+GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
+SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
+ PORTVERSION=${PORTVERSION} \
+ SUBDIR=${SUBDIR}
+
+do-configure:
+ cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+
+do-build:
+ cd ${WRKSRC} && ${CABAL} build && ${CABAL} register --gen-script
+
+do-install:
+ cd ${WRKSRC} && ${CABAL} install
+ ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${SUBDIR}/register.sh
+
+.include <bsd.port.mk>
diff --git a/textproc/hs-utf8-string/distinfo b/textproc/hs-utf8-string/distinfo
new file mode 100644
index 000000000000..ba275edfc233
--- /dev/null
+++ b/textproc/hs-utf8-string/distinfo
@@ -0,0 +1,3 @@
+MD5 (utf8-string-0.3.3.tar.gz) = f311e85aebccffb272ebf3bd49a28c8f
+SHA256 (utf8-string-0.3.3.tar.gz) = a327daab89cbe9d687f0b612422da0e032f8cb4174abcf058e583a94099b40a5
+SIZE (utf8-string-0.3.3.tar.gz) = 7821
diff --git a/textproc/hs-utf8-string/pkg-descr b/textproc/hs-utf8-string/pkg-descr
new file mode 100644
index 000000000000..6b405f5fc09d
--- /dev/null
+++ b/textproc/hs-utf8-string/pkg-descr
@@ -0,0 +1,5 @@
+A UTF8 layer for IO, ByteStrings and Strings. The utf8-string package provides
+operations for encoding UTF8 strings to Word8 lists and back, and for reading
+and writing UTF8 without truncation.
+
+WWW: http://github.com/glguy/utf8-string/
diff --git a/textproc/hs-utf8-string/pkg-plist b/textproc/hs-utf8-string/pkg-plist
new file mode 100644
index 000000000000..a6c2e12791b8
--- /dev/null
+++ b/textproc/hs-utf8-string/pkg-plist
@@ -0,0 +1,26 @@
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/libHSutf8-string-%%PORTVERSION%%.a
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/HSutf8-string-%%PORTVERSION%%.o
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Codec/Binary/UTF8/Generic.hi
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Codec/Binary/UTF8/String.hi
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/System/IO/UTF8.hi
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Data/ByteString/Lazy/UTF8.hi
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Data/ByteString/UTF8.hi
+%%SUBDIR%%/ghc-%%GHC_VERSION%%/Data/String/UTF8.hi
+%%SUBDIR%%/register.sh
+share/doc/utf8-string-%%PORTVERSION%%/LICENSE
+@dirrm share/doc/utf8-string-%%PORTVERSION%%
+@dirrm lib/utf8-string-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Data/ByteString/Lazy
+@dirrm lib/utf8-string-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Data/ByteString
+@dirrm lib/utf8-string-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Data/String
+@dirrm lib/utf8-string-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Data
+@dirrm lib/utf8-string-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/System/IO
+@dirrm lib/utf8-string-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/System
+@dirrm lib/utf8-string-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Codec/Binary/UTF8
+@dirrm lib/utf8-string-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Codec/Binary
+@dirrm lib/utf8-string-%%PORTVERSION%%/ghc-%%GHC_VERSION%%/Codec
+@dirrm lib/utf8-string-%%PORTVERSION%%/ghc-%%GHC_VERSION%%
+@dirrm lib/utf8-string-%%PORTVERSION%%
+@exec /bin/sh %D/%%SUBDIR%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister utf8-string
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old