aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-02-12 04:00:35 +0800
committerpi <pi@FreeBSD.org>2016-02-12 04:00:35 +0800
commit3db6adca004aa36600d3dc08fa91ee1d37c38093 (patch)
treea013deba9ea64680a8069376c7b9ccc219962037
parent190aec0b422e3bf047be42ff928fa378f8b06acd (diff)
downloadfreebsd-ports-gnome-3db6adca004aa36600d3dc08fa91ee1d37c38093.tar.gz
freebsd-ports-gnome-3db6adca004aa36600d3dc08fa91ee1d37c38093.tar.zst
freebsd-ports-gnome-3db6adca004aa36600d3dc08fa91ee1d37c38093.zip
databases/sqlite3: Enable one of the command line editing options
- The last update to sqlite3 disabled readline support - Now several variants can be selected. PR: 206944 Submitted by: Tobias Kortkamp <t@tobik.me> Approved by: Pavel Volkov <pavelivolkov@gmail.com> (maintainer)
-rw-r--r--databases/sqlite3/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/databases/sqlite3/Makefile b/databases/sqlite3/Makefile
index 144d9262f35b..b70f9e4dad01 100644
--- a/databases/sqlite3/Makefile
+++ b/databases/sqlite3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sqlite3
PORTVERSION= 3.10.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= https://www.sqlite.org/2016/ http://www2.sqlite.org/2016/ http://www3.sqlite.org/2016/
DISTNAME= sqlite-autoconf-${PORTVERSION:C/\.([[:digit:]])[[:>:]]/0\1/g:S/.//g}00
@@ -27,8 +27,8 @@ OPTIONS_DEFINE= FTS4 UPD_DEL_LIMIT URI URI_AUTHORITY SOUNDEX METADATA \
EXTENSION ARMOR STMT DBSTAT FTS5 JSON1 RBU \
LIKENOTBLOB STSHELL
OPTIONS_SINGLE= RAMT
-OPTIONS_RADIO= STAT RL
-OPTIONS_GROUP= UNICODE RTREEG
+OPTIONS_RADIO= STAT
+OPTIONS_GROUP= UNICODE RTREEG RL
UPD_DEL_LIMIT_DESC= ORDER BY and LIMIT on UPDATE and DELETE
URI_DESC= Enable use the URI filename
@@ -92,14 +92,17 @@ RTREEG_DESC= Index type for range queries
RTREE_DESC= Enable R*Tree module
RTREE_INT_DESC= Store 32-bit sig int (no float) coordinates
-OPTIONS_RADIO_RL= READLINES READLINEP EDITLINE
+OPTIONS_GROUP_RL= READLINES READLINEP EDITLINE
RL_DESC= Which command line editing library to use:
READLINES_DESC= the libreadline from system
READLINEP_DESC= the GNU libreadline from ports
EDITLINE_DESC= the BSD libedit from ports
+READLINES_PREVENTS= READLINEP EDITLINE
+READLINEP_PREVENTS= READLINES EDITLINE
+EDITLINE_PREVENTS= READLINES READLINEP
OPTIONS_DEFAULT= FTS4 URI METADATA SECURE_DELETE UNLOCK_NOTIFY THREADS \
- EXTENSION TS1 UNICODE61 RTREE DBSTAT STSHELL
+ EXTENSION TS1 UNICODE61 RTREE DBSTAT STSHELL READLINES
# SECURE_DELETE, UNLOCK_NOTIFY, DBSTAT (since 41.0) used by www/firefox et al.
# RTREE used by graphics/mapnik, databases/spatialite