aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-04 09:30:04 +0800
committeredwin <edwin@FreeBSD.org>2002-11-04 09:30:04 +0800
commit3eaf84074b8b9b8c7747d2a188c0795de859f5fe (patch)
tree8611e069b47a9f5d296cb046f6b775b8708e75f7
parenta6b2fb678bff4552c8629addef6e8f9ec1d023a9 (diff)
downloadfreebsd-ports-gnome-3eaf84074b8b9b8c7747d2a188c0795de859f5fe.tar.gz
freebsd-ports-gnome-3eaf84074b8b9b8c7747d2a188c0795de859f5fe.tar.zst
freebsd-ports-gnome-3eaf84074b8b9b8c7747d2a188c0795de859f5fe.zip
PERL -> REINPLACE
Noticed by: bento
-rw-r--r--security/audit/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/security/audit/Makefile b/security/audit/Makefile
index dc007af19a84..4f3733a0a280 100644
--- a/security/audit/Makefile
+++ b/security/audit/Makefile
@@ -24,6 +24,7 @@ LIB_DEPENDS+= pq.2:${PORTSDIR}/databases/postgresql7
WRKSRC= ${WRKDIR}/${PORTNAME}-v${PORTVERSION}beta
USE_GMAKE= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-audit-libdir=${PREFIX}/lib/alat
@@ -54,13 +55,14 @@ FIXPREFIX_CONF= src/include/audconf.h src/auditd/auditd.8
LIBVERSION= 1
post-patch:
- ${PERL} -pi -e "s@Linux@FreeBSD@g" ${WRKSRC}/configure
- (${FIND} ${WRKSRC}/src/modules -name Makefile.in -exec ${PERL} -pi -e \
+ ${REINPLACE_CMD} -e "s@Linux@FreeBSD@g" ${WRKSRC}/configure
+ (${FIND} ${WRKSRC}/src/modules -name Makefile.in -exec \
+ ${REINPLACE_CMD} -e \
"s@^LIB=(.*){VERSION}@SOVERSION=\t${LIBVERSION}\nLIB=\1\{SOVERSION\}@" {} \;)
- ${PERL} -pi -e "s@AUDIT_VERSION@\"${LIBVERSION}\"@g" \
+ ${REINPLACE_CMD} -e "s@AUDIT_VERSION@\"${LIBVERSION}\"@g" \
${WRKSRC}/src/lib/modules.c
.for f in ${FIXPREFIX_CONF}
- ${PERL} -pi -e "s@/etc/auditd.conf@${PREFIX}/etc/auditd.conf@g" \
+ ${REINPLACE_CMD} -e "s@/etc/auditd.conf@${PREFIX}/etc/auditd.conf@g" \
${WRKSRC}/${f}
.endfor