aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorultima <ultima@FreeBSD.org>2017-08-18 03:50:26 +0800
committerultima <ultima@FreeBSD.org>2017-08-18 03:50:26 +0800
commit41075c9557647398b49d9490891319222ce88cfb (patch)
treee8f93a800e8b5b980df2e38c30296e95f27b93bd
parent90416318b7e42d3b5e651ffe69aba015169d18d0 (diff)
downloadfreebsd-ports-gnome-41075c9557647398b49d9490891319222ce88cfb.tar.gz
freebsd-ports-gnome-41075c9557647398b49d9490891319222ce88cfb.tar.zst
freebsd-ports-gnome-41075c9557647398b49d9490891319222ce88cfb.zip
The Midi Matrix (Channel Filter) is a 3-in-1 filter plugin with a simple UI
enabling you to easily accomplish: * MIDI channel filtering (e.g. blocking of specific channels) * MIDI channel multiplication (e.g. send events from channel X to channels X, Y and Z) * MIDI channel rerouting (e.g send events from channel X to channel Y) * And any possible combination thereof WWW: http://open-music-kontrollers.ch/lv2/midi_matrix PR: 221344 Submitted by: Yuri Victorovich (maintainer) Reviewed by: matthew (mentor) Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D12060
-rw-r--r--audio/Makefile1
-rw-r--r--audio/midi-matrix-lv2/Makefile25
-rw-r--r--audio/midi-matrix-lv2/distinfo3
-rw-r--r--audio/midi-matrix-lv2/files/patch-pugl_pugl_pugl__x11.c11
-rw-r--r--audio/midi-matrix-lv2/pkg-descr9
-rw-r--r--audio/midi-matrix-lv2/pkg-plist6
6 files changed, 55 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 517e8dc254c8..f468c6ac3b9c 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -485,6 +485,7 @@
SUBDIR += mctoolame-encoder
SUBDIR += mda-lv2
SUBDIR += mhwaveedit
+ SUBDIR += midi-matrix-lv2
SUBDIR += midipp
SUBDIR += mikmod
SUBDIR += milkytracker
diff --git a/audio/midi-matrix-lv2/Makefile b/audio/midi-matrix-lv2/Makefile
new file mode 100644
index 000000000000..715b96e81f8d
--- /dev/null
+++ b/audio/midi-matrix-lv2/Makefile
@@ -0,0 +1,25 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= midi-matrix
+PORTVERSION= 0.20.0
+CATEGORIES= audio
+MASTER_SITES= https://gitlab.com/OpenMusicKontrollers/midi_matrix.lv2/repository/archive.tar.gz?ref=${PORTVERSION}&dummy=/
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= LV2 'Midi Matrix' plugin bundle: 'Channel Filter'
+
+LICENSE= ART20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+
+USES= cmake pkgconfig
+USE_XORG= x11 xext
+USE_GL= gl glu
+
+post-extract:
+ @${MV} ${WRKDIR}/midi_matrix* ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/audio/midi-matrix-lv2/distinfo b/audio/midi-matrix-lv2/distinfo
new file mode 100644
index 000000000000..9abe52c397ea
--- /dev/null
+++ b/audio/midi-matrix-lv2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1502216898
+SHA256 (midi-matrix-0.20.0.tar.gz) = 1ff8478d2610c4b216a02052bde24929a54d89af31eb0c1a3e7e1ff5d07b7980
+SIZE (midi-matrix-0.20.0.tar.gz) = 1719808
diff --git a/audio/midi-matrix-lv2/files/patch-pugl_pugl_pugl__x11.c b/audio/midi-matrix-lv2/files/patch-pugl_pugl_pugl__x11.c
new file mode 100644
index 000000000000..03e52a2b2d54
--- /dev/null
+++ b/audio/midi-matrix-lv2/files/patch-pugl_pugl_pugl__x11.c
@@ -0,0 +1,11 @@
+--- pugl/pugl/pugl_x11.c.orig 2017-05-16 21:46:21 UTC
++++ pugl/pugl/pugl_x11.c
+@@ -648,7 +648,7 @@ puglPasteFromClipboard(PuglView* view, s
+ if( (xevent.xselection.selection == impl->clipboard)
+ && (xevent.xselection.target == impl->utf8_string)
+ && (xevent.xselection.property == XA_PRIMARY) ) {
+- ulong nitems, rem;
++ uint32_t nitems, rem;
+ int format;
+ uint8_t* data;
+ Atom type;
diff --git a/audio/midi-matrix-lv2/pkg-descr b/audio/midi-matrix-lv2/pkg-descr
new file mode 100644
index 000000000000..8f00d58cb88d
--- /dev/null
+++ b/audio/midi-matrix-lv2/pkg-descr
@@ -0,0 +1,9 @@
+The Midi Matrix (Channel Filter) is a 3-in-1 filter plugin with a simple UI
+enabling you to easily accomplish:
+* MIDI channel filtering (e.g. blocking of specific channels)
+* MIDI channel multiplication (e.g. send events from channel X to channels
+ X, Y and Z)
+* MIDI channel rerouting (e.g send events from channel X to channel Y)
+* And any possible combination thereof
+
+WWW: http://open-music-kontrollers.ch/lv2/midi_matrix
diff --git a/audio/midi-matrix-lv2/pkg-plist b/audio/midi-matrix-lv2/pkg-plist
new file mode 100644
index 000000000000..e976bc87fd9b
--- /dev/null
+++ b/audio/midi-matrix-lv2/pkg-plist
@@ -0,0 +1,6 @@
+lib/lv2/midi_matrix.lv2/Cousine-Regular.ttf
+lib/lv2/midi_matrix.lv2/manifest.ttl
+lib/lv2/midi_matrix.lv2/midi_matrix.so
+lib/lv2/midi_matrix.lv2/midi_matrix.ttl
+lib/lv2/midi_matrix.lv2/midi_matrix_ui.so
+lib/lv2/midi_matrix.lv2/midi_matrix_ui.ttl