aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2016-12-17 04:30:31 +0800
committermandree <mandree@FreeBSD.org>2016-12-17 04:30:31 +0800
commit4119e6889200145bcea3743393f66d8c599d0722 (patch)
treede1b8b31b21eaa42ec9c049a31e89979cc9cccae
parent399f6c1fb43d01015fcd48f8df291ce5a6e67621 (diff)
downloadfreebsd-ports-gnome-4119e6889200145bcea3743393f66d8c599d0722.tar.gz
freebsd-ports-gnome-4119e6889200145bcea3743393f66d8c599d0722.tar.zst
freebsd-ports-gnome-4119e6889200145bcea3743393f66d8c599d0722.zip
Add new putty-nogtk port as alternative SSH implementation.
-rw-r--r--security/Makefile1
-rw-r--r--security/putty-nogtk/Makefile12
-rw-r--r--security/putty/Makefile2
3 files changed, 14 insertions, 1 deletions
diff --git a/security/Makefile b/security/Makefile
index 3d934ce1ddde..185c38348e84 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -822,6 +822,7 @@
SUBDIR += pulledpork
SUBDIR += pure-sfv
SUBDIR += putty
+ SUBDIR += putty-nogtk
SUBDIR += pvk
SUBDIR += pwauth
SUBDIR += pwman
diff --git a/security/putty-nogtk/Makefile b/security/putty-nogtk/Makefile
new file mode 100644
index 000000000000..df342de9462a
--- /dev/null
+++ b/security/putty-nogtk/Makefile
@@ -0,0 +1,12 @@
+# Created by: Matthias Andree <mandree@FreeBSD.org>
+# $FreeBSD$
+
+PKGNAMESUFFIX= -nogtk
+
+OPTIONS_EXCLUDE= GTK2
+
+CONFLICTS_INSTALL= pssh-[0-9]* putty-[0-9]*
+
+MASTERDIR= ${.CURDIR}/../../security/putty
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/putty/Makefile b/security/putty/Makefile
index 472f5f4bfad3..caa6fb7ba8f9 100644
--- a/security/putty/Makefile
+++ b/security/putty/Makefile
@@ -26,7 +26,7 @@ PLIST_FILES+= man/man1/plink.1.gz man/man1/pscp.1.gz man/man1/psftp.1.gz man/man
OPTIONS_DEFINE= GSSAPI GTK2
OPTIONS_DEFAULT=GSSAPI GTK2
-CONFLICTS= pssh-[0-9]*
+CONFLICTS_INSTALL?= pssh-[0-9]* putty-nogtk-[0-9]*
.include <bsd.port.options.mk>