aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlippe <lippe@FreeBSD.org>2013-07-09 05:28:28 +0800
committerlippe <lippe@FreeBSD.org>2013-07-09 05:28:28 +0800
commit413de41cc8501095ea7862329ffebe8ba88af7db (patch)
treee64fb41295d7562de98647cbbb78e4476a1a187b
parent0a42ef556e2b4e375f0d54dbd3b1aacaf07bfad5 (diff)
downloadfreebsd-ports-gnome-413de41cc8501095ea7862329ffebe8ba88af7db.tar.gz
freebsd-ports-gnome-413de41cc8501095ea7862329ffebe8ba88af7db.tar.zst
freebsd-ports-gnome-413de41cc8501095ea7862329ffebe8ba88af7db.zip
- Add OPTIONS to enable internal debugger
PR: ports/179924 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> Approved by: Tom Carrick <knyght@gmail.com> (maintainer)
-rw-r--r--emulators/dosbox/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/emulators/dosbox/Makefile b/emulators/dosbox/Makefile
index d76d9a7e5519..feb3db9178a8 100644
--- a/emulators/dosbox/Makefile
+++ b/emulators/dosbox/Makefile
@@ -27,8 +27,19 @@ DESKTOP_ENTRIES="DOSBox" "${COMMENT}" \
"" "dosbox" \
"System;Emulator;" "true"
+OPTIONS_RADIO= DEBUGGER
+OPTIONS_RADIO_DEBUGGER=DEBUGGER_ENABLE DEBUGGER_HEAVY
+DEBUGGER_ENABLE_DESC=Enable internal debugger
+DEBUGGER_HEAVY_DESC=Enable internal debugger with extra features
+
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MDEBUGGER_ENABLE}
+CONFIGURE_ARGS+= --enable-debug=yes
+.elif ${PORT_OPTIONS:MDEBUGGER_HEAVY}
+CONFIGURE_ARGS+= --enable-debug=heavy
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's#\/usr\/share\/doc\/dosbox#${DOCSDIR}#g' \
${WRKSRC}/docs/dosbox.1