aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-03-31 02:32:01 +0800
committerdinoex <dinoex@FreeBSD.org>2010-03-31 02:32:01 +0800
commit4314f2386aa6e298567179230dd42a63db4425aa (patch)
tree4484de8be04733e2bde05ebd28ed89ac4e1d5c6b
parenta355c72507c963cb5dad3f814ac04ba42d1fce36 (diff)
downloadfreebsd-ports-gnome-4314f2386aa6e298567179230dd42a63db4425aa.tar.gz
freebsd-ports-gnome-4314f2386aa6e298567179230dd42a63db4425aa.tar.zst
freebsd-ports-gnome-4314f2386aa6e298567179230dd42a63db4425aa.zip
- fix build for png-1.4.1
- fix build for jpeg8
-rw-r--r--games/ufoai/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index 5413b7771afe..82cce66915ab 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -63,6 +63,14 @@ CONFIGURE_ARGS+= --disable-ufo2map
PLIST_SUB+= UFO2MAP="@comment "
.endif
+# Resolve name collision with jpeg-8 amd API png
+post-patch:
+ ${REINPLACE_CMD} -e 's|jpeg_mem_src|local_jpeg_mem_src|' \
+ -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
+ -e 's|png_check_sig(PngFileBuffer.buffer, 8)|!png_sig_cmp(PngFileBuffer.buffer, 0, 8)|' \
+ ${WRKSRC}/src/renderer/r_image.c \
+ ${WRKSRC}/src/tools/ufo2map/common/imagelib.c
+
pre-install:
. for FILE in ${UFO_FILES}
@${ECHO} "#!/bin/sh" > ${WRKDIR}/${FILE}