aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-02-17 22:38:53 +0800
committergahr <gahr@FreeBSD.org>2014-02-17 22:38:53 +0800
commit43fee3656c65cd1ac325589ea19d704b0eb375a3 (patch)
tree9288c2290b57497f3187a9539394e28f54937fd8
parent65703f1ccba581dffd9aa142e727f52b26588a20 (diff)
downloadfreebsd-ports-gnome-43fee3656c65cd1ac325589ea19d704b0eb375a3.tar.gz
freebsd-ports-gnome-43fee3656c65cd1ac325589ea19d704b0eb375a3.tar.zst
freebsd-ports-gnome-43fee3656c65cd1ac325589ea19d704b0eb375a3.zip
- Convert to USES=gmake tk
- Convert to new LIB_DEPENDS format
-rw-r--r--devel/git/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 3dccd81c1839..5c8cda0f2888 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -188,7 +188,7 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV+= V=1
@@ -267,7 +267,7 @@ MAKE_ENV+= NO_ICONV=1
MAKE_ENV+= CURLDIR=${LOCALBASE}
BUILD_DEPENDS+= curl:${PORTSDIR}/ftp/curl
RUN_DEPENDS+= curl:${PORTSDIR}/ftp/curl
-LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS+= libexpat.so:${PORTSDIR}/textproc/expat2
PLIST_SUB+= CURL=""
.else
MAKE_ENV+= NO_CURL=1 \
@@ -285,7 +285,7 @@ PLIST_SUB+= HTMLDOCS="@comment "
.endif
.if ${PORT_OPTIONS:MGUI}
-USE_TK= 84+
+USES+= tk
.include "${PORTSDIR}/Mk/bsd.tcl.mk"
MAN1+= git-citool.1 \
git-gui.1 \