aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2004-11-09 22:08:54 +0800
committerskv <skv@FreeBSD.org>2004-11-09 22:08:54 +0800
commit440d8c309c836090b38e2ce9d7cdb3662c92610d (patch)
tree8f1c13b0fdcd5796924f412df21231d6656a3b29
parent8ad96e774c7718de154ccc16d21dd07df844bb46 (diff)
downloadfreebsd-ports-gnome-440d8c309c836090b38e2ce9d7cdb3662c92610d.tar.gz
freebsd-ports-gnome-440d8c309c836090b38e2ce9d7cdb3662c92610d.tar.zst
freebsd-ports-gnome-440d8c309c836090b38e2ce9d7cdb3662c92610d.zip
Add "pkg-install".
-rw-r--r--textproc/p5-XML-LibXML/Makefile8
-rw-r--r--textproc/p5-XML-LibXML/pkg-descr3
-rw-r--r--textproc/p5-XML-LibXML/pkg-install5
3 files changed, 10 insertions, 6 deletions
diff --git a/textproc/p5-XML-LibXML/Makefile b/textproc/p5-XML-LibXML/Makefile
index 47d5ac99050e..08aeb5a21520 100644
--- a/textproc/p5-XML-LibXML/Makefile
+++ b/textproc/p5-XML-LibXML/Makefile
@@ -7,6 +7,7 @@
PORTNAME= XML-LibXML
PORTVERSION= 1.58
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML/PHISH
@@ -24,6 +25,8 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
CONFIGURE_ENV= XMLPREFIX=${LOCALBASE}
+PKGDEINSTALL= ${PKGINSTALL}
+
MAN3= XML::LibXML.3 XML::LibXML::Attr.3 XML::LibXML::Boolean.3 \
XML::LibXML::CDATASection.3 XML::LibXML::Comment.3 \
XML::LibXML::DOM.3 XML::LibXML::Document.3 \
@@ -35,9 +38,8 @@ MAN3= XML::LibXML.3 XML::LibXML::Attr.3 XML::LibXML::Boolean.3 \
XML::LibXML::SAX::Builder.3 XML::LibXML::SAX::Generator.3 \
XML::LibXML::Text.3
-post-patch:
- @${PERL} -pi -e 's,(-MXML::SAX),-I${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH} \1,g' \
- ${WRKSRC}/Makefile.PL
+post-install:
+ @PKG_PREFIX=${PREFIX} ${PERL} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.pre.mk>
diff --git a/textproc/p5-XML-LibXML/pkg-descr b/textproc/p5-XML-LibXML/pkg-descr
index a9927bd9851e..3d742b4878da 100644
--- a/textproc/p5-XML-LibXML/pkg-descr
+++ b/textproc/p5-XML-LibXML/pkg-descr
@@ -4,6 +4,3 @@ XML::XPath-like findnodes() interface, providing access to the XPath API
in libxml2.
WWW: http://search.cpan.org/dist/XML-LibXML/
-
--- Sergey Skvortsov
-skv@FreeBSD.org
diff --git a/textproc/p5-XML-LibXML/pkg-install b/textproc/p5-XML-LibXML/pkg-install
new file mode 100644
index 000000000000..a6e6bdad8455
--- /dev/null
+++ b/textproc/p5-XML-LibXML/pkg-install
@@ -0,0 +1,5 @@
+#!/usr/bin/perl
+exit unless $ARGV[1]=~ /^(DE|POST\-)INSTALL$/;
+$action=(($1 eq 'DE')?'remove':'add').'_parser';
+eval "use XML::SAX;"; exit(-1) if $@;
+XML::SAX->$action('XML::LibXML::SAX'.$_)->save_parsers() for('::Parser', '');