aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-10-07 06:19:27 +0800
committermarino <marino@FreeBSD.org>2013-10-07 06:19:27 +0800
commit4481fe035d4e8d94c09ba390c4fcd57bb5abf646 (patch)
tree2ede4cbf06d4883cdc65fa1b3a6d7d6fcafbcf87
parentdd64b460ee4b97c05ea096a83aaa962204e6aefe (diff)
downloadfreebsd-ports-gnome-4481fe035d4e8d94c09ba390c4fcd57bb5abf646.tar.gz
freebsd-ports-gnome-4481fe035d4e8d94c09ba390c4fcd57bb5abf646.tar.zst
freebsd-ports-gnome-4481fe035d4e8d94c09ba390c4fcd57bb5abf646.zip
Remove verbose flag from install command of three unmaintained ports
It appears that the -v option (verbose) is handled slightly differently on DragonFly. FreeBSD appears to be intolerant of where it appears in the command line while the DragonFly version of "install" insists that it appear in the early group of options. In any case, these three ports may be the only ones in the entire ports collection to use -v switch with ${INSTALL_DATA}, so for the sake of compatibility and consistency, it is being removed from these unmaintained ports which also local patches to be removed from DPorts.
-rw-r--r--dns/dnsproxy/Makefile4
-rw-r--r--net-im/jabber-pyicq/Makefile4
-rw-r--r--net-im/jabber-pymsn/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/dns/dnsproxy/Makefile b/dns/dnsproxy/Makefile
index a7d3c6d5976c..d2826c2c428c 100644
--- a/dns/dnsproxy/Makefile
+++ b/dns/dnsproxy/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= dns
MASTER_SITES= http://www.wolfermann.org/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A proxy for DNS queries
+COMMENT= proxy for DNS queries
BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.so:${PORTSDIR}/devel/libevent
@@ -28,7 +28,7 @@ do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/dnsproxy ${PREFIX}/sbin
@${INSTALL_MAN} ${WRKSRC}/dnsproxy.1 ${MAN1PREFIX}/man/man1
@${MKDIR} ${ETCDIR}
- @${INSTALL_DATA} -v ${WRKSRC}/dnsproxy.conf ${ETCDIR}/dnsproxy.conf.sample
+ @${INSTALL_DATA} ${WRKSRC}/dnsproxy.conf ${ETCDIR}/dnsproxy.conf.sample
post-install:
${CAT} ${PKGMESSAGE}
diff --git a/net-im/jabber-pyicq/Makefile b/net-im/jabber-pyicq/Makefile
index 5fced97e6428..2c0b621d2c8b 100644
--- a/net-im/jabber-pyicq/Makefile
+++ b/net-im/jabber-pyicq/Makefile
@@ -113,9 +113,9 @@ do-install:
@${MKDIR} ${DOCSDIR}
. for portdoc in ${PORTDOCS}
@if [ -f ${WRKDIR}/${portdoc} ]; then \
- ${INSTALL_DATA} -v ${WRKDIR}/${portdoc} ${DOCSDIR}/; \
+ ${INSTALL_DATA} ${WRKDIR}/${portdoc} ${DOCSDIR}/; \
else \
- ${INSTALL_DATA} -v ${WRKSRC}/${portdoc} ${DOCSDIR}/; \
+ ${INSTALL_DATA} ${WRKSRC}/${portdoc} ${DOCSDIR}/; \
fi
. endfor
.endif
diff --git a/net-im/jabber-pymsn/Makefile b/net-im/jabber-pymsn/Makefile
index f3cfae1a4b01..939d4b4e5701 100644
--- a/net-im/jabber-pymsn/Makefile
+++ b/net-im/jabber-pymsn/Makefile
@@ -120,9 +120,9 @@ do-install:
@${MKDIR} ${DOCSDIR}
.for portdoc in ${PORTDOCS}
@if [ -f ${WRKDIR}/${portdoc} ]; then \
- ${INSTALL_DATA} -v ${WRKDIR}/${portdoc} ${DOCSDIR}/; \
+ ${INSTALL_DATA} ${WRKDIR}/${portdoc} ${DOCSDIR}/; \
else \
- ${INSTALL_DATA} -v ${WRKSRC}/${portdoc} ${DOCSDIR}/; \
+ ${INSTALL_DATA} ${WRKSRC}/${portdoc} ${DOCSDIR}/; \
fi
.endfor
.endif