aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2008-01-05 09:29:10 +0800
committerbms <bms@FreeBSD.org>2008-01-05 09:29:10 +0800
commit467b0d30859458aac2f94a4ee04f489a0380f6ba (patch)
treea94c3b2409f6e8e404e94d1b1c702a811d6e725c
parent8c9cbd6eb52dada1ce3974cb1bbef20b6f108e17 (diff)
downloadfreebsd-ports-gnome-467b0d30859458aac2f94a4ee04f489a0380f6ba.tar.gz
freebsd-ports-gnome-467b0d30859458aac2f94a4ee04f489a0380f6ba.tar.zst
freebsd-ports-gnome-467b0d30859458aac2f94a4ee04f489a0380f6ba.zip
Add new port urjtag, a more recently maintained version of openwince jtag
which can run on any platform supported by FreeBSD's ppi(4) driver and more.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/urjtag/Makefile43
-rw-r--r--devel/urjtag/distinfo3
-rw-r--r--devel/urjtag/files/patch-src__lib__fclock.c11
-rw-r--r--devel/urjtag/files/patch-src__svf__svf.c14
-rw-r--r--devel/urjtag/pkg-descr5
-rw-r--r--devel/urjtag/pkg-plist273
7 files changed, 350 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0aed7fd57e21..2b5daea82947 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2313,6 +2313,7 @@
SUBDIR += upnp
SUBDIR += upp
SUBDIR += uppaal
+ SUBDIR += urjtag
SUBDIR += ustl
SUBDIR += valgrind
SUBDIR += valgrind-snapshot
diff --git a/devel/urjtag/Makefile b/devel/urjtag/Makefile
new file mode 100644
index 000000000000..b5f3d92b96dc
--- /dev/null
+++ b/devel/urjtag/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: urjtag
+# Date created: 2008-01-05
+# Whom: Bruce M. Simpson
+#
+# $FreeBSD$
+#
+
+PORTNAME= urjtag
+PORTVERSION= 0.7
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=urjtag
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Extended utility to work with JTAG-aware boards
+
+BUILD_DEPENDS= ${OPENWINCE_INCLUDE_DEP}:${PORTSDIR}/devel/openwince-include
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS+= --without-libusb --without-libftdi --without-ftd2xx
+CONFIGURE_ENV+= CFLAGS=--std=c99
+
+OPENWINCE_INCLUDE=${LOCALBASE}/include/openwince
+OPENWINCE_INCLUDE_DEP=${OPENWINCE_INCLUDE}/common.h
+
+MAN1= jtag.1 bsdl2jtag.1
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libreadline.so.5)
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.endif
+
+post-extract:
+ @${REINPLACE_CMD} -E -e \
+ "s,/usr/local/include/openwince,${OPENWINCE_INCLUDE}," \
+ ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/devel/urjtag/distinfo b/devel/urjtag/distinfo
new file mode 100644
index 000000000000..44c128a21b25
--- /dev/null
+++ b/devel/urjtag/distinfo
@@ -0,0 +1,3 @@
+MD5 (urjtag-0.7.tar.bz2) = 29f4e27a2395dea05786b0570deb7779
+SHA256 (urjtag-0.7.tar.bz2) = a89f4967bef5d51428c2356d3ed3d9396f92c1d80f6cdbbaf57c4b98f738ac9d
+SIZE (urjtag-0.7.tar.bz2) = 857261
diff --git a/devel/urjtag/files/patch-src__lib__fclock.c b/devel/urjtag/files/patch-src__lib__fclock.c
new file mode 100644
index 000000000000..aa2829f78ae2
--- /dev/null
+++ b/devel/urjtag/files/patch-src__lib__fclock.c
@@ -0,0 +1,11 @@
+--- src/lib/fclock.c.orig Sat Jan 5 00:50:24 2008
++++ src/lib/fclock.c Sat Jan 5 00:51:05 2008
+@@ -66,7 +66,7 @@
+ }
+ result = (long double)c/CLK_TCK;
+ #endif
+- assert(isnormal(result));
++ /*assert(isnormal(result));*/
+ assert(result > 0);
+ return result;
+ }
diff --git a/devel/urjtag/files/patch-src__svf__svf.c b/devel/urjtag/files/patch-src__svf__svf.c
new file mode 100644
index 000000000000..60f8d10fcbc2
--- /dev/null
+++ b/devel/urjtag/files/patch-src__svf__svf.c
@@ -0,0 +1,14 @@
+--- src/svf/svf.c.orig Sun Dec 23 15:10:23 2007
++++ src/svf/svf.c Sat Jan 5 00:46:34 2008
+@@ -690,7 +690,11 @@
+ unsigned max_time;
+
+ sa.sa_handler = sigalrm_handler;
++#ifdef __FreeBSD__
++ sa.sa_flags = SA_RESETHAND;
++#else
+ sa.sa_flags = SA_ONESHOT;
++#endif
+ sigemptyset(&sa.sa_mask);
+ if (sigaction(SIGALRM, &sa, NULL) != 0) {
+ perror("sigaction");
diff --git a/devel/urjtag/pkg-descr b/devel/urjtag/pkg-descr
new file mode 100644
index 000000000000..319f659dd02b
--- /dev/null
+++ b/devel/urjtag/pkg-descr
@@ -0,0 +1,5 @@
+UrJTAG aims to create an enhanced, modern tool for communicating over
+JTAG with flash chips, CPUs, and many more. It takes on the well proven
+openwince jtag tools code.
+
+WWW: http://urjtag.org/
diff --git a/devel/urjtag/pkg-plist b/devel/urjtag/pkg-plist
new file mode 100644
index 000000000000..0f7edbcd08e9
--- /dev/null
+++ b/devel/urjtag/pkg-plist
@@ -0,0 +1,273 @@
+bin/bsdl2jtag
+bin/jtag
+%%DATADIR%%/MANUFACTURERS
+%%DATADIR%%/admtek/adm5120/adm5120
+%%DATADIR%%/altera/PARTS
+%%DATADIR%%/altera/ep1c12/STEPPINGS
+%%DATADIR%%/altera/ep1c12/ep1c12
+%%DATADIR%%/altera/ep1c12/f256
+%%DATADIR%%/altera/ep1c12/f324
+%%DATADIR%%/altera/ep1c12/q240
+%%DATADIR%%/altera/ep1c20f400/STEPPINGS
+%%DATADIR%%/altera/ep1c20f400/ep1c20f400
+%%DATADIR%%/altera/ep1c6q240/ep1c6q240
+%%DATADIR%%/altera/epm3064a/STEPPINGS
+%%DATADIR%%/altera/epm3064a/epm3064a
+%%DATADIR%%/altera/epm3064a/l44
+%%DATADIR%%/altera/epm3064a/t100
+%%DATADIR%%/altera/epm3064a/t44
+%%DATADIR%%/altera/epm7128aetc100/STEPPINGS
+%%DATADIR%%/altera/epm7128aetc100/epm7128aetc100
+%%DATADIR%%/analog/bf533/STEPPINGS
+%%DATADIR%%/analog/bf533/bf533
+%%DATADIR%%/analog/PARTS
+%%DATADIR%%/analog/sharc21065l/STEPPINGS
+%%DATADIR%%/analog/sharc21065l/sharc21065l
+%%DATADIR%%/atheros/ar2312/ar2312
+%%DATADIR%%/atmel/PARTS
+%%DATADIR%%/atmel/atmega128/STEPPINGS
+%%DATADIR%%/atmel/atmega128/atmega128
+%%DATADIR%%/atmel/at91sam7s256/STEPPINGS
+%%DATADIR%%/atmel/at91sam7s256/at91sam7s_tq64v0
+%%DATADIR%%/atmel/at91sam7s256/at91sam7s_tq48v0
+%%DATADIR%%/brecis/msp2006/STEPPINGS
+%%DATADIR%%/brecis/msp2006/msp2006
+%%DATADIR%%/brecis/PARTS
+%%DATADIR%%/broadcom/PARTS
+%%DATADIR%%/broadcom/bcm1250/STEPPINGS
+%%DATADIR%%/broadcom/bcm1250/bcm1250
+%%DATADIR%%/broadcom/bcm3310/STEPPINGS
+%%DATADIR%%/broadcom/bcm3310/bcm3310
+%%DATADIR%%/broadcom/bcm4712/STEPPINGS
+%%DATADIR%%/broadcom/bcm4712/bcm4712
+%%DATADIR%%/broadcom/bcm5421s/STEPPINGS
+%%DATADIR%%/broadcom/bcm5421s/bcm5421s
+%%DATADIR%%/dec/PARTS
+%%DATADIR%%/dec/sa1100/STEPPINGS
+%%DATADIR%%/dec/sa1100/sa1100
+%%DATADIR%%/freescale/mpc5200/STEPPINGS
+%%DATADIR%%/freescale/mpc5200/mpc5200
+%%DATADIR%%/freescale/PARTS
+%%DATADIR%%/hitachi/PARTS
+%%DATADIR%%/hitachi/ar7300/STEPPINGS
+%%DATADIR%%/hitachi/ar7300/ar7300
+%%DATADIR%%/hitachi/hd64465/hd64465
+%%DATADIR%%/hitachi/sh7727/STEPPINGS
+%%DATADIR%%/hitachi/sh7727/sh7727
+%%DATADIR%%/hitachi/sh7729/STEPPINGS
+%%DATADIR%%/hitachi/sh7729/sh7729
+%%DATADIR%%/ibm/PARTS
+%%DATADIR%%/ibm/ppc440gx/STEPPINGS
+%%DATADIR%%/ibm/ppc440gx/ppc440gx
+%%DATADIR%%/ibm/ppc405ep/STEPPINGS
+%%DATADIR%%/ibm/ppc405ep/ppc405ep
+%%DATADIR%%/intel/PARTS
+%%DATADIR%%/intel/ixp425/STEPPINGS
+%%DATADIR%%/intel/ixp425/ixp425
+%%DATADIR%%/intel/pxa250/STEPPINGS
+%%DATADIR%%/intel/pxa250/pxa250
+%%DATADIR%%/intel/pxa250/pxa250c0
+%%DATADIR%%/intel/pxa270/STEPPINGS
+%%DATADIR%%/intel/pxa270/pxa270
+%%DATADIR%%/intel/sa1110/STEPPINGS
+%%DATADIR%%/intel/sa1110/sa1110
+%%DATADIR%%/lattice/PARTS
+%%DATADIR%%/lattice/lc4032v-tqfp48/STEPPINGS
+%%DATADIR%%/lattice/lc4032v-tqfp48/lc4032v-tqfp48
+%%DATADIR%%/lattice/lc4128c-tqfp100/STEPPINGS
+%%DATADIR%%/lattice/lc4128c-tqfp100/lc4128c-tqfp100
+%%DATADIR%%/lattice/m4a3-256.192-fpbga256/STEPPINGS
+%%DATADIR%%/lattice/m4a3-256.192-fpbga256/m4a3-256.192-fpbga256
+%%DATADIR%%/lattice/m4a3-64.32-tqfp48/STEPPINGS
+%%DATADIR%%/lattice/m4a3-64.32-tqfp48/m4a3-64.32-tqfp48
+%%DATADIR%%/lexra/PARTS
+%%DATADIR%%/lexra/lx5280/STEPPINGS
+%%DATADIR%%/lexra/lx5280/lx5280
+%%DATADIR%%/motorola/mpc8245/1.2
+%%DATADIR%%/philips/PARTS
+%%DATADIR%%/philips/xcr3128xl-cs144/STEPPINGS
+%%DATADIR%%/philips/xcr3128xl-cs144/xcr3128xl-cs144
+%%DATADIR%%/philips/xcr3128xl-vq100/STEPPINGS
+%%DATADIR%%/philips/xcr3128xl-vq100/xcr3128xl-vq100
+%%DATADIR%%/samsung/s3c4510b/s3c4510b
+%%DATADIR%%/sharp/lh7a400/STEPPINGS
+%%DATADIR%%/sharp/lh7a400/lh7a400
+%%DATADIR%%/sharp/PARTS
+%%DATADIR%%/toshiba/PARTS
+%%DATADIR%%/toshiba/tx4925/STEPPINGS
+%%DATADIR%%/toshiba/tx4925/tx4925
+%%DATADIR%%/toshiba/tx4926/STEPPINGS
+%%DATADIR%%/toshiba/tx4926/tx4926
+%%DATADIR%%/xilinx/PARTS
+%%DATADIR%%/xilinx/xc18v04pc44/xc18v04pc44
+%%DATADIR%%/xilinx/xc18v04pc44/STEPPINGS
+%%DATADIR%%/xilinx/xc2c256-tq144/STEPPINGS
+%%DATADIR%%/xilinx/xc2c256-tq144/xc2c256-tq144
+%%DATADIR%%/xilinx/xc2c256-vq100/STEPPINGS
+%%DATADIR%%/xilinx/xc2c256-vq100/xc2c256-vq100
+%%DATADIR%%/xilinx/xc2c64a-vq44/STEPPINGS
+%%DATADIR%%/xilinx/xc2c64a-vq44/xc2c64a-vq44
+%%DATADIR%%/xilinx/xc2s200e-pq208/STEPPINGS
+%%DATADIR%%/xilinx/xc2s200e-pq208/xc2s200e-pq208
+%%DATADIR%%/xilinx/xc2s300e/STEPPINGS
+%%DATADIR%%/xilinx/xc2s300e/xc2s300e
+%%DATADIR%%/xilinx/xc2s300e/pq208
+%%DATADIR%%/xilinx/xc2s300e/ft256
+%%DATADIR%%/xilinx/xc2s300e/fg456
+%%DATADIR%%/xilinx/xc3s1000/fg676
+%%DATADIR%%/xilinx/xc3s1000/xc3s1000
+%%DATADIR%%/xilinx/xc3s1000/fg320
+%%DATADIR%%/xilinx/xc3s1000/ft256
+%%DATADIR%%/xilinx/xc3s1000/STEPPINGS
+%%DATADIR%%/xilinx/xc3s1000/fg456
+%%DATADIR%%/xilinx/xc3s100e_die/xc3s100e_pq208
+%%DATADIR%%/xilinx/xc3s100e_die/xc3s100e_tq144
+%%DATADIR%%/xilinx/xc3s100e_die/xc3s100e_die
+%%DATADIR%%/xilinx/xc3s100e_die/STEPPINGS
+%%DATADIR%%/xilinx/xc3s100e_die/xc3s100e_vq100
+%%DATADIR%%/xilinx/xc3s1500/xc3s1500_fg456
+%%DATADIR%%/xilinx/xc3s1500/xc3s1500l_fg676
+%%DATADIR%%/xilinx/xc3s1500/xc3s1500l
+%%DATADIR%%/xilinx/xc3s1500/xc3s1500l_fg320
+%%DATADIR%%/xilinx/xc3s1500/xc3s1500_fg676
+%%DATADIR%%/xilinx/xc3s1500/xc3s1500
+%%DATADIR%%/xilinx/xc3s1500/xc3s1500_fg320
+%%DATADIR%%/xilinx/xc3s1500/STEPPINGS
+%%DATADIR%%/xilinx/xc3s1500/xc3s1500l_fg456
+%%DATADIR%%/xilinx/xc3s200/xc3s200_tq144
+%%DATADIR%%/xilinx/xc3s200/xc3s200
+%%DATADIR%%/xilinx/xc3s200/xc3s200_ft256
+%%DATADIR%%/xilinx/xc3s200/xc3s200_vq100
+%%DATADIR%%/xilinx/xc3s200/STEPPINGS
+%%DATADIR%%/xilinx/xc3s200/xc3s200_pq208
+%%DATADIR%%/xilinx/xc3s2000/xc3s2000_fg676
+%%DATADIR%%/xilinx/xc3s2000/xc3s2000
+%%DATADIR%%/xilinx/xc3s2000/xc3s2000l_fg900
+%%DATADIR%%/xilinx/xc3s2000/xc3s2000_fg900
+%%DATADIR%%/xilinx/xc3s2000/STEPPINGS
+%%DATADIR%%/xilinx/xc3s2000/xc3s2000_fg456
+%%DATADIR%%/xilinx/xc3s2000/xc3s2000l_fg676
+%%DATADIR%%/xilinx/xc3s2000/xc3s2000l
+%%DATADIR%%/xilinx/xc3s400/xc3s400_fg456
+%%DATADIR%%/xilinx/xc3s400/xc3s400_tq144
+%%DATADIR%%/xilinx/xc3s400/xc3s400
+%%DATADIR%%/xilinx/xc3s400/xc3s400_fg320
+%%DATADIR%%/xilinx/xc3s400/xc3s400_ft256
+%%DATADIR%%/xilinx/xc3s400/STEPPINGS
+%%DATADIR%%/xilinx/xc3s400/xc3s400_pq208
+%%DATADIR%%/xilinx/xc3s4000/xc3s4000l
+%%DATADIR%%/xilinx/xc3s4000/xc3s4000_fg676
+%%DATADIR%%/xilinx/xc3s4000/xc3s4000
+%%DATADIR%%/xilinx/xc3s4000/xc3s4000l_fg900
+%%DATADIR%%/xilinx/xc3s4000/xc3s4000_fg900
+%%DATADIR%%/xilinx/xc3s4000/xc3s4000l_fg1156
+%%DATADIR%%/xilinx/xc3s4000/STEPPINGS
+%%DATADIR%%/xilinx/xc3s4000/xc3s4000_fg1156
+%%DATADIR%%/xilinx/xc3s50/xc3s50_pq208
+%%DATADIR%%/xilinx/xc3s50/xc3s50_tq144
+%%DATADIR%%/xilinx/xc3s50/xc3s50
+%%DATADIR%%/xilinx/xc3s50/STEPPINGS
+%%DATADIR%%/xilinx/xc3s50/xc3s50_vq100
+%%DATADIR%%/xilinx/xc3s50/xc3s50_cp132
+%%DATADIR%%/xilinx/xc3s5000/xc3s5000
+%%DATADIR%%/xilinx/xc3s5000/xc3s5000_fg900
+%%DATADIR%%/xilinx/xc3s5000/STEPPINGS
+%%DATADIR%%/xilinx/xc3s5000/xc3s5000_fg1156
+%%DATADIR%%/xilinx/xc3s500e_fg320/xc3s500e_ft256
+%%DATADIR%%/xilinx/xc3s500e_fg320/xc3s500e_pq208
+%%DATADIR%%/xilinx/xc3s500e_fg320/xc3s500e_fg320
+%%DATADIR%%/xilinx/xc3s500e_fg320/STEPPINGS
+%%DATADIR%%/xilinx/xc9572xl_vq44/xc9572xl_vq44
+%%DATADIR%%/xilinx/xc9572xl_vq44/STEPPINGS
+%%DATADIR%%/xilinx/xcf04s/xcf04s
+%%DATADIR%%/xilinx/xcf04s/STEPPINGS
+%%DATADIR%%/xilinx/xcr3032xl-vq44/STEPPINGS
+%%DATADIR%%/xilinx/xcr3032xl-vq44/xcr3032xl-vq44
+%%DATADIR%%/xilinx/xcr3128xl-cs144/STEPPINGS
+%%DATADIR%%/xilinx/xcr3128xl-cs144/xcr3128xl-cs144
+%%DATADIR%%/xilinx/xcr3128xl-vq100/xcr3128xl-vq100
+%%DATADIR%%/xilinx/xcr3256xl-ft256/STEPPINGS
+%%DATADIR%%/xilinx/xcr3256xl-ft256/xcr3256xl-ft256
+@dirrm %%DATADIR%%/xilinx/xcr3256xl-ft256
+@dirrm %%DATADIR%%/xilinx/xcr3032xl-vq44
+@dirrm %%DATADIR%%/xilinx/xcr3128xl-vq100
+@dirrm %%DATADIR%%/xilinx/xcr3128xl-cs144
+@dirrm %%DATADIR%%/xilinx/xcf04s
+@dirrm %%DATADIR%%/xilinx/xc9572xl_vq44
+@dirrm %%DATADIR%%/xilinx/xc3s500e_fg320
+@dirrm %%DATADIR%%/xilinx/xc3s5000
+@dirrm %%DATADIR%%/xilinx/xc3s50
+@dirrm %%DATADIR%%/xilinx/xc3s4000
+@dirrm %%DATADIR%%/xilinx/xc3s400
+@dirrm %%DATADIR%%/xilinx/xc3s2000
+@dirrm %%DATADIR%%/xilinx/xc3s200
+@dirrm %%DATADIR%%/xilinx/xc3s1500
+@dirrm %%DATADIR%%/xilinx/xc3s100e_die
+@dirrm %%DATADIR%%/xilinx/xc3s1000
+@dirrm %%DATADIR%%/xilinx/xc2c64a-vq44
+@dirrm %%DATADIR%%/xilinx/xc2c256-vq100
+@dirrm %%DATADIR%%/xilinx/xc2s300e
+@dirrm %%DATADIR%%/xilinx/xc2s200e-pq208
+@dirrm %%DATADIR%%/xilinx/xc2c256-tq144
+@dirrm %%DATADIR%%/xilinx/xc18v04pc44
+@dirrm %%DATADIR%%/xilinx
+@dirrm %%DATADIR%%/toshiba/tx4926
+@dirrm %%DATADIR%%/toshiba/tx4925
+@dirrm %%DATADIR%%/toshiba
+@dirrm %%DATADIR%%/sharp/lh7a400
+@dirrm %%DATADIR%%/sharp
+@dirrm %%DATADIR%%/samsung/s3c4510b
+@dirrm %%DATADIR%%/samsung
+@dirrm %%DATADIR%%/philips/xcr3128xl-vq100
+@dirrm %%DATADIR%%/philips/xcr3128xl-cs144
+@dirrm %%DATADIR%%/philips
+@dirrm %%DATADIR%%/motorola/mpc8245
+@dirrm %%DATADIR%%/motorola
+@dirrm %%DATADIR%%/lexra/lx5280
+@dirrm %%DATADIR%%/lexra
+@dirrm %%DATADIR%%/lattice/m4a3-64.32-tqfp48
+@dirrm %%DATADIR%%/lattice/m4a3-256.192-fpbga256
+@dirrm %%DATADIR%%/lattice/lc4128c-tqfp100
+@dirrm %%DATADIR%%/lattice/lc4032v-tqfp48
+@dirrm %%DATADIR%%/lattice
+@dirrm %%DATADIR%%/intel/sa1110
+@dirrm %%DATADIR%%/intel/pxa270
+@dirrm %%DATADIR%%/intel/pxa250
+@dirrm %%DATADIR%%/intel/ixp425
+@dirrm %%DATADIR%%/intel
+@dirrm %%DATADIR%%/ibm/ppc440gx
+@dirrm %%DATADIR%%/ibm/ppc405ep
+@dirrm %%DATADIR%%/ibm
+@dirrm %%DATADIR%%/hitachi/sh7729
+@dirrm %%DATADIR%%/hitachi/sh7727
+@dirrm %%DATADIR%%/hitachi/hd64465
+@dirrm %%DATADIR%%/hitachi/ar7300
+@dirrm %%DATADIR%%/hitachi
+@dirrm %%DATADIR%%/freescale/mpc5200
+@dirrm %%DATADIR%%/freescale
+@dirrm %%DATADIR%%/dec/sa1100
+@dirrm %%DATADIR%%/dec
+@dirrm %%DATADIR%%/broadcom/bcm5421s
+@dirrm %%DATADIR%%/broadcom/bcm4712
+@dirrm %%DATADIR%%/broadcom/bcm3310
+@dirrm %%DATADIR%%/broadcom/bcm1250
+@dirrm %%DATADIR%%/broadcom
+@dirrm %%DATADIR%%/brecis/msp2006
+@dirrm %%DATADIR%%/brecis
+@dirrm %%DATADIR%%/atmel/at91sam7s256
+@dirrm %%DATADIR%%/atmel/atmega128
+@dirrm %%DATADIR%%/atmel
+@dirrm %%DATADIR%%/atheros/ar2312
+@dirrm %%DATADIR%%/atheros
+@dirrm %%DATADIR%%/analog/sharc21065l
+@dirrm %%DATADIR%%/analog/bf533
+@dirrm %%DATADIR%%/analog
+@dirrm %%DATADIR%%/altera/epm7128aetc100
+@dirrm %%DATADIR%%/altera/epm3064a
+@dirrm %%DATADIR%%/altera/ep1c6q240
+@dirrm %%DATADIR%%/altera/ep1c20f400
+@dirrm %%DATADIR%%/altera/ep1c12
+@dirrm %%DATADIR%%/altera
+@dirrm %%DATADIR%%/admtek/adm5120
+@dirrm %%DATADIR%%/admtek
+@dirrm %%DATADIR%%