aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-04-12 12:26:27 +0800
committerkris <kris@FreeBSD.org>2004-04-12 12:26:27 +0800
commit47f0dab7b119e8035b9e64a39052aea8dea00f3f (patch)
treec55a79a83dc1af1da4dc8d2fc6d528e791968315
parent9d4064635a992455656b4fdc108ddbcc03624087 (diff)
downloadfreebsd-ports-gnome-47f0dab7b119e8035b9e64a39052aea8dea00f3f.tar.gz
freebsd-ports-gnome-47f0dab7b119e8035b9e64a39052aea8dea00f3f.tar.zst
freebsd-ports-gnome-47f0dab7b119e8035b9e64a39052aea8dea00f3f.zip
BROKEN on sparc64: Does not compile
-rw-r--r--graphics/dore/Makefile8
-rw-r--r--lang/gcl/Makefile8
-rw-r--r--math/scilab/Makefile4
-rw-r--r--x11-toolkits/scintilla/Makefile8
4 files changed, 23 insertions, 5 deletions
diff --git a/graphics/dore/Makefile b/graphics/dore/Makefile
index d4524eb196d3..b2732413996a 100644
--- a/graphics/dore/Makefile
+++ b/graphics/dore/Makefile
@@ -24,6 +24,12 @@ EXTRACT_CMD= ${MKDIR} ${WRKSRC}; cd ${WRKSRC}; ${GZIP_CMD}
MAKEFILE= mk.stdx
MAKE_ENV= DORE_LOC=${WRKDIR}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
post-extract:
@${MKDIR} ${WRKSRC}/lib
@@ -33,4 +39,4 @@ post-patch:
pre-install:
@${MKDIR} ${PREFIX}/share/dore
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/gcl/Makefile b/lang/gcl/Makefile
index acf1dfab5d8e..60b5f841c388 100644
--- a/lang/gcl/Makefile
+++ b/lang/gcl/Makefile
@@ -44,8 +44,14 @@ INFO= gcl gcl-si gcl-tk
PLIST_SUB= GCL_VER=${PORTVERSION}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
pre-configure:
${RM} -f ${WRKSRC}/configure
${SED} -i '.PRE-SED' -e 's|@@CFLAGS@@|${CFLAGS}|' ${WRKSRC}/h/FreeBSD.defs
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 2af8a827a285..ef6f1b585b2c 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -46,8 +46,8 @@ MAKE_ENV= PVM_INCLUDE=${LOCALBASE}/include
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
-BROKEN= "Does not compile on alpha 5.x"
+.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102 || ${ARCH} == "sparc64"
+BROKEN= "Does not compile on alpha 5.x or sparc64"
.endif
post-patch:
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index fae990a841e4..67c7efffb494 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -32,6 +32,12 @@ USE_GNOME= gtk12
MAKE_ARGS= GTK1=yes
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= "Build fails on sparc64"
+.endif
+
do-install:
${MKDIR} ${PREFIX}/include/scintilla
${INSTALL_DATA} ${WRKSRC}/../include/*.h ${PREFIX}/include/scintilla
@@ -40,4 +46,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/../bin/libscintilla_lexers.so.1 ${PREFIX}/lib
${LN} -sf ${PREFIX}/lib/libscintilla_lexers.so.1 ${PREFIX}/lib/libscintilla_lexers.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>