aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-10-03 02:32:12 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-10-03 02:32:12 +0800
commit491b444df53060e021029adee51ceebebf75b5ba (patch)
tree132bf1ca0a268cdcee1eac0bd3cda23e5fb27001
parent23d59fe5b9c15ed17c01c6b7502f39e7d7c4949c (diff)
downloadfreebsd-ports-gnome-491b444df53060e021029adee51ceebebf75b5ba.tar.gz
freebsd-ports-gnome-491b444df53060e021029adee51ceebebf75b5ba.tar.zst
freebsd-ports-gnome-491b444df53060e021029adee51ceebebf75b5ba.zip
- Add p5-Excel-Writer-XLSX 0.26
The Excel::Writer::XLSX module can be used to create an Excel file in the 2007+ XLSX format. The XLSX format is the Office Open XML (OOXML) format used by Excel 2007 and later. Multiple worksheets can be added to a workbook and formatting can be applied to cells. Text, numbers, and formulas can be written to the cells. This module cannot, as yet, be used to write to an existing Excel XLSX file. WWW: http://search.cpan.org/dist/Excel-Writer-XLSX/
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Excel-Writer-XLSX/Makefile51
-rw-r--r--textproc/p5-Excel-Writer-XLSX/distinfo2
-rw-r--r--textproc/p5-Excel-Writer-XLSX/pkg-descr8
-rw-r--r--textproc/p5-Excel-Writer-XLSX/pkg-plist37
5 files changed, 99 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e7a3501b40d8..3b472429e2ae 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -494,6 +494,7 @@
SUBDIR += p5-DocSet
SUBDIR += p5-EBook-Tools
SUBDIR += p5-Excel-Template
+ SUBDIR += p5-Excel-Writer-XLSX
SUBDIR += p5-File-Inplace
SUBDIR += p5-Filter-Simple
SUBDIR += p5-FormValidator-Lite
diff --git a/textproc/p5-Excel-Writer-XLSX/Makefile b/textproc/p5-Excel-Writer-XLSX/Makefile
new file mode 100644
index 000000000000..909a063e7c2f
--- /dev/null
+++ b/textproc/p5-Excel-Writer-XLSX/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: p5-Excel-Writer-XLSX
+# Date created: 2011-10-02
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Excel-Writer-XLSX
+PORTVERSION= 0.26
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Create a new file in the Excel 2007+ XLSX format
+
+BUILD_DEPENDS= p5-Archive-Zip>=1.30:${PORTSDIR}/archivers/p5-Archive-Zip
+RUN_DEPENDS= p5-Archive-Zip>=1.30:${PORTSDIR}/archivers/p5-Archive-Zip
+
+PERL_CONFIGURE= yes
+
+MAN3= Excel::Writer::XLSX.3 \
+ Excel::Writer::XLSX::Chart.3 \
+ Excel::Writer::XLSX::Chart::Area.3 \
+ Excel::Writer::XLSX::Chart::Bar.3 \
+ Excel::Writer::XLSX::Chart::Column.3 \
+ Excel::Writer::XLSX::Chart::Line.3 \
+ Excel::Writer::XLSX::Chart::Pie.3 \
+ Excel::Writer::XLSX::Chart::Scatter.3 \
+ Excel::Writer::XLSX::Chart::Stock.3 \
+ Excel::Writer::XLSX::Chartsheet.3 \
+ Excel::Writer::XLSX::Drawing.3 \
+ Excel::Writer::XLSX::Examples.3 \
+ Excel::Writer::XLSX::Format.3 \
+ Excel::Writer::XLSX::Package::App.3 \
+ Excel::Writer::XLSX::Package::Comments.3 \
+ Excel::Writer::XLSX::Package::ContentTypes.3 \
+ Excel::Writer::XLSX::Package::Core.3 \
+ Excel::Writer::XLSX::Package::Packager.3 \
+ Excel::Writer::XLSX::Package::Relationships.3 \
+ Excel::Writer::XLSX::Package::SharedStrings.3 \
+ Excel::Writer::XLSX::Package::Styles.3 \
+ Excel::Writer::XLSX::Package::Theme.3 \
+ Excel::Writer::XLSX::Package::VML.3 \
+ Excel::Writer::XLSX::Package::XMLwriter.3 \
+ Excel::Writer::XLSX::Package::XMLwriterSimple.3 \
+ Excel::Writer::XLSX::Utility.3 \
+ Excel::Writer::XLSX::Workbook.3 \
+ Excel::Writer::XLSX::Worksheet.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Excel-Writer-XLSX/distinfo b/textproc/p5-Excel-Writer-XLSX/distinfo
new file mode 100644
index 000000000000..78f98d1f7c14
--- /dev/null
+++ b/textproc/p5-Excel-Writer-XLSX/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Excel-Writer-XLSX-0.26.tar.gz) = 230ffa977ffce42e9eb8a5c7cb65a1bd0d15bfce7bc8629d3820c92df8d4e742
+SIZE (Excel-Writer-XLSX-0.26.tar.gz) = 628022
diff --git a/textproc/p5-Excel-Writer-XLSX/pkg-descr b/textproc/p5-Excel-Writer-XLSX/pkg-descr
new file mode 100644
index 000000000000..a6dced534032
--- /dev/null
+++ b/textproc/p5-Excel-Writer-XLSX/pkg-descr
@@ -0,0 +1,8 @@
+The Excel::Writer::XLSX module can be used to create an Excel file in the 2007+
+XLSX format. The XLSX format is the Office Open XML (OOXML) format used by Excel
+2007 and later. Multiple worksheets can be added to a workbook and formatting
+can be applied to cells. Text, numbers, and formulas can be written to the
+cells. This module cannot, as yet, be used to write to an existing Excel XLSX
+file.
+
+WWW: http://search.cpan.org/dist/Excel-Writer-XLSX/
diff --git a/textproc/p5-Excel-Writer-XLSX/pkg-plist b/textproc/p5-Excel-Writer-XLSX/pkg-plist
new file mode 100644
index 000000000000..838a2ac5f77c
--- /dev/null
+++ b/textproc/p5-Excel-Writer-XLSX/pkg-plist
@@ -0,0 +1,37 @@
+%%SITE_PERL%%/Excel/Writer/XLSX.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Chart.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Chart/Area.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Chart/Bar.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Chart/Column.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Chart/Line.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Chart/Pie.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Chart/Scatter.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Chart/Stock.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Chartsheet.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Drawing.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Examples.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Format.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Package/App.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Package/Comments.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Package/ContentTypes.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Package/Core.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Package/Packager.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Package/Relationships.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Package/SharedStrings.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Package/Styles.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Package/Theme.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Package/VML.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Package/XMLwriter.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Package/XMLwriterSimple.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Utility.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Workbook.pm
+%%SITE_PERL%%/Excel/Writer/XLSX/Worksheet.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Excel/Writer/XLSX/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Excel/Writer/XLSX
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Excel/Writer
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Excel
+@dirrm %%SITE_PERL%%/Excel/Writer/XLSX/Package
+@dirrm %%SITE_PERL%%/Excel/Writer/XLSX/Chart
+@dirrm %%SITE_PERL%%/Excel/Writer/XLSX
+@dirrmtry %%SITE_PERL%%/Excel/Writer
+@dirrmtry %%SITE_PERL%%/Excel