aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-03 11:51:09 +0800
committermiwi <miwi@FreeBSD.org>2014-02-03 11:51:09 +0800
commit4b0d26ac69f351c78e24a22a842a6ad11b0cdbcb (patch)
tree034a934fb6ad416e3b3e0d1d9dd7a0718a951549
parent405e7dc7814360a2b237899d97fe4522c85a305d (diff)
downloadfreebsd-ports-gnome-4b0d26ac69f351c78e24a22a842a6ad11b0cdbcb.tar.gz
freebsd-ports-gnome-4b0d26ac69f351c78e24a22a842a6ad11b0cdbcb.tar.zst
freebsd-ports-gnome-4b0d26ac69f351c78e24a22a842a6ad11b0cdbcb.zip
- Stage support
-rw-r--r--textproc/py-libxslt/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/textproc/py-libxslt/Makefile b/textproc/py-libxslt/Makefile
index 9917d40c9184..a7280478cf5e 100644
--- a/textproc/py-libxslt/Makefile
+++ b/textproc/py-libxslt/Makefile
@@ -13,7 +13,8 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
-USE_GNOME= gnomehack lthack libxslt
+USES= pathfix
+USE_GNOME= lthack libxslt
USE_PYTHON= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
@@ -22,9 +23,8 @@ CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
DOCSDIR= ${PREFIX}/share/doc/py-libxslt
EXAMPLESDIR= ${PREFIX}/share/examples/py-libxslt
-NO_STAGE= yes
post-install:
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${STAGEDIR}${PYTHON_SITELIBDIR}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -l ${STAGEDIR}${PYTHON_SITELIBDIR}
.include "${MASTERDIR}/Makefile"