aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-04-15 12:50:23 +0800
committerflz <flz@FreeBSD.org>2005-04-15 12:50:23 +0800
commit4bf608e22c5c0daed4d88ac1ce3436026ce34236 (patch)
tree50a4d24e5630b0a8eaf129ee9491e923c1bebec1
parentc46e8c342f44e35f91adaadd026433ce798cb1da (diff)
downloadfreebsd-ports-gnome-4bf608e22c5c0daed4d88ac1ce3436026ce34236.tar.gz
freebsd-ports-gnome-4bf608e22c5c0daed4d88ac1ce3436026ce34236.tar.zst
freebsd-ports-gnome-4bf608e22c5c0daed4d88ac1ce3436026ce34236.zip
- Add py-twistedRunner, process management framework including an inetd
replacement. PR: ports/79931 Submitted by: Neal Nelson <neal@nelson.name>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-twistedRunner/Makefile29
-rw-r--r--devel/py-twistedRunner/distinfo2
-rw-r--r--devel/py-twistedRunner/pkg-descr5
-rw-r--r--devel/py-twistedRunner/pkg-plist21
5 files changed, 58 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e0c0abcf7920..ff1510204c13 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1315,6 +1315,7 @@
SUBDIR += py-tconfpy
SUBDIR += py-twisted
SUBDIR += py-twistedCore
+ SUBDIR += py-twistedRunner
SUBDIR += py-ui
SUBDIR += py-unit
SUBDIR += py-urwid
diff --git a/devel/py-twistedRunner/Makefile b/devel/py-twistedRunner/Makefile
new file mode 100644
index 000000000000..22ab1278147e
--- /dev/null
+++ b/devel/py-twistedRunner/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-twistedRunner
+# Date created: 14 April 2005
+# Whom: Neal Nelson <neal@nelson.name>
+#
+# $FreeBSD$
+#
+
+PORTNAME= twistedRunner
+PORTVERSION= 0.1.0
+CATEGORIES= devel net python
+MASTER_SITES= http://twistedmatrix.com/downloads/Runner/0.1/ \
+ http://tmrc.mit.edu/mirror/twisted/Runner/0.1/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= TwistedRunner-${PORTVERSION}
+
+MAINTAINER= neal@nelson.name
+COMMENT= Runner has process management, including an inetd replacement
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/twisted:${PORTSDIR}/devel/py-twistedCore
+
+WRKSRC= ${WRKDIR}/TwistedRunner-${PORTVERSION}
+
+USE_BZIP2= yes
+USE_PYTHON= 2.2+
+USE_PYDISTUTILS= yes
+
+PLIST_SUB+= S=${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}
+
+.include <bsd.port.mk>
diff --git a/devel/py-twistedRunner/distinfo b/devel/py-twistedRunner/distinfo
new file mode 100644
index 000000000000..624bc6ce48fa
--- /dev/null
+++ b/devel/py-twistedRunner/distinfo
@@ -0,0 +1,2 @@
+MD5 (TwistedRunner-0.1.0.tar.bz2) = 6829d0c85c6b4398f715f7a0f5e34e4b
+SIZE (TwistedRunner-0.1.0.tar.bz2) = 8089
diff --git a/devel/py-twistedRunner/pkg-descr b/devel/py-twistedRunner/pkg-descr
new file mode 100644
index 000000000000..05601d34e67d
--- /dev/null
+++ b/devel/py-twistedRunner/pkg-descr
@@ -0,0 +1,5 @@
+Twisted Runner has process management, including an inetd replacement.
+
+Twisted Lore is available under the MIT Free Software licence.
+
+WWW: http://twistedmatrix.com/
diff --git a/devel/py-twistedRunner/pkg-plist b/devel/py-twistedRunner/pkg-plist
new file mode 100644
index 000000000000..5a9130405c5e
--- /dev/null
+++ b/devel/py-twistedRunner/pkg-plist
@@ -0,0 +1,21 @@
+%%S%%/twisted/runner/__init__.py
+%%S%%/twisted/runner/__init__.pyc
+%%S%%/twisted/runner/__init__.pyo
+%%S%%/twisted/runner/inetd.py
+%%S%%/twisted/runner/inetd.pyc
+%%S%%/twisted/runner/inetd.pyo
+%%S%%/twisted/runner/inetdconf.py
+%%S%%/twisted/runner/inetdconf.pyc
+%%S%%/twisted/runner/inetdconf.pyo
+%%S%%/twisted/runner/inetdtap.py
+%%S%%/twisted/runner/inetdtap.pyc
+%%S%%/twisted/runner/inetdtap.pyo
+%%S%%/twisted/runner/portmap.c
+%%S%%/twisted/runner/portmap.so
+%%S%%/twisted/runner/procmon.py
+%%S%%/twisted/runner/procmon.pyc
+%%S%%/twisted/runner/procmon.pyo
+%%S%%/twisted/runner/procutils.py
+%%S%%/twisted/runner/procutils.pyc
+%%S%%/twisted/runner/procutils.pyo
+@dirrm %%S%%/twisted/runner