aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2006-01-24 00:40:28 +0800
committervd <vd@FreeBSD.org>2006-01-24 00:40:28 +0800
commit4e83490bb06fd3da7d07e0a2b519c6b8545d1c44 (patch)
tree4bb27da6751e2082b5fc598c4deff56f8ca0f5e7
parentbafcba56133f19d2763e74f34f6417bc66f64758 (diff)
downloadfreebsd-ports-gnome-4e83490bb06fd3da7d07e0a2b519c6b8545d1c44.tar.gz
freebsd-ports-gnome-4e83490bb06fd3da7d07e0a2b519c6b8545d1c44.tar.zst
freebsd-ports-gnome-4e83490bb06fd3da7d07e0a2b519c6b8545d1c44.zip
Add database options
PR: ports/92072 Submitted by: Roderick van Domburg <roderick@developer.nedforce.nl>, Jonathan Weiss <jw@innerewut.de> Approved by: Jonathan Weiss <jw@innerewut.de> (maintainer), garga (mentor)
-rw-r--r--databases/rubygem-activerecord/Makefile26
1 files changed, 23 insertions, 3 deletions
diff --git a/databases/rubygem-activerecord/Makefile b/databases/rubygem-activerecord/Makefile
index 2e801738b840..2a9350ddcc4b 100644
--- a/databases/rubygem-activerecord/Makefile
+++ b/databases/rubygem-activerecord/Makefile
@@ -6,17 +6,37 @@
PORTNAME= activerecord
PORTVERSION= 1.13.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases rubygems
+MASTER_SITES= http://rubyforge.org/frs/download.php/7641/
MAINTAINER= jw@innerewut.de
COMMENT= Object-relational mapping layer for Rails MVC Framework
-MASTER_SITES= http://rubyforge.org/frs/download.php/7641/
-
BUILD_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/activesupport-1.2.5.gemspec:${PORTSDIR}/devel/rubygem-activesupport
RUN_DEPENDS= ${BUILD_DEPENDS}
+OPTIONS= NATIVE_MYSQL "Use native MySQL bindings" Off\
+ NATIVE_POSTGRESQL "Use native PostgreSQL bindings" Off\
+ NATIVE_SQLITE3 "Use native SQLite3 bindings" Off
+OPTIONSFILE= ${PORT_DBDIR}/rubygem-${PORTNAME}/options
+
+# to get RUBY_SITEARCHLIBDIR
+USE_RUBY= yes
+
.include <bsd.port.pre.mk>
+
+.if defined(WITH_NATIVE_MYSQL)
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/mysql.so:${PORTSDIR}/databases/ruby-mysql
+.endif
+
+.if defined(WITH_NATIVE_POSTGRESQL)
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/postgres.so:${PORTSDIR}/databases/ruby-postgres
+.endif
+
+.if defined(WITH_NATIVE_SQLITE3)
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/sqlite3_api.so:${PORTSDIR}/databases/ruby-sqlite3
+.endif
+
.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
.include <bsd.port.post.mk>