aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-17 05:50:13 +0800
committermiwi <miwi@FreeBSD.org>2009-03-17 05:50:13 +0800
commit4f52f3dc4ce4df23857aee6a859d156a8d489455 (patch)
tree1ac3cfaba6da30f25f47cce5ed4966f8c20e476d
parentabe1eb4848ae791628e40557fd6505a015ddb821 (diff)
downloadfreebsd-ports-gnome-4f52f3dc4ce4df23857aee6a859d156a8d489455.tar.gz
freebsd-ports-gnome-4f52f3dc4ce4df23857aee6a859d156a8d489455.tar.zst
freebsd-ports-gnome-4f52f3dc4ce4df23857aee6a859d156a8d489455.zip
iniparse is a INI parser for Python which is:
- Compatiable with ConfigParser: Backward compatible implementations of ConfigParser, RawConfigParser, and SafeConfigParser are included that are API-compatible with the Python standard library. They pass all the unit tests in Python-2.4.4. - Preserves structure of INI files: Order of sections & options, indentation, comments, and blank lines are preserved as far as possible when data is updated. - More convenient: Values can be accessed using dotted notation (cfg.user.name), or using container syntax (cfg['user']['name']). It is very useful for config files that are updated both by users and by programs, since it is very disorienting for a user to have her config file completely rearranged whenever a program changes it. iniparse also allows making the order of entries in a config file significant, which is desirable in applications like image galleries. WWW: http://code.google.com/p/iniparse/ PR: ports/132687 Submitted by: Yi-Jheng Lin <yzlin at cs.nctu.edu.tw>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-iniparse/Makefile30
-rw-r--r--devel/py-iniparse/distinfo3
-rw-r--r--devel/py-iniparse/files/patch-setup.py15
-rw-r--r--devel/py-iniparse/pkg-descr22
-rw-r--r--devel/py-iniparse/pkg-plist14
6 files changed, 85 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index caa12ca76a00..4b5951f255a8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2275,6 +2275,7 @@
SUBDIR += py-icalendar
SUBDIR += py-ice
SUBDIR += py-icu
+ SUBDIR += py-iniparse
SUBDIR += py-instant
SUBDIR += py-ipaddr
SUBDIR += py-istring
diff --git a/devel/py-iniparse/Makefile b/devel/py-iniparse/Makefile
new file mode 100644
index 000000000000..7b7477c9984f
--- /dev/null
+++ b/devel/py-iniparse/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: py-iniparse
+# Date created: 2009-03-16
+# Whom: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iniparse
+PORTVERSION= 0.3.1
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+ CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yzlin@cs.nctu.edu.tw
+COMMENT= A better INI parser for Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PORTDOCS= Changelog README
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-iniparse/distinfo b/devel/py-iniparse/distinfo
new file mode 100644
index 000000000000..438243feb786
--- /dev/null
+++ b/devel/py-iniparse/distinfo
@@ -0,0 +1,3 @@
+MD5 (iniparse-0.3.1.tar.gz) = 94adcf1cf01e2a537491a18f2e9b7a7a
+SHA256 (iniparse-0.3.1.tar.gz) = ee4e2379e143a85f02207f46a3f7d47a2486fc0cbc123b7b59731c80ff31a3f5
+SIZE (iniparse-0.3.1.tar.gz) = 28476
diff --git a/devel/py-iniparse/files/patch-setup.py b/devel/py-iniparse/files/patch-setup.py
new file mode 100644
index 000000000000..c84006961ffe
--- /dev/null
+++ b/devel/py-iniparse/files/patch-setup.py
@@ -0,0 +1,15 @@
+--- setup.py.orig
++++ setup.py
+@@ -30,12 +30,5 @@
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ ],
+ packages = ['iniparse'],
+- data_files = [
+- ('share/doc/iniparse-%s' % VERSION, ['README', 'LICENSE-PSF',
+- 'LICENSE', 'Changelog',
+- 'html/index.html',
+- 'html/style.css',
+- ]),
+- ],
+ )
+
diff --git a/devel/py-iniparse/pkg-descr b/devel/py-iniparse/pkg-descr
new file mode 100644
index 000000000000..2e67a7086cb9
--- /dev/null
+++ b/devel/py-iniparse/pkg-descr
@@ -0,0 +1,22 @@
+iniparse is a INI parser for Python which is:
+ - Compatiable with ConfigParser:
+ Backward compatible implementations of ConfigParser,
+ RawConfigParser, and SafeConfigParser are included that are
+ API-compatible with the Python standard library.
+ They pass all the unit tests in Python-2.4.4.
+
+ - Preserves structure of INI files:
+ Order of sections & options, indentation, comments, and blank
+ lines are preserved as far as possible when data is updated.
+
+ - More convenient:
+ Values can be accessed using dotted notation (cfg.user.name),
+ or using container syntax (cfg['user']['name']).
+
+It is very useful for config files that are updated both by users and by
+programs, since it is very disorienting for a user to have her config
+file completely rearranged whenever a program changes it. iniparse also
+allows making the order of entries in a config file significant, which is
+desirable in applications like image galleries.
+
+WWW: http://code.google.com/p/iniparse/
diff --git a/devel/py-iniparse/pkg-plist b/devel/py-iniparse/pkg-plist
new file mode 100644
index 000000000000..3f12feb7d2b1
--- /dev/null
+++ b/devel/py-iniparse/pkg-plist
@@ -0,0 +1,14 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/iniparse/__init__.py
+%%PYTHON_SITELIBDIR%%/iniparse/__init__.pyc
+%%PYTHON_SITELIBDIR%%/iniparse/__init__.pyo
+%%PYTHON_SITELIBDIR%%/iniparse/compat.py
+%%PYTHON_SITELIBDIR%%/iniparse/compat.pyc
+%%PYTHON_SITELIBDIR%%/iniparse/compat.pyo
+%%PYTHON_SITELIBDIR%%/iniparse/config.py
+%%PYTHON_SITELIBDIR%%/iniparse/config.pyc
+%%PYTHON_SITELIBDIR%%/iniparse/config.pyo
+%%PYTHON_SITELIBDIR%%/iniparse/ini.py
+%%PYTHON_SITELIBDIR%%/iniparse/ini.pyc
+%%PYTHON_SITELIBDIR%%/iniparse/ini.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/iniparse