aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-01-02 10:35:40 +0800
committerswills <swills@FreeBSD.org>2014-01-02 10:35:40 +0800
commit503b7283f690fc0d4eec9630abf9f37e75f48356 (patch)
tree1378db8d4bf7e86e9d4ce7775074783fcc869c0d
parent7bc6430626ae10196ed9adbfd79fcccc00e5e6bc (diff)
downloadfreebsd-ports-gnome-503b7283f690fc0d4eec9630abf9f37e75f48356.tar.gz
freebsd-ports-gnome-503b7283f690fc0d4eec9630abf9f37e75f48356.tar.zst
freebsd-ports-gnome-503b7283f690fc0d4eec9630abf9f37e75f48356.zip
- Add patch to bundled rdoc to fix issue which causes some ports to fail to
build Obtained from: https://github.com/rdoc/rdoc/commit/f4f5b94285aa9b20cacf78bda61450e17be63a22
-rw-r--r--Mk/bsd.ruby.mk2
-rw-r--r--lang/ruby20/files/patch-lib__rdoc__ruby_lex.rb11
2 files changed, 12 insertions, 1 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index f0b36f0275d0..7dd2e708267f 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -204,7 +204,7 @@ RUBY20= "@comment "
# Ruby 2.0
#
RUBY_RELVERSION= 2.0.0
-RUBY_PORTREVISION= 1
+RUBY_PORTREVISION= 2
RUBY_PORTEPOCH= 1
RUBY_PATCHLEVEL= 353
diff --git a/lang/ruby20/files/patch-lib__rdoc__ruby_lex.rb b/lang/ruby20/files/patch-lib__rdoc__ruby_lex.rb
new file mode 100644
index 000000000000..212886386bcd
--- /dev/null
+++ b/lang/ruby20/files/patch-lib__rdoc__ruby_lex.rb
@@ -0,0 +1,11 @@
+--- ./lib/rdoc/ruby_lex.rb.orig 2012-12-18 07:31:36.000000000 +0000
++++ ./lib/rdoc/ruby_lex.rb 2014-01-02 01:09:06.630327388 +0000
+@@ -1028,6 +1028,8 @@
+ end
+
+ if output_heredoc then
++ raise Error, "Missing terminating #{quoted} for string" unless l
++
+ doc << l.chomp
+ else
+ doc << '"'