aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>1996-11-12 14:02:12 +0800
committerache <ache@FreeBSD.org>1996-11-12 14:02:12 +0800
commit518c0300c06235664a8011508c604bae0ac4cbfd (patch)
tree3a34567c31317c9f2d6a32371fc4073bebafd4b3
parentd7e5c15d5b99662375eddd1393dc79d002213e1f (diff)
downloadfreebsd-ports-gnome-518c0300c06235664a8011508c604bae0ac4cbfd.tar.gz
freebsd-ports-gnome-518c0300c06235664a8011508c604bae0ac4cbfd.tar.zst
freebsd-ports-gnome-518c0300c06235664a8011508c604bae0ac4cbfd.zip
Upgrade to 5.3
-rw-r--r--audio/tracker/Makefile14
-rw-r--r--audio/tracker/distinfo2
-rw-r--r--audio/tracker/files/patch-aa111
-rw-r--r--audio/tracker/files/patch-ab33
-rw-r--r--audio/tracker/files/patch-ac24
-rw-r--r--audio/tracker/pkg-descr2
-rw-r--r--audio/tracker/pkg-plist2
7 files changed, 139 insertions, 49 deletions
diff --git a/audio/tracker/Makefile b/audio/tracker/Makefile
index 383cec1d8f5e..b4f263d2abc1 100644
--- a/audio/tracker/Makefile
+++ b/audio/tracker/Makefile
@@ -1,19 +1,19 @@
# New ports collection makefile for: tracker
-# Version required: 4.44
+# Version required: 5.3
# Date created: 2 Oct 1994
# Whom: swallace
#
-# $Id: Makefile,v 1.26 1995/10/16 07:13:12 ache Exp $
+# $Id: Makefile,v 1.27 1996/01/16 01:44:20 ache Exp $
#
-DISTNAME= tracker
-PKGNAME= tracker-4.44
-CATEGORIES+= audio
+DISTNAME= tracker-5.3
+CATEGORIES= audio
MASTER_SITES= ftp://ftp.ens.fr/pub/dmi/users/espie/beta/
-DISTFILES= tracker-4.44.tar.Z
+EXTRACT_SUFX= .tgz
MAINTAINER= ache@FreeBSD.ORG
+WRKSRC= ${WRKDIR}/tracker
USE_GMAKE= yes
MAKE_FLAGS= MACHINE=freebsd CC=$(CC) INSTALL="$(INSTALL)" \
INST_BIN_OPT="-c -s -m $(BINMODE) -o $(BINOWN) -g $(BINGRP)" \
@@ -24,6 +24,6 @@ MAKE_FLAGS= MACHINE=freebsd CC=$(CC) INSTALL="$(INSTALL)" \
post-install:
cd ${WRKSRC}/Docs; makeinfo --no-split tracker.texinfo -o tracker.info; \
cd ${WRKSRC}/Docs; gzip -f tracker.info; \
- $(INSTALL) -c -m 644 -o $(BINOWN) -g $(BINGRP) tracker.info.gz ${PREFIX}/info
+ $(INSTALL_MAN) tracker.info.gz ${PREFIX}/info
.include <bsd.port.mk>
diff --git a/audio/tracker/distinfo b/audio/tracker/distinfo
index 9f47b69bfe6e..1d55a893893a 100644
--- a/audio/tracker/distinfo
+++ b/audio/tracker/distinfo
@@ -1 +1 @@
-MD5 (tracker-4.44.tar.Z) = 321abd3ac5277fb85d257b1868aa9757
+MD5 (tracker-5.3.tgz) = b1fc0f2cbdd0ff0dd79889f45d58f411
diff --git a/audio/tracker/files/patch-aa b/audio/tracker/files/patch-aa
index 11c16dfe9ec4..470698aacd7f 100644
--- a/audio/tracker/files/patch-aa
+++ b/audio/tracker/files/patch-aa
@@ -1,38 +1,73 @@
---- Makefile.orig Fri Oct 20 18:06:58 1995
-+++ Makefile Mon Apr 15 23:23:27 1996
-@@ -19,7 +19,7 @@
-
- OPTS=-c
-
--PREFIX=/users/algo/espie/pub
-+PREFIX?=/users/algo/espie/pub
- # Destination directory for tracker binaries and manpage.
- #
- # If you don't wish to use the 'make install' and 'make install.man'
-@@ -165,7 +165,7 @@
- UI_linux = Unix/
- SHELL_linux = /bin/sh
-
--CFLAGS_freebsd = -O2 -funroll-loops -finline-functions -fno-strength-reduce
-+CFLAGS_freebsd = -O2 -funroll-loops -finline-functions
- LIBS_freebsd = -lm
- AUDIODIR_freebsd=PCux/
- CONFIG_freebsd = PCux/freebsd_
-@@ -247,7 +247,7 @@
- display$O prefs$O autoinit$O $(UI)ui$O empty$O color$O version$O \
- st_virt$O automaton$O
-
--all: tracker${EXE} randomize${EXE} splitmod${EXE} Docs/tracker.text
-+all: tracker${EXE} randomize${EXE} splitmod${EXE}
-
- config.h: $(CONFIG)config.h Makefile
- rm -f config.h
-@@ -271,7 +271,7 @@
- $(INSTALL) $(INST_BIN_OPT) randomize $(BIN_DIR)
- $(INSTALL) $(INST_BIN_OPT) splitmod $(BIN_DIR)
- [ -f ${COMPRESSION_FILE} ] || \
-- $(INSTALL) $(INST_MAN_OPT) compression_methods ${COMPRESSION_FILE}
-+ $(INSTALL) $(INST_MAN_OPT) Lib/compression_methods ${COMPRESSION_FILE}
-
- # no manpage available, use the texinfo manual.
- install.man:
+*** Makefile.orig Tue May 7 19:20:50 1996
+--- Makefile Tue Nov 12 06:56:18 1996
+***************
+*** 20,26 ****
+
+ OPTS=-c
+
+! PREFIX=/users/algo/espie/pub
+ # Destination directory for tracker binaries and manpage.
+ #
+ # If you don't wish to use the 'make install' and 'make install.man'
+--- 20,26 ----
+
+ OPTS=-c
+
+! PREFIX?=/users/algo/espie/pub
+ # Destination directory for tracker binaries and manpage.
+ #
+ # If you don't wish to use the 'make install' and 'make install.man'
+***************
+*** 166,172 ****
+ UI_linux = Unix/
+ SHELL_linux = /bin/sh
+
+! CFLAGS_freebsd = -O2 -funroll-loops -finline-functions -fno-strength-reduce
+ LIBS_freebsd = -lm
+ AUDIODIR_freebsd=PCux/
+ CONFIG_freebsd = PCux/freebsd_
+--- 166,172 ----
+ UI_linux = Unix/
+ SHELL_linux = /bin/sh
+
+! CFLAGS_freebsd = -O2 -funroll-loops -finline-functions
+ LIBS_freebsd = -lm
+ AUDIODIR_freebsd=PCux/
+ CONFIG_freebsd = PCux/freebsd_
+***************
+*** 250,256 ****
+ display$O prefs$O autoinit$O $(UI)ui$O empty$O color$O version$O \
+ st_virt$O automaton$O
+
+! all: tracker${EXE} randomize${EXE} splitmod${EXE} Docs/tracker.text
+
+ config.h: $(CONFIG)config.h
+ rm -f config.h
+--- 250,256 ----
+ display$O prefs$O autoinit$O $(UI)ui$O empty$O color$O version$O \
+ st_virt$O automaton$O
+
+! all: tracker${EXE} randomize${EXE}
+
+ config.h: $(CONFIG)config.h
+ rm -f config.h
+***************
+*** 272,280 ****
+ install:
+ $(INSTALL) $(INST_BIN_OPT) tracker $(BIN_DIR)
+ $(INSTALL) $(INST_BIN_OPT) randomize $(BIN_DIR)
+- $(INSTALL) $(INST_BIN_OPT) splitmod $(BIN_DIR)
+ [ -f ${COMPRESSION_FILE} ] || \
+! $(INSTALL) $(INST_MAN_OPT) compression_methods ${COMPRESSION_FILE}
+
+ # no manpage available, use the texinfo manual.
+ install.man:
+--- 272,279 ----
+ install:
+ $(INSTALL) $(INST_BIN_OPT) tracker $(BIN_DIR)
+ $(INSTALL) $(INST_BIN_OPT) randomize $(BIN_DIR)
+ [ -f ${COMPRESSION_FILE} ] || \
+! $(INSTALL) $(INST_MAN_OPT) Lib/compression_methods ${COMPRESSION_FILE}
+
+ # no manpage available, use the texinfo manual.
+ install.man:
diff --git a/audio/tracker/files/patch-ab b/audio/tracker/files/patch-ab
new file mode 100644
index 000000000000..6d56391fa6bf
--- /dev/null
+++ b/audio/tracker/files/patch-ab
@@ -0,0 +1,33 @@
+*** Docs/tracker.texinfo.orig Thu Apr 11 21:21:05 1996
+--- Docs/tracker.texinfo Tue Nov 12 07:08:17 1996
+***************
+*** 979,992 ****
+ * Other Architectures: Porting tracker.
+ @end menu
+
+! @node Aix, Amiga, Architecture dependent problems, Architecture Dependent problems
+ @subsection Aix
+
+ The Aix port is slightly outdated and won't run with most recent versions of
+ Aix. There is nothing I can do about it until somebody sends me an up-to-date
+ version as I don't have access to Aix machines.
+
+! @node Amiga, DECstation, Architecture dependent problems, Architecture dependent problems
+ @subsection Amiga
+
+ There is currently one Amiga version running under AmigaDos.
+--- 979,992 ----
+ * Other Architectures: Porting tracker.
+ @end menu
+
+! @node Aix, Amiga, Architecture dependent problems, Architecture dependent problems
+ @subsection Aix
+
+ The Aix port is slightly outdated and won't run with most recent versions of
+ Aix. There is nothing I can do about it until somebody sends me an up-to-date
+ version as I don't have access to Aix machines.
+
+! @node Amiga, DECstation, Aix, Architecture dependent problems
+ @subsection Amiga
+
+ There is currently one Amiga version running under AmigaDos.
diff --git a/audio/tracker/files/patch-ac b/audio/tracker/files/patch-ac
new file mode 100644
index 000000000000..5bee61206a48
--- /dev/null
+++ b/audio/tracker/files/patch-ac
@@ -0,0 +1,24 @@
+*** Arch/PCux/audio.c.bak Fri Apr 12 20:30:37 1996
+--- Arch/PCux/audio.c Tue Nov 12 08:40:29 1996
+***************
+*** 9,14 ****
+--- 9,17 ----
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include "extern.h"
++ #include "prefs.h"
++ #include "autoinit.h"
++ #include "watched_var.h"
+
+ struct options_set *port_options=0;
+
+***************
+*** 116,121 ****
+--- 119,125 ----
+ }
+ samples_max = buf_max / dsize;
+ current_freq = f;
++ set_watched_scalar(FREQUENCY, f);
+ total = 0;
+ return f;
+ }
diff --git a/audio/tracker/pkg-descr b/audio/tracker/pkg-descr
index 1264f267e9c5..2246f24fd3e7 100644
--- a/audio/tracker/pkg-descr
+++ b/audio/tracker/pkg-descr
@@ -2,5 +2,5 @@ Tracker plays soundtracker music modules on a Unix machine.
Soundtracker modules originated on the amiga, where several composing
playing programs are available, that give results mostly compatible
with each other. tracker just plays the specified files in sequence
-accord- ing with the current options.
+according with the current options.
diff --git a/audio/tracker/pkg-plist b/audio/tracker/pkg-plist
index 9343302a9f57..58a0efe2b023 100644
--- a/audio/tracker/pkg-plist
+++ b/audio/tracker/pkg-plist
@@ -1,6 +1,4 @@
-@cwd /usr/local
bin/tracker
bin/randomize
-bin/splitmod
etc/compression_methods
info/tracker.info.gz