aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortrhodes <trhodes@FreeBSD.org>2004-09-11 12:55:48 +0800
committertrhodes <trhodes@FreeBSD.org>2004-09-11 12:55:48 +0800
commit51925b29051f29660739e538d942a2e069befb83 (patch)
treea61ba71f1941e450e94ad42c78922dbc0c7f7403
parentca95c11f4747935a430fe37989379110b8ad3ccf (diff)
downloadfreebsd-ports-gnome-51925b29051f29660739e538d942a2e069befb83.tar.gz
freebsd-ports-gnome-51925b29051f29660739e538d942a2e069befb83.tar.zst
freebsd-ports-gnome-51925b29051f29660739e538d942a2e069befb83.zip
Fix recently found bug.
Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru> (maintainer) Approved by: portmgr (linimon)
-rw-r--r--audio/mpg123/Makefile2
-rw-r--r--audio/mpg123/files/patch-layer2.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/audio/mpg123/Makefile b/audio/mpg123/Makefile
index d2b516260a4c..8976b8e02972 100644
--- a/audio/mpg123/Makefile
+++ b/audio/mpg123/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mpg123
PORTVERSION= 0.59r
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= audio ipv6
MASTER_SITES= http://www.mpg123.de/mpg123/ \
http://www-ti.informatik.uni-tuebingen.de/~hippm/mpg123/
diff --git a/audio/mpg123/files/patch-layer2.c b/audio/mpg123/files/patch-layer2.c
new file mode 100644
index 000000000000..f87a4ff36913
--- /dev/null
+++ b/audio/mpg123/files/patch-layer2.c
@@ -0,0 +1,14 @@
+diff -u -r1.1.1.1 layer2.c
+--- layer2.c 1999/02/10 12:13:06 1.1.1.1
++++ layer2.c 2004/09/02 21:43:58
+@@ -265,6 +265,11 @@
+ fr->jsbound = (fr-&gt;>mode == MPG_MD_JOINT_STEREO) ?
+ (fr->mode_ext<<2)+4 : fr->II_sblimit;
+
++ if (fr->jsbound > fr->II_sblimit) {
++ fprintf(stderr, "Truncating stereo boundary to sideband limit.\n");
++ fr->jsbound=fr->II_sblimit;
++ }
++
+ if(stereo == 1 || single == 3)
+ single = 0;