aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2013-12-03 00:56:42 +0800
committerdbn <dbn@FreeBSD.org>2013-12-03 00:56:42 +0800
commit5311ccf6a4eb6821f68886fc899ad2d45e2917ae (patch)
treebc94ab51513b48a9bd205f6dc23ca703d88dc8ea
parent0b26998cc5ee840119de8960ac2e34b7722eb0c6 (diff)
downloadfreebsd-ports-gnome-5311ccf6a4eb6821f68886fc899ad2d45e2917ae.tar.gz
freebsd-ports-gnome-5311ccf6a4eb6821f68886fc899ad2d45e2917ae.tar.zst
freebsd-ports-gnome-5311ccf6a4eb6821f68886fc899ad2d45e2917ae.zip
Add sanity check for LIB_DEPENDS and RUN_DEPENDS.
Ports does not support relative paths in ${TYPE}_DEPENDS and actually breaks the dependency registration with pkgng. This occurs in ACTUAL_PACKAGE_DEPENDS where ${PORTSDIR} is stripped from the dependencies' directory and uses the rest of the string as the package origin. pkg(8) then fails to detect package origins with relative paths. Approved by: portmgr (bapt)
-rw-r--r--Mk/bsd.sanity.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index 8ca6fdf58d18..b7e9de292c98 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -51,6 +51,14 @@ DEV_ERROR+= "USE_KDELIBS_VER is unsupported"
DEV_ERROR+= "USE_QT_VER is unsupported"
.endif
+.if !empty(LIB_DEPENDS:M*/../*)
+DEV_ERROR+= "LIB_DEPENDS contains unsupported relative path to dependency"
+.endif
+
+.if !empty(RUN_DEPENDS:M*/../*)
+DEV_ERROR+= "RUN_DEPENDS contains unsupported relative path to dependency"
+.endif
+
.if defined(USE_DISPLAY)
DEV_WARNING+= "USE_DISPLAY is deprecated, please use USES=display"
.endif