aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-07-16 16:44:04 +0800
committerbapt <bapt@FreeBSD.org>2014-07-16 16:44:04 +0800
commit54fe086946300e97f880eadf5c3294ffafd89807 (patch)
tree289ec4aa8b822fb645ed24b93d3aecb4b11d3438
parent117881353a4b7072903cc6e7f10e947c2fa9dcc5 (diff)
downloadfreebsd-ports-gnome-54fe086946300e97f880eadf5c3294ffafd89807.tar.gz
freebsd-ports-gnome-54fe086946300e97f880eadf5c3294ffafd89807.tar.zst
freebsd-ports-gnome-54fe086946300e97f880eadf5c3294ffafd89807.zip
Fix some non default LIB_DEPENDS
With hat: portmgr
-rw-r--r--palm/pilot-link/Makefile2
-rw-r--r--polish/gnugadu2/Makefile10
-rw-r--r--ports-mgmt/bxpkg/Makefile2
-rw-r--r--ports-mgmt/packagekit/Makefile2
-rw-r--r--print/ghostscript7/files/Makefile.drivers_post2
-rw-r--r--print/gutenprint-base/Makefile10
-rw-r--r--science/abinit/Makefile6
-rw-r--r--science/psi3/Makefile2
-rw-r--r--security/lasso/Makefile2
-rw-r--r--security/openvpn-devel/Makefile2
-rw-r--r--security/ophcrack/Makefile2
-rw-r--r--security/samhain/Makefile2
-rw-r--r--security/suricata/Makefile4
-rw-r--r--sysutils/fusefs-ntfs/Makefile2
-rw-r--r--sysutils/grub2-pcbsd/Makefile2
-rw-r--r--sysutils/grub2/Makefile2
-rw-r--r--sysutils/heartbeat/Makefile4
-rw-r--r--sysutils/jailadmin/Makefile2
-rw-r--r--sysutils/pdsh/Makefile2
-rw-r--r--sysutils/pflogx/Makefile2
-rw-r--r--textproc/htmldoc/Makefile2
-rw-r--r--textproc/libextractor/Makefile12
-rw-r--r--textproc/pootle/Makefile2
-rw-r--r--textproc/sphinxsearch-devel/Makefile2
-rw-r--r--www/cacheboy16/Makefile2
-rw-r--r--www/elinks/Makefile14
-rw-r--r--www/gallery3/Makefile2
-rw-r--r--www/groupoffice/Makefile2
-rw-r--r--www/links-hacked/Makefile4
-rw-r--r--www/lusca-head/Makefile2
-rw-r--r--www/opera-devel/Makefile2
-rw-r--r--www/squid/Makefile2
-rw-r--r--www/squid32/Makefile8
-rw-r--r--www/squid33/Makefile8
-rw-r--r--x11/mlterm/Makefile14
-rw-r--r--x11/mrxvt/Makefile2
-rw-r--r--x11/xbindkeys/Makefile2
-rw-r--r--x11/xvkbd/Makefile2
38 files changed, 72 insertions, 76 deletions
diff --git a/palm/pilot-link/Makefile b/palm/pilot-link/Makefile
index 7eeaa5c6171c..88f0c9c0abea 100644
--- a/palm/pilot-link/Makefile
+++ b/palm/pilot-link/Makefile
@@ -45,7 +45,7 @@ LDFLAGS+= ${PTHREAD_LIBS}
.endif
.if ${PORT_OPTIONS:MPNG}
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+= --with-libpng=${PREFIX}
.else
CONFIGURE_ARGS+= --disable-png
diff --git a/polish/gnugadu2/Makefile b/polish/gnugadu2/Makefile
index 9e1bd962f1ee..99666b9020e4 100644
--- a/polish/gnugadu2/Makefile
+++ b/polish/gnugadu2/Makefile
@@ -74,7 +74,7 @@ PORT_OPTIONS+= GTKSPELL
.endif
.if ${PORT_OPTIONS:MTLEN}
-LIB_DEPENDS+= tlen.1:${PORTSDIR}/polish/libtlen
+LIB_DEPENDS+= libtlen.so:${PORTSDIR}/polish/libtlen
CONFIGURE_ARGS+= --with-tlen
PLIST_SUB+= TLEN:=""
.else
@@ -83,7 +83,7 @@ PLIST_SUB+= TLEN:="@comment "
.endif
.if ${PORT_OPTIONS:MJABBER}
-LIB_DEPENDS+= loudmouth-1.0:${PORTSDIR}/net-im/loudmouth
+LIB_DEPENDS+= libloudmouth-1.so:${PORTSDIR}/net-im/loudmouth
CONFIGURE_ARGS+= --with-jabber
PLIST_SUB+= JABBER:=""
.else
@@ -108,14 +108,14 @@ PLIST_SUB+= DOCKAPP:="@comment "
.endif
.if ${PORT_OPTIONS:MGTKSPELL}
-LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell
+LIB_DEPENDS+= libgtkspell.so:${PORTSDIR}/textproc/gtkspell
CONFIGURE_ARGS+= --with-gtkspell
.else
CONFIGURE_ARGS+= --without-gtkspell
.endif
.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
+LIB_DEPENDS+= libdbus-1.so:${PORTSDIR}/devel/dbus
CONFIGURE_ARGS+= --with-dbus \
--with-dbus-dir=${PREFIX}/share/dbus-1/services
PLIST_SUB+= DBUS:=""
@@ -135,7 +135,7 @@ PLIST_SUB+= ESOUND:="@comment "
.endif
.if ${PORT_OPTIONS:MXOSD}
-LIB_DEPENDS+= xosd.4:${PORTSDIR}/misc/xosd
+LIB_DEPENDS+= libxosd.so:${PORTSDIR}/misc/xosd
CONFIGURE_ARGS+= --with-xosd
PLIST_SUB+= XOSD:=""
.else
diff --git a/ports-mgmt/bxpkg/Makefile b/ports-mgmt/bxpkg/Makefile
index 9ae67e21385b..bf8af7af4c1e 100644
--- a/ports-mgmt/bxpkg/Makefile
+++ b/ports-mgmt/bxpkg/Makefile
@@ -24,7 +24,7 @@ NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800000
-LIB_DEPENDS+= archive:${PORTSDIR}/archivers/libarchive
+LIB_DEPENDS+= libarchive.so:${PORTSDIR}/archivers/libarchive
.endif
.include <bsd.port.post.mk>
diff --git a/ports-mgmt/packagekit/Makefile b/ports-mgmt/packagekit/Makefile
index f03a9f0bf750..45ed5d0f7b89 100644
--- a/ports-mgmt/packagekit/Makefile
+++ b/ports-mgmt/packagekit/Makefile
@@ -72,7 +72,7 @@ PLIST_SUB+= GTK="@comment "
CONFIGURE_ARGS+=--disable-qt
.elif defined(${SLAVEPORT}) && ${SLAVEPORT}=="qt4"
-LIB_DEPENDS+= packagekit-glib2:${PORTSDIR}/ports-mgmt/packagekit
+LIB_DEPENDS+= libpackagekit-glib2.so:${PORTSDIR}/ports-mgmt/packagekit
CONFIGURE_ARGS+=--enable-qt
LIB_DEPENDS+= libcppunit-1.12.so:${PORTSDIR}/devel/cppunit
diff --git a/print/ghostscript7/files/Makefile.drivers_post b/print/ghostscript7/files/Makefile.drivers_post
index 24147c9d9419..72c1139803cb 100644
--- a/print/ghostscript7/files/Makefile.drivers_post
+++ b/print/ghostscript7/files/Makefile.drivers_post
@@ -31,7 +31,7 @@ OPTIONS_UNSET+= ${PORT_OPTIONS:MGS_${D}}
.endfor
.if defined(_VGA_DEVS)
-LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
+LIB_DEPENDS+= libvga.so:${PORTSDIR}/graphics/svgalib
.endif
# x11 specific
diff --git a/print/gutenprint-base/Makefile b/print/gutenprint-base/Makefile
index 796174c79240..f69be55368c0 100644
--- a/print/gutenprint-base/Makefile
+++ b/print/gutenprint-base/Makefile
@@ -29,7 +29,7 @@ NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${SLAVE_PORT}=="yes"
-LIB_DEPENDS+= gutenprintui2.1:${PORTSDIR}/print/gutenprint-base
+LIB_DEPENDS+= libgutenprintui2.so:${PORTSDIR}/print/gutenprint-base
PKG_CONFIG?= ${LOCALBASE}/bin/pkg-config
GUTENPRINTUI2_LIBS=`${PKG_CONFIG} --libs gutenprintui2`
.else
@@ -37,7 +37,7 @@ MAN1+= escputil.1
.endif
.if defined(GUT_SLAVE) && ${GUT_SLAVE}=="gimp"
-LIB_DEPENDS+= gimp-2.0:${PORTSDIR}/graphics/gimp-app \
+LIB_DEPENDS+= libgimp-2.0.so:${PORTSDIR}/graphics/gimp-app \
gutenprint.3:${PORTSDIR}/print/gutenprint-base
CONFIGURE_ARGS=--with-gimp2=yes # Override CONFIGURE_ARGS
BUILD_WRKSRC= ${WRKSRC}/src/gimp2
@@ -47,8 +47,8 @@ CONFIGURE_ARGS+=--without-gimp2
.endif
.if defined(GUT_SLAVE) && ${GUT_SLAVE}=="cups"
-LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-client \
- cupsimage.2:${PORTSDIR}/print/cups-image
+LIB_DEPENDS+= libcups.so:${PORTSDIR}/print/cups-client \
+ libcupsimage.so:${PORTSDIR}/print/cups-image
RUN_DEPENDS+= espgs:${PORTSDIR}/print/cups-pstoraster
CONFIGURE_ARGS+= --with-cups=${PREFIX} \
--enable-cups-ppds \
@@ -61,7 +61,7 @@ CONFIGURE_ARGS+= --without-cups
.endif
.if defined(GUT_SLAVE) && ${GUT_SLAVE}=="ijs"
-LIB_DEPENDS+= ijs.1:${PORTSDIR}/print/libijs
+LIB_DEPENDS+= libijs.so:${PORTSDIR}/print/libijs
CONFIGURE_ARGS+=--with-ijs=yes
MAN1+= ijsgutenprint.1
BUILD_WRKSRC= ${WRKSRC}/src/ghost
diff --git a/science/abinit/Makefile b/science/abinit/Makefile
index 6f1420fed073..0ac1203d0b0d 100644
--- a/science/abinit/Makefile
+++ b/science/abinit/Makefile
@@ -48,12 +48,12 @@ MANUAL_PACKAGE_BUILD= takes a tremendous amount of time to build on pointyhat no
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
BLAS= -lf77blas
LAPACK= -lalapack -lcblas
.else
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
-LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.endif
diff --git a/science/psi3/Makefile b/science/psi3/Makefile
index b7c9423d1a83..7933f287a0ec 100644
--- a/science/psi3/Makefile
+++ b/science/psi3/Makefile
@@ -40,7 +40,7 @@ LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
BLAS= -lgoto2p
LAPACK= -lgoto2p
.elif ${WITH_BLAS} == atlas
-LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
BLAS= -lptf77blas
LAPACK= -lalapack -lptcblas
.endif
diff --git a/security/lasso/Makefile b/security/lasso/Makefile
index 7f6ecae66f4b..3b25b48b2eac 100644
--- a/security/lasso/Makefile
+++ b/security/lasso/Makefile
@@ -40,7 +40,7 @@ PLIST_SUB+= WITH_PERL="@comment "
CONFIGURE_ARGS+= --enable-php5 \
--with-php5-config="${LOCALBASE}/bin/php-config"
LDFLAGS+= "-L${LOCALBASE}/lib"
-LIB_DEPENDS+= expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS+= libexpat.so:${PORTSDIR}/textproc/expat2
PLIST_SUB+= WITH_PHP5=""
USE_PHP= yes
USE_PHP_BUILD= yes
diff --git a/security/openvpn-devel/Makefile b/security/openvpn-devel/Makefile
index 145eebfbf949..2b054c7497ec 100644
--- a/security/openvpn-devel/Makefile
+++ b/security/openvpn-devel/Makefile
@@ -72,7 +72,7 @@ CONFIGURE_ARGS+=--disable-lzo
.endif
.if ${PORT_OPTIONS:MSNAPPY}
-LIB_DEPENDS+= snappy:${PORTSDIR}/archivers/snappy
+LIB_DEPENDS+= libsnappy.so:${PORTSDIR}/archivers/snappy
.else
CONFIGURE_ARGS+=--disable-snappy
.endif
diff --git a/security/ophcrack/Makefile b/security/ophcrack/Makefile
index 346b6cde2c3b..56261e5d5cdc 100644
--- a/security/ophcrack/Makefile
+++ b/security/ophcrack/Makefile
@@ -40,7 +40,7 @@ CONFIGURE_ARGS+= --disable-gui
.endif
.if ${PORT_OPTIONS:MGRAPH}
-LIB_DEPENDS+= qwt:${PORTSDIR}/x11-toolkits/qwt5
+LIB_DEPENDS+= libqwt.so:${PORTSDIR}/x11-toolkits/qwt5
.else
CONFIGURE_ARGS+= --disable-graph
.endif
diff --git a/security/samhain/Makefile b/security/samhain/Makefile
index 492a85296668..b3534b26aeba 100644
--- a/security/samhain/Makefile
+++ b/security/samhain/Makefile
@@ -106,7 +106,7 @@ CONFIGURE_ARGS+= --with-logserver=true
CONFIGURE_ARGS+= --with-altlogserver=true
.endif
.if ${PORT_OPTIONS:MPRELUDE}
-LIB_DEPENDS+= prelude:${PORTSDIR}/security/libprelude
+LIB_DEPENDS+= libprelude.so:${PORTSDIR}/security/libprelude
CONFIGURE_ARGS+= --with-prelude
.endif
diff --git a/security/suricata/Makefile b/security/suricata/Makefile
index 3726043754c8..a916a9d064e3 100644
--- a/security/suricata/Makefile
+++ b/security/suricata/Makefile
@@ -61,7 +61,7 @@ BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
.if ${PORT_OPTIONS:MPRELUDE}
-LIB_DEPENDS+= prelude:${PORTSDIR}/security/libprelude
+LIB_DEPENDS+= libprelude.so:${PORTSDIR}/security/libprelude
CONFIGURE_ARGS+= --enable-prelude \
--with-libprelude-prefix=${LOCALBASE}
PLIST_SUB+= PRELUDE=""
@@ -72,7 +72,7 @@ CONFIGURE_ARGS+= --enable-ipfw
.endif
.if ${PORT_OPTIONS:MPORTS_PCAP}
-LIB_DEPENDS+= pcap:${PORTSDIR}/net/libpcap
+LIB_DEPENDS+= libpcap.so:${PORTSDIR}/net/libpcap
CONFIGURE_ARGS+= --with-libpcap-includes=${LOCALBASE}/include \
--with-libpcap-libraries=${LOCALBASE}/lib
.else
diff --git a/sysutils/fusefs-ntfs/Makefile b/sysutils/fusefs-ntfs/Makefile
index 89153fcfdfe2..371016a9d10d 100644
--- a/sysutils/fusefs-ntfs/Makefile
+++ b/sysutils/fusefs-ntfs/Makefile
@@ -41,7 +41,7 @@ CFLAGS+= -DUSE_LOCK
.if ${PORT_OPTIONS:MUBLIO}
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-ublio
-LIB_DEPENDS+= ublio:${PORTSDIR}/devel/libublio
+LIB_DEPENDS+= libublio.so:${PORTSDIR}/devel/libublio
CFLAGS+= -DUSE_UBLIO
.endif
diff --git a/sysutils/grub2-pcbsd/Makefile b/sysutils/grub2-pcbsd/Makefile
index c383d56c4686..6761acdcac66 100644
--- a/sysutils/grub2-pcbsd/Makefile
+++ b/sysutils/grub2-pcbsd/Makefile
@@ -64,7 +64,7 @@ MKFONT= "@comment "
PLIST_SUB+= MKFONT=${MKFONT}
.if ${PORT_OPTIONS:MFUSE}
-LIB_DEPENDS+= fuse:${PORTSDIR}/sysutils/fusefs-libs
+LIB_DEPENDS+= libfuse.so:${PORTSDIR}/sysutils/fusefs-libs
CONFIGURE_ARGS+= --enable-grub-mount
.else
CONFIGURE_ARGS+= --disable-grub-mount
diff --git a/sysutils/grub2/Makefile b/sysutils/grub2/Makefile
index 9d5acbe263c3..16a8b3899028 100644
--- a/sysutils/grub2/Makefile
+++ b/sysutils/grub2/Makefile
@@ -57,7 +57,7 @@ MKFONT= "@comment "
PLIST_SUB+= MKFONT=${MKFONT}
.if ${PORT_OPTIONS:MFUSE}
-LIB_DEPENDS+= fuse:${PORTSDIR}/sysutils/fusefs-libs
+LIB_DEPENDS+= libfuse.so:${PORTSDIR}/sysutils/fusefs-libs
CONFIGURE_ARGS+= --enable-grub-mount
.else
CONFIGURE_ARGS+= --disable-grub-mount
diff --git a/sysutils/heartbeat/Makefile b/sysutils/heartbeat/Makefile
index 51d9195d716d..84021aa7c8f7 100644
--- a/sysutils/heartbeat/Makefile
+++ b/sysutils/heartbeat/Makefile
@@ -65,8 +65,8 @@ LDIRECTORD_DESC= Enable Linux Director Daemon
APCSNMP_DESC= Enable APC SNMP Stonith Device
DRAC3_DESC= Enable Dell DRACIII Stonith Device
-APCSNMP_LIB_DEPENDS= netsnmp:${PORTSDIR}/net-mgmt/net-snmp
-DRAC3_LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+APCSNMP_LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
+DRAC3_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
.include <bsd.port.options.mk>
diff --git a/sysutils/jailadmin/Makefile b/sysutils/jailadmin/Makefile
index a67bec5e423e..0dce1bb29fb1 100644
--- a/sysutils/jailadmin/Makefile
+++ b/sysutils/jailadmin/Makefile
@@ -19,7 +19,7 @@ NO_STAGE= yes
.include <bsd.port.pre.mk>
.if defined(WITH_SNMP)
-LIB_DEPENDS+= netsnmp.30:${PORTSDIR}/net-mgmt/net-snmp
+LIB_DEPENDS+= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
PLIST_SUB+= SNMP=""
.else
INSTALL_TARGET= installbase
diff --git a/sysutils/pdsh/Makefile b/sysutils/pdsh/Makefile
index f9a12bb169a7..82975cf7d3c9 100644
--- a/sysutils/pdsh/Makefile
+++ b/sysutils/pdsh/Makefile
@@ -51,7 +51,7 @@ PLIST_SUB+= NETGROUP="@comment "
.if ${PORT_OPTIONS:MREADLINE}
CONFIGURE_ARGS+= --with-readline
-LIB_DEPENDS+= readline:${PORTSDIR}/devel/readline
+LIB_DEPENDS+= libreadline.so.6:${PORTSDIR}/devel/readline
.else
CONFIGURE_ARGS+= --without-readline
.endif
diff --git a/sysutils/pflogx/Makefile b/sysutils/pflogx/Makefile
index 939248105cdb..2fb593058352 100644
--- a/sysutils/pflogx/Makefile
+++ b/sysutils/pflogx/Makefile
@@ -18,7 +18,7 @@ EXPAT_DESC= Ability to merge new events (require expat)
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MEXPAT}
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
MAKE_ARGS+= -DWITH_EXPAT \
EXPAT_INCLUDEDIR=${LOCALBASE}/include \
EXPAT_LIBDIR=${LOCALBASE}/lib
diff --git a/textproc/htmldoc/Makefile b/textproc/htmldoc/Makefile
index 856643a739c1..76c6a19e3a54 100644
--- a/textproc/htmldoc/Makefile
+++ b/textproc/htmldoc/Makefile
@@ -56,7 +56,7 @@ post-install:
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MHTMLDOCGUI}
-LIB_DEPENDS+= fltk:${PORTSDIR}/x11-toolkits/fltk
+LIB_DEPENDS+= libfltk.so:${PORTSDIR}/x11-toolkits/fltk
CONFIGURE_ARGS+=--with-gui=yes
.else
CONFIGURE_ARGS+=--with-gui=no
diff --git a/textproc/libextractor/Makefile b/textproc/libextractor/Makefile
index 1c4d560f4432..d204f6e34383 100644
--- a/textproc/libextractor/Makefile
+++ b/textproc/libextractor/Makefile
@@ -70,28 +70,28 @@ PLIST_SUB+= EXIV2="@comment "
.endif
.if ${PORT_OPTIONS:MFLAC}
-LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
+LIB_DEPENDS+= libFLAC.so:${PORTSDIR}/audio/flac
PLIST_SUB+= FLAC=""
.else
PLIST_SUB+= FLAC="@comment "
.endif
.if ${PORT_OPTIONS:MMPEG2}
-LIB_DEPENDS+= mpeg2:${PORTSDIR}/multimedia/libmpeg2
+LIB_DEPENDS+= libmpeg2.so:${PORTSDIR}/multimedia/libmpeg2
PLIST_SUB+= MPEG2=""
.else
PLIST_SUB+= MPEG2="@comment "
.endif
.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbisfile:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
PLIST_SUB+= VORBIS=""
.else
PLIST_SUB+= VORBIS="@comment "
.endif
.if ${PORT_OPTIONS:MGSF}
-LIB_DEPENDS+= gsf-1:${PORTSDIR}/devel/libgsf
+LIB_DEPENDS+= libgsf-1.so:${PORTSDIR}/devel/libgsf
PLIST_SUB+= GSF=""
.else
PLIST_SUB+= GSF="@comment "
@@ -105,7 +105,7 @@ PLIST_SUB+= POPPLER="@comment "
.endif
.if ${PORT_OPTIONS:MRPM}
-LIB_DEPENDS+= rpm:${PORTSDIR}/archivers/rpm4
+LIB_DEPENDS+= librpm.so:${PORTSDIR}/archivers/rpm4
PLIST_SUB+= RPM=""
.else
PLIST_SUB+= RPM="@comment "
@@ -113,7 +113,7 @@ PLIST_SUB+= RPM="@comment "
# QT can be disabled
.if ${PORT_OPTIONS:MQT}
-LIB_DEPENDS+= QtGui:${PORTSDIR}/x11-toolkits/qt4-gui
+LIB_DEPENDS+= libQtGui.so:${PORTSDIR}/x11-toolkits/qt4-gui
LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/qt4
CONFIGURE_ARGS+=--with-qt=${LOCALBASE}
PLIST_SUB+= QT=""
diff --git a/textproc/pootle/Makefile b/textproc/pootle/Makefile
index c654f5420bc8..ae19e9c61e34 100644
--- a/textproc/pootle/Makefile
+++ b/textproc/pootle/Makefile
@@ -70,7 +70,7 @@ RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion
.endif
.if ${PORT_OPTIONS:MMEMCACHED}
-LIB_DEPENDS+= memcached:${PORTSDIR}/databases/libmemcached
+LIB_DEPENDS+= libmemcached.so:${PORTSDIR}/databases/libmemcached
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}memcached>=1.45:${PORTSDIR}/databases/py-memcached
.endif
diff --git a/textproc/sphinxsearch-devel/Makefile b/textproc/sphinxsearch-devel/Makefile
index 6d371eaa1e2b..3bf6a014fb73 100644
--- a/textproc/sphinxsearch-devel/Makefile
+++ b/textproc/sphinxsearch-devel/Makefile
@@ -82,7 +82,7 @@ SYSLOG_DESC= Enable logging via syslog
SYSLOG_CONFIGURE_WITH= syslog
UNIXODBC_CONFIGURE_WITH=unixodbc
-UNIXODBC_LIB_DEPENDS= odbc:${PORTSDIR}/databases/unixODBC
+UNIXODBC_LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/unixODBC
CONFLICTS= sphinxsearch-[0-9]* dpsearch-[0-9]* rdb-[0-9]* \
diff --git a/www/cacheboy16/Makefile b/www/cacheboy16/Makefile
index d7eef9ff4d95..a0eef350d37c 100644
--- a/www/cacheboy16/Makefile
+++ b/www/cacheboy16/Makefile
@@ -140,7 +140,7 @@ external_acl+= ldap_group
libexec+= digest_ldap_auth squid_ldap_auth squid_ldap_group
.endif
.if ${PORT_OPTIONS:MSQUID_SASL_AUTH}
-LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/www/elinks/Makefile b/www/elinks/Makefile
index e695d05d1d7f..1999c1aaff68 100644
--- a/www/elinks/Makefile
+++ b/www/elinks/Makefile
@@ -55,7 +55,7 @@ CONFIGURE_ARGS+= --disable-nls
#.endif
.if ${PORT_OPTIONS:MGUILE}
-LIB_DEPENDS+= guile:${PORTSDIR}/lang/guile
+LIB_DEPENDS+= libguile.so:${PORTSDIR}/lang/guile
CONFIGURE_ARGS+= --with-guile
.else
CONFIGURE_ARGS+= --without-guile
@@ -82,7 +82,7 @@ CONFIGURE_ARGS+= --enable-fastmem
.endif
.if ${PORT_OPTIONS:MIDN}
-LIB_DEPENDS+= idn:${PORTSDIR}/dns/libidn
+LIB_DEPENDS+= libidn.so:${PORTSDIR}/dns/libidn
CONFIGURE_ARGS+= --with-idn
.else
CONFIGURE_ARGS+= --without-idn
@@ -159,7 +159,7 @@ CONFIGURE_ARGS+= --disable-cgi
.endif
.if ${PORT_OPTIONS:MXBELMARKS}
-LIB_DEPENDS+= expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS+= libexpat.so:${PORTSDIR}/textproc/expat2
CONFIGURE_ARGS+= --enable-xbel --with-expat
.else
CONFIGURE_ARGS+= --disable-xbel
@@ -176,7 +176,7 @@ CONFIGURE_ARGS+= --enable-88-colors
.if ${PORT_OPTIONS:MSPIDERMONKEY}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libjs.so:${PORTSDIR}/lang/spidermonkey17
RUN_DEPENDS+= js:${PORTSDIR}/lang/spidermonkey17
-LIB_DEPENDS+= nspr4:${PORTSDIR}/devel/nspr
+LIB_DEPENDS+= libnspr4.so:${PORTSDIR}/devel/nspr
CFLAGS+= -I${LOCALBASE}/include/nspr
LDFLAGS+= -lnspr4 -pthread -lpthread -lm
CONFIGURE_ARGS+= --enable-sm-scripting --with-spidermonkey
@@ -189,17 +189,13 @@ USES+= iconv
CONFIGURE_ARGS+= ${ICONV_CONFIGURE_ARG}
.endif
-.if ${PORT_OPTIONS:MFASTMEM} && ${OSVERSION} > 1000000
-BROKEN= segfaults on 10.X with fast mem enabled
-.endif
-
#
# Elinks will try to use it if exists
#
.if exists(/usr/include/execinfo.h)
LDFLAGS+= -lexecinfo
.elif exists(${LOCALBASE}/include/execinfo.h)
-LIB_DEPENDS+= execinfo.1:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS+= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
.endif
diff --git a/www/gallery3/Makefile b/www/gallery3/Makefile
index b0bca51767ba..259221c17e55 100644
--- a/www/gallery3/Makefile
+++ b/www/gallery3/Makefile
@@ -38,7 +38,7 @@ RUN_DEPENDS+= dcraw:${PORTSDIR}/graphics/dcraw
.endif
.if ${PORT_OPTIONS:MFFMPEG}
-LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
.endif
.if ${PORT_OPTIONS:MGD}
diff --git a/www/groupoffice/Makefile b/www/groupoffice/Makefile
index 1d201e74e7bf..05e6f95ea7e8 100644
--- a/www/groupoffice/Makefile
+++ b/www/groupoffice/Makefile
@@ -42,7 +42,7 @@ USE_PHP+= calendar
.endif
.if ${PORT_OPTIONS:MWBXML}
-LIB_DEPENDS= wbxml2:${PORTSDIR}/textproc/wbxml2
+LIB_DEPENDS= libwbxml2.so:${PORTSDIR}/textproc/wbxml2
.endif
do-install:
diff --git a/www/links-hacked/Makefile b/www/links-hacked/Makefile
index 6f968713073e..a8cd001a6354 100644
--- a/www/links-hacked/Makefile
+++ b/www/links-hacked/Makefile
@@ -45,14 +45,14 @@ CONFIGURE_ARGS+= --disable-graphics --without-libjpeg --without-libtiff
.endif
.if ${PORT_OPTIONS:MSVGALIB}
-LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
+LIB_DEPENDS+= libvga.so:${PORTSDIR}/graphics/svgalib
CONFIGURE_ARGS+= --with-svgalib
.else
CONFIGURE_ARGS+= --without-svgalib
.endif
.if ${PORT_OPTIONS:MDIRECTFB}
-LIB_DEPENDS+= directfb-1.4.5:${PORTSDIR}/devel/directfb
+LIB_DEPENDS+= libdirectfb-1.4.so:${PORTSDIR}/devel/directfb
CONFIGURE_ARGS+= --with-directfb
.else
CONFIGURE_ARGS+= --without-directfb
diff --git a/www/lusca-head/Makefile b/www/lusca-head/Makefile
index 6a62027d3af0..620f5414d92e 100644
--- a/www/lusca-head/Makefile
+++ b/www/lusca-head/Makefile
@@ -209,7 +209,7 @@ external_acl+= ldap_group
libexec+= digest_ldap_auth squid_ldap_auth squid_ldap_group
.endif
.if ${PORT_OPTIONS:MSASL_AUTH}
-LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/www/opera-devel/Makefile b/www/opera-devel/Makefile
index 6d4138d45e77..cdd5fbb347b8 100644
--- a/www/opera-devel/Makefile
+++ b/www/opera-devel/Makefile
@@ -43,7 +43,7 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ! ${PORT_OPTIONS:MCUPS}
-LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-client
+LIB_DEPENDS+= libcups.so:${PORTSDIR}/print/cups-client
.endif
.if ! ${PORT_OPTIONS:MVIDEO}
diff --git a/www/squid/Makefile b/www/squid/Makefile
index e77f47518d41..dae846b77e46 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -232,7 +232,7 @@ external_acl+= ldap_group
libexec+= digest_ldap_auth squid_ldap_auth squid_ldap_group
.endif
.if ${PORT_OPTIONS:MSASL_AUTH}
-LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/www/squid32/Makefile b/www/squid32/Makefile
index 7572a7df6371..74b637cb8ff0 100644
--- a/www/squid32/Makefile
+++ b/www/squid32/Makefile
@@ -245,7 +245,7 @@ external_acl+= LDAP_group
libexec+= basic_ldap_auth ext_ldap_group_acl
.endif
.if ${PORT_OPTIONS:MAUTH_SASL}
-LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -422,7 +422,7 @@ CONFIGURE_ARGS+= --disable-follow-x-forwarded-for
.endif
.if ${PORT_OPTIONS:MECAP}
CONFIGURE_ARGS+= --enable-ecap
-LIB_DEPENDS+= ecap:${PORTSDIR}/www/libecap
+LIB_DEPENDS+= libecap.so:${PORTSDIR}/www/libecap
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.else
@@ -435,8 +435,8 @@ CONFIGURE_ARGS+= --disable-icap-client
.endif
.if ${PORT_OPTIONS:MESI}
CONFIGURE_ARGS+= --enable-esi
-LIB_DEPENDS+= expat:${PORTSDIR}/textproc/expat2 \
- xml2:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS+= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libxml2.so:${PORTSDIR}/textproc/libxml2
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2
LDFLAGS+= -L${LOCALBASE}/lib
.else
diff --git a/www/squid33/Makefile b/www/squid33/Makefile
index a889e5ee9180..71f891005718 100644
--- a/www/squid33/Makefile
+++ b/www/squid33/Makefile
@@ -252,7 +252,7 @@ external_acl+= LDAP_group
libexec+= basic_ldap_auth ext_ldap_group_acl
.endif
.if ${PORT_OPTIONS:MAUTH_SASL}
-LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -432,7 +432,7 @@ CONFIGURE_ARGS+= --disable-follow-x-forwarded-for
.endif
.if ${PORT_OPTIONS:MECAP}
CONFIGURE_ARGS+= --enable-ecap
-LIB_DEPENDS+= ecap:${PORTSDIR}/www/libecap
+LIB_DEPENDS+= libecap.so:${PORTSDIR}/www/libecap
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.else
@@ -445,8 +445,8 @@ CONFIGURE_ARGS+= --disable-icap-client
.endif
.if ${PORT_OPTIONS:MESI}
CONFIGURE_ARGS+= --enable-esi
-LIB_DEPENDS+= expat:${PORTSDIR}/textproc/expat2 \
- xml2:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS+= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libxml2.so:${PORTSDIR}/textproc/libxml2
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2
LDFLAGS+= -L${LOCALBASE}/lib
.else
diff --git a/x11/mlterm/Makefile b/x11/mlterm/Makefile
index 354d7a762353..a05769618182 100644
--- a/x11/mlterm/Makefile
+++ b/x11/mlterm/Makefile
@@ -36,7 +36,7 @@ UIM_DESC= "uim support (experimental)"
.if ${PORT_OPTIONS:MFRIBIDI}
CONFIGURE_ARGS+= --enable-fribidi
-LIB_DEPENDS+= fribidi:${PORTSDIR}/converters/fribidi
+LIB_DEPENDS+= libfribidi.so:${PORTSDIR}/converters/fribidi
PLIST_SUB+= FRIBIDI=""
.else
CONFIGURE_ARGS+= --disable-fribidi
@@ -45,7 +45,7 @@ PLIST_SUB+= FRIBIDI="@comment "
.if ${PORT_OPTIONS:MUIM}
CONFIGURE_ARGS+= --enable-uim
-LIB_DEPENDS+= uim:${PORTSDIR}/textproc/uim
+LIB_DEPENDS+= libuim.so:${PORTSDIR}/textproc/uim
PLIST_SUB+= UIM=""
.else
CONFIGURE_ARGS+= --disable-uim
@@ -54,7 +54,7 @@ PLIST_SUB+= UIM="@comment "
.if ${PORT_OPTIONS:MM17NLIB}
CONFIGURE_ARGS+= --enable-m17nlib
-LIB_DEPENDS+= m17n:${PORTSDIR}/devel/m17n-lib
+LIB_DEPENDS+= libm17n.so:${PORTSDIR}/devel/m17n-lib
PLIST_SUB+= M17NLIB=""
.else
CONFIGURE_ARGS+= --disable-m17nlib
@@ -63,7 +63,7 @@ PLIST_SUB+= M17NLIB="@comment "
.if ${PORT_OPTIONS:MSCIM}
CONFIGURE_ARGS+= --enable-scim
-LIB_DEPENDS+= scim-1.0:${PORTSDIR}/textproc/scim
+LIB_DEPENDS+= libscim-1.0.so:${PORTSDIR}/textproc/scim
PLIST_SUB+= SCIM=""
.else
CONFIGURE_ARGS+= --disable-scim
@@ -72,7 +72,7 @@ PLIST_SUB+= SCIM="@comment "
.if ${PORT_OPTIONS:MIBUS}
CONFIGURE_ARGS+= --enable-ibus
-LIB_DEPENDS+= ibus-1.0:${PORTSDIR}/textproc/ibus
+LIB_DEPENDS+= libibus-1.0.so:${PORTSDIR}/textproc/ibus
PLIST_SUB+= IBUS=""
.else
CONFIGURE_ARGS+= --disable-ibus
@@ -81,7 +81,7 @@ PLIST_SUB+= IBUS="@comment "
.if ${PORT_OPTIONS:MCAIRO}
CONFIGURE_ARGS+= --with-type-engines="xcore,xft,cairo"
-LIB_DEPENDS+= cairo:${PORTSDIR}/graphics/cairo
+LIB_DEPENDS+= libcairo.so:${PORTSDIR}/graphics/cairo
PLIST_SUB+= CAIRO=""
.else
CONFIGURE_ARGS+= --with-type-engines="xcore,xft"
@@ -97,7 +97,7 @@ PLIST_SUB+= SIXEL="@comment "
.endif
.if ${OSVERSION} < 900004
-LIB_DEPENDS+= utempter:${PORTSDIR}/sysutils/libutempter
+LIB_DEPENDS+= libutempter.so:${PORTSDIR}/sysutils/libutempter
.endif
post-configure:
diff --git a/x11/mrxvt/Makefile b/x11/mrxvt/Makefile
index 2cea667e9785..76470fafbf82 100644
--- a/x11/mrxvt/Makefile
+++ b/x11/mrxvt/Makefile
@@ -22,7 +22,7 @@ USE_XORG= x11
OPTIONS_DEFINE= DOCS JAPANESE XFT
JAPANESE_CONFIGURE_ON= --enable-xim --enable-cjk --with-encoding=eucj
-XFT_LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
+XFT_LIB_DEPENDS= libXft.so:${PORTSDIR}/x11-fonts/libXft
XFT_CONFIGURE_ENABLE= xft
.include <bsd.port.pre.mk>
diff --git a/x11/xbindkeys/Makefile b/x11/xbindkeys/Makefile
index 84469383949d..41f5a7200a16 100644
--- a/x11/xbindkeys/Makefile
+++ b/x11/xbindkeys/Makefile
@@ -26,7 +26,7 @@ WISH= ${LOCALBASE}/bin/wish8.4
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGUILE}
-LIB_DEPENDS+= guile:${PORTSDIR}/lang/guile
+LIB_DEPENDS+= libguile.so:${PORTSDIR}/lang/guile
.else
CONFIGURE_ARGS+= --disable-guile
.endif
diff --git a/x11/xvkbd/Makefile b/x11/xvkbd/Makefile
index 36f849e36164..ff170ae36563 100644
--- a/x11/xvkbd/Makefile
+++ b/x11/xvkbd/Makefile
@@ -22,7 +22,7 @@ USE_XORG= ice sm x11 xaw xext xmu xpm xt
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MXAW3D}
-LIB_DEPENDS+= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS+= libXaw3d.so:${PORTSDIR}/x11-toolkits/Xaw3d
XK_DEFSUBST+= -e 's/XCOMM define XAW3d/\#define XAW3d/;'
.endif