aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorloader <loader@FreeBSD.org>2015-09-09 01:57:12 +0800
committerloader <loader@FreeBSD.org>2015-09-09 01:57:12 +0800
commit56783699ed19e5aa8ebb361f1d18f0f48aa9c547 (patch)
treec0b21dd53791121be20ba1cfe6cc8047121c633a
parent75ca0022e671cb6e4b7fd1b064150d4c91d5ca95 (diff)
downloadfreebsd-ports-gnome-56783699ed19e5aa8ebb361f1d18f0f48aa9c547.tar.gz
freebsd-ports-gnome-56783699ed19e5aa8ebb361f1d18f0f48aa9c547.tar.zst
freebsd-ports-gnome-56783699ed19e5aa8ebb361f1d18f0f48aa9c547.zip
[NEW] devel/p5-File-Copy-Link: Extension for replacing
a link with a copy of linked file The distribution File-Copy-Link includes the modules File::Spec::Link and File::Copy::Link and the script copylink. They include routines to read and copy links. WWW: http://search.cpan.org/dist/File-Copy-Link/ Approved by: koobs, mat Differential Revision: https://reviews.freebsd.org/D3446
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-Copy-Link/Makefile20
-rw-r--r--devel/p5-File-Copy-Link/distinfo2
-rw-r--r--devel/p5-File-Copy-Link/pkg-descr5
-rw-r--r--devel/p5-File-Copy-Link/pkg-plist6
5 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8877cd3038fb..002a14e6bd71 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2218,6 +2218,7 @@
SUBDIR += p5-File-Cat
SUBDIR += p5-File-ChangeNotify
SUBDIR += p5-File-ConfigDir
+ SUBDIR += p5-File-Copy-Link
SUBDIR += p5-File-Copy-Recursive
SUBDIR += p5-File-CountLines
SUBDIR += p5-File-CreationTime
diff --git a/devel/p5-File-Copy-Link/Makefile b/devel/p5-File-Copy-Link/Makefile
new file mode 100644
index 000000000000..fe2f58201b45
--- /dev/null
+++ b/devel/p5-File-Copy-Link/Makefile
@@ -0,0 +1,20 @@
+# Created by: loader <loader@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= File-Copy-Link
+PORTVERSION= 0.140
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= loader@FreeBSD.org
+COMMENT= Extension for replacing a link with a copy of linked file
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+NO_ARCH= yes
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Copy-Link/distinfo b/devel/p5-File-Copy-Link/distinfo
new file mode 100644
index 000000000000..5d08df3f81fe
--- /dev/null
+++ b/devel/p5-File-Copy-Link/distinfo
@@ -0,0 +1,2 @@
+SHA256 (File-Copy-Link-0.140.tar.gz) = 2063656dcd38bade43dc7f1e2ef5f1b6a8086c2f15d37b334189bd2a28e8ffeb
+SIZE (File-Copy-Link-0.140.tar.gz) = 11157
diff --git a/devel/p5-File-Copy-Link/pkg-descr b/devel/p5-File-Copy-Link/pkg-descr
new file mode 100644
index 000000000000..febf64a4db94
--- /dev/null
+++ b/devel/p5-File-Copy-Link/pkg-descr
@@ -0,0 +1,5 @@
+The distribution File-Copy-Link includes the modules
+File::Spec::Link and File::Copy::Link and the script
+copylink. They include routines to read and copy links.
+
+WWW: http://search.cpan.org/dist/File-Copy-Link/
diff --git a/devel/p5-File-Copy-Link/pkg-plist b/devel/p5-File-Copy-Link/pkg-plist
new file mode 100644
index 000000000000..f8b2baae8477
--- /dev/null
+++ b/devel/p5-File-Copy-Link/pkg-plist
@@ -0,0 +1,6 @@
+bin/copylink
+%%SITE_PERL%%/File/Copy/Link.pm
+%%SITE_PERL%%/File/Spec/Link.pm
+%%PERL5_MAN3%%/File::Copy::Link.3.gz
+%%PERL5_MAN3%%/File::Spec::Link.3.gz
+man/man1/copylink.1.gz