aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2002-07-27 03:52:49 +0800
committernaddy <naddy@FreeBSD.org>2002-07-27 03:52:49 +0800
commit58153eabc7c32cb8c47e2220436d1e9c8e3396a6 (patch)
tree48a1c679540fa724c185325aecadf19b1a1cec4d
parentd2b66aba4fa32670b61406744bc11cac58735a65 (diff)
downloadfreebsd-ports-gnome-58153eabc7c32cb8c47e2220436d1e9c8e3396a6.tar.gz
freebsd-ports-gnome-58153eabc7c32cb8c47e2220436d1e9c8e3396a6.tar.zst
freebsd-ports-gnome-58153eabc7c32cb8c47e2220436d1e9c8e3396a6.zip
- Add new knob WITHOUT_MUTT_SMIME_OUTLOOK_COMPAT which is useful
in environments which do not use the outlook-builtin smime functions. - Fix a portlint WARN for a trailing whitespace. PR: 41011 Submitted by: Udo Schweigert <udo.schweigert@siemens.com> (maintainer)
-rw-r--r--mail/mutt-devel/Makefile9
-rw-r--r--mail/mutt-devel/files/extra-patch-smime-no-outlook11
2 files changed, 19 insertions, 1 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 766343b2e65d..ba5a1f2ccb8e 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -21,7 +21,7 @@
#
# In general you can choose between using the SLANG port (WITH_MUTT_SLANG)
# and ncurses (WITH_MUTT_NCURSES) which is the default. Note that you may
-# have to set the variables COLORTERM=yes and COLORFGBG=color,color in your
+# have to set the variables COLORTERM=yes and COLORFGBG=color,color in your
# environment to get slang function properly.
#
# If you want to install the mutt documentation in html format define:
@@ -50,6 +50,9 @@
# If you want to enable the pgp_outlook_compat function for use with pgp define:
# WITH_MUTT_PGP_OUTLOOK_PATCH
#
+# If you want to disable a outlook_compat function for use with smime define:
+# WITHOUT_MUTT_SMIME_OUTLOOK_COMPAT
+#
# If you want to use the rethreading functions define:
# WITH_MUTT_EDIT_THREADS
@@ -161,6 +164,10 @@ WITH_MUTT_PGP_OUTLOOK_PATCH= yes
pre-configure::
${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-pgp-outlook
.endif
+.if defined(WITHOUT_MUTT_SMIME_OUTLOOK_COMPAT)
+pre-configure::
+ ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-smime-no-outlook
+.endif
.if defined(WITH_MUTT_LOCALES_FIX)
CONFIGURE_ARGS+= --enable-locales-fix
diff --git a/mail/mutt-devel/files/extra-patch-smime-no-outlook b/mail/mutt-devel/files/extra-patch-smime-no-outlook
new file mode 100644
index 000000000000..0d10becd82db
--- /dev/null
+++ b/mail/mutt-devel/files/extra-patch-smime-no-outlook
@@ -0,0 +1,11 @@
+--- smime.c.orig Thu May 2 01:20:42 2002
++++ smime.c Fri Jul 26 18:15:19 2002
+@@ -144,7 +144,7 @@
+ {
+ len++;
+ if (!ascii_strcasecmp ((t+len), "p7m"))
+-#if 0
++#if 1
+ return SMIMEENCRYPT;
+ #else
+ /* Not sure if this is the correct thing to do, but