aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2012-03-16 10:27:04 +0800
committermezz <mezz@FreeBSD.org>2012-03-16 10:27:04 +0800
commit592760e7abf2f93d50cfcb33999728104adf9016 (patch)
tree3cfb10c1b7f6dbc1a71d65af0b13f9060441effb
parent7af2aff9c1a7a16a6f18ac792a5c85252e4f4ffe (diff)
downloadfreebsd-ports-gnome-592760e7abf2f93d50cfcb33999728104adf9016.tar.gz
freebsd-ports-gnome-592760e7abf2f93d50cfcb33999728104adf9016.tar.zst
freebsd-ports-gnome-592760e7abf2f93d50cfcb33999728104adf9016.zip
-Make the iconv optional.
PR: ports/162571 Submitted by: Pedro Giffuni <giffunip@tutopia.com> Feature safe: yes
-rw-r--r--textproc/libxml2/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index e4262bc5d65b..dc747bb953ce 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -28,17 +28,20 @@ COMMENT?= XML parser library for GNOME
USE_CSTD= gnu89
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
-USE_ICONV= yes
GNU_CONFIGURE= yes
USE_GNOME?= gnomehack pkgconfig
USE_LDCONFIG= yes
-CONFIGURE_ARGS?=--with-iconv=${LOCALBASE} \
- --with-html-dir=${PREFIX}/share/doc \
+CONFIGURE_ARGS?=---with-html-dir=${PREFIX}/share/doc \
--with-html-subdir=${PORTNAME} \
--without-python
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.if !defined(WITHOUT_ICONV)
+USE_ICONV= yes
+CONFIGURE_ARGS+=--with-iconv=${LOCALBASE}
+.endif
+
.if !defined(MASTERDIR)
MAN1= xml2-config.1 xmllint.1 xmlcatalog.1
MAN3= libxml.3