aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2013-07-06 16:56:37 +0800
committerohauer <ohauer@FreeBSD.org>2013-07-06 16:56:37 +0800
commit5a95b1f9442f8bcab870dd9aa9cd1caa6d4692cf (patch)
treec78d07cc280c49e91fc4c9104013d30ba86a063d
parent5dc670586833d060acb2459cd4edf1b5f1b8458f (diff)
downloadfreebsd-ports-gnome-5a95b1f9442f8bcab870dd9aa9cd1caa6d4692cf.tar.gz
freebsd-ports-gnome-5a95b1f9442f8bcab870dd9aa9cd1caa6d4692cf.tar.zst
freebsd-ports-gnome-5a95b1f9442f8bcab870dd9aa9cd1caa6d4692cf.zip
- enable NSS crypto driver
- use service(8) in apachectl where it makes sence - bump PORTREVISION
-rw-r--r--www/apache24/Makefile2
-rw-r--r--www/apache24/Makefile.modules2
-rw-r--r--www/apache24/files/patch-support__apachectl.in44
3 files changed, 45 insertions, 3 deletions
diff --git a/www/apache24/Makefile b/www/apache24/Makefile
index 007dd172e3ff..79248f8b3785 100644
--- a/www/apache24/Makefile
+++ b/www/apache24/Makefile
@@ -2,7 +2,7 @@
PORTNAME= apache24
PORTVERSION= 2.4.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
diff --git a/www/apache24/Makefile.modules b/www/apache24/Makefile.modules
index c9c7c95b1d8b..37126aa86a80 100644
--- a/www/apache24/Makefile.modules
+++ b/www/apache24/Makefile.modules
@@ -41,7 +41,7 @@ IGNORE= LDAP and AUTHNZ_LDAP requires APR-util to have LDAP support built in.\
. endif
. if ${PORT_OPTIONS:MSESSION_CRYPTO}
-. if !exists(${APU_CRYPTO_OPENSSL})
+. if !exists(${APU_CRYPTO_OPENSSL}) && !exists(${APU_CRYPTO_NSS})
IGNORE= SESSION_CRYPTO requires APR-util to have crypto openssl support build in.\
Please rebuild APR with crypto openssl support
. endif
diff --git a/www/apache24/files/patch-support__apachectl.in b/www/apache24/files/patch-support__apachectl.in
index 7d9f5521aeed..bd23406991e5 100644
--- a/www/apache24/files/patch-support__apachectl.in
+++ b/www/apache24/files/patch-support__apachectl.in
@@ -1,6 +1,14 @@
--- ./support/apachectl.in.orig 2012-02-01 04:47:28.000000000 +0100
+++ ./support/apachectl.in 2013-03-22 18:55:53.000000000 +0100
-@@ -66,6 +66,7 @@
+@@ -43,6 +43,7 @@
+ #
+ # the path to your httpd binary, including options if necessary
+ HTTPD='@exp_sbindir@/@progname@'
++SERVICE='/usr/sbin/service apache24'
+ #
+ # pick up any necessary environment variables
+ if test -f @exp_sbindir@/envvars; then
+@@ -66,19 +67,21 @@
# -------------------- --------------------
# |||||||||||||||||||| END CONFIGURATION SECTION ||||||||||||||||||||
@@ -8,3 +16,37 @@
# Set the maximum number of file descriptors allowed per child process.
if [ "x$ULIMIT_MAX_FILES" != "x" ] ; then
$ULIMIT_MAX_FILES
+ fi
+
+ ERROR=0
+-if [ "x$ARGV" = "x" ] ; then
+- ARGV="-h"
++if [ "x$ACMD" = "x" ] ; then
++ ACMD="-h"
+ fi
+
+ case $ACMD in
+-start|stop|restart|graceful|graceful-stop)
+- $HTTPD -k $ARGV
++start|stop|restart|rcvar|reload|graceful|gracefulstop|graceful-stop)
++# $HTTPD -k $ARGV
++ $SERVICE $( echo $ACMD | tr -d '-' )
+ ERROR=$?
+ ;;
+ startssl|sslstart|start-SSL)
+@@ -88,11 +91,13 @@
+ ERROR=2
+ ;;
+ configtest)
+- $HTTPD -t
++# $HTTPD -t
++ $SERVICE $ACMD
+ ERROR=$?
+ ;;
+ status)
+- $LYNX $STATUSURL | awk ' /process$/ { print; exit } { print } '
++# $LYNX $STATUSURL | awk ' /process$/ { print; exit } { print } '
++ $SERVICE $ACMD
+ ;;
+ fullstatus)
+ $LYNX $STATUSURL