aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-04-17 21:13:46 +0800
committerkoobs <koobs@FreeBSD.org>2015-04-17 21:13:46 +0800
commit5bd355145c5fe43c6a65a82722e503528a3acb8e (patch)
treeb3ec3e1350514526c00172f277e05833c0d228fb
parent2c983cb656102e9cffaaab9f0a90e65388c9314d (diff)
downloadfreebsd-ports-gnome-5bd355145c5fe43c6a65a82722e503528a3acb8e.tar.gz
freebsd-ports-gnome-5bd355145c5fe43c6a65a82722e503528a3acb8e.tar.zst
freebsd-ports-gnome-5bd355145c5fe43c6a65a82722e503528a3acb8e.zip
[NEW] www/py-hyper: HTTP/2 Client for Python
HTTP is changing under our feet. HTTP/1.1, our old friend, is being supplemented by the brand new HTTP/2 standard. HTTP/2 provides many benefits: improved speed, lower bandwidth usage, better connection management, and more. hyper supports the final draft of the HTTP/2 specification: additionally, it provides support for drafts 14, 15, and 16 of the HTTP/2 specification. It also supports the final draft of the HPACK specification WWW: https://hyper.readthedocs.org
-rw-r--r--www/Makefile1
-rw-r--r--www/py-hyper/Makefile25
-rw-r--r--www/py-hyper/distinfo2
-rw-r--r--www/py-hyper/pkg-descr11
4 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3a6f0ba7e5b7..f799c5f29bfa 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1573,6 +1573,7 @@
SUBDIR += py-html5lib
SUBDIR += py-http-parser
SUBDIR += py-httplib2
+ SUBDIR += py-hyper
SUBDIR += py-imdbpy
SUBDIR += py-jonpy
SUBDIR += py-jswebkit
diff --git a/www/py-hyper/Makefile b/www/py-hyper/Makefile
new file mode 100644
index 000000000000..68826dae914b
--- /dev/null
+++ b/www/py-hyper/Makefile
@@ -0,0 +1,25 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= hyper
+PORTVERSION= 0.3.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= HTTP/2 Client for Python
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} == 330 || (${PYTHON_VER} == 2.7 && ${PYTHON_REL} < 279)
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openssl>=0.14:${PORTSDIR}/security/py-openssl
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/py-hyper/distinfo b/www/py-hyper/distinfo
new file mode 100644
index 000000000000..53cb3b0ef78d
--- /dev/null
+++ b/www/py-hyper/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hyper-0.3.1.tar.gz) = a5bf8ec59a89a45549e03886505b1a797b7c2bd3b77f1c7a06d46a282c215239
+SIZE (hyper-0.3.1.tar.gz) = 250572
diff --git a/www/py-hyper/pkg-descr b/www/py-hyper/pkg-descr
new file mode 100644
index 000000000000..8c03941c7c4a
--- /dev/null
+++ b/www/py-hyper/pkg-descr
@@ -0,0 +1,11 @@
+HTTP is changing under our feet. HTTP/1.1, our old friend, is being
+supplemented by the brand new HTTP/2 standard. HTTP/2 provides many
+benefits: improved speed, lower bandwidth usage, better connection
+management, and more.
+
+hyper supports the final draft of the HTTP/2 specification:
+additionally, it provides support for drafts 14, 15, and 16 of the
+HTTP/2 specification. It also supports the final draft of the HPACK
+specification
+
+WWW: https://hyper.readthedocs.org