aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-08-03 01:22:08 +0800
committerrafan <rafan@FreeBSD.org>2006-08-03 01:22:08 +0800
commit5bfc4e9fdaa1dc1f5d63bca084cc57157c120c5e (patch)
treedf2ecebee9c869b1fc7531196c70c9ba0f14bdca
parent8f6d349f25898dbd796ef98a8262f89e82f823a3 (diff)
downloadfreebsd-ports-gnome-5bfc4e9fdaa1dc1f5d63bca084cc57157c120c5e.tar.gz
freebsd-ports-gnome-5bfc4e9fdaa1dc1f5d63bca084cc57157c120c5e.tar.zst
freebsd-ports-gnome-5bfc4e9fdaa1dc1f5d63bca084cc57157c120c5e.zip
Add p5-Crypt-OICQ, cryptographic algorithm used by OICQ protocol.
This is for chinese/oicq.
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-OICQ/Makefile29
-rw-r--r--security/p5-Crypt-OICQ/distinfo3
-rw-r--r--security/p5-Crypt-OICQ/pkg-descr4
-rw-r--r--security/p5-Crypt-OICQ/pkg-plist4
5 files changed, 41 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 9dc928a35430..0399c9c99ef4 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -355,6 +355,7 @@
SUBDIR += p5-Crypt-MySQL
SUBDIR += p5-Crypt-NULL
SUBDIR += p5-Crypt-OFB
+ SUBDIR += p5-Crypt-OICQ
SUBDIR += p5-Crypt-OTP
SUBDIR += p5-Crypt-OpenSSL-Bignum
SUBDIR += p5-Crypt-OpenSSL-DSA
diff --git a/security/p5-Crypt-OICQ/Makefile b/security/p5-Crypt-OICQ/Makefile
new file mode 100644
index 000000000000..ac157bf2a528
--- /dev/null
+++ b/security/p5-Crypt-OICQ/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Crypt-OICQ
+# Date created: Aug 01, 2006
+# Whom: Rong-En Fan <rafan@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-OICQ
+PORTVERSION= 1.1
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= rafan@FreeBSD.org
+COMMENT= Cryptographic algorithm used by OICQ protocol
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::OICQ.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-OICQ/distinfo b/security/p5-Crypt-OICQ/distinfo
new file mode 100644
index 000000000000..9e0d421eda7d
--- /dev/null
+++ b/security/p5-Crypt-OICQ/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-OICQ-1.1.tgz) = 48409e13143eb4063634884387fa71f8
+SHA256 (Crypt-OICQ-1.1.tgz) = 1c94795df1acbcb27e25a94f40e994f0f28eb925c664d5290c89cfff44ed7c58
+SIZE (Crypt-OICQ-1.1.tgz) = 5649
diff --git a/security/p5-Crypt-OICQ/pkg-descr b/security/p5-Crypt-OICQ/pkg-descr
new file mode 100644
index 000000000000..2deae3811920
--- /dev/null
+++ b/security/p5-Crypt-OICQ/pkg-descr
@@ -0,0 +1,4 @@
+This module implements the cipher used by OICQ instant messaging
+protocol, used by Tencent Technology Limited, China.
+
+WWW: http://search.cpan.org/dist/Crypt-OICQ/
diff --git a/security/p5-Crypt-OICQ/pkg-plist b/security/p5-Crypt-OICQ/pkg-plist
new file mode 100644
index 000000000000..51cd1f0ac4e1
--- /dev/null
+++ b/security/p5-Crypt-OICQ/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OICQ/.packlist
+%%SITE_PERL%%/Crypt/OICQ.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OICQ
+@dirrmtry %%SITE_PERL%%/Crypt