aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-24 18:18:43 +0800
committerpgj <pgj@FreeBSD.org>2012-06-24 18:18:43 +0800
commit5cbe721fac6b41129f8a9a531e5c656bf6f6e264 (patch)
tree1f2c133b9f133e11450cffed29fefa33dbe8f384
parent7a21637e20431dc3a9e9268627462608a5a4c612 (diff)
downloadfreebsd-ports-gnome-5cbe721fac6b41129f8a9a531e5c656bf6f6e264.tar.gz
freebsd-ports-gnome-5cbe721fac6b41129f8a9a531e5c656bf6f6e264.tar.zst
freebsd-ports-gnome-5cbe721fac6b41129f8a9a531e5c656bf6f6e264.zip
Tag-stream is a library for parsing HTML//XML to a token stream. It can
parse unstructured and malformed HTML from the web. It also provides an Enumeratee which can parse streamline html, which means it consumes constant memory. You can start from the `tests/Tests.hs` module to see what it can do. WWW: http://github.com/yihuang/tagstream-conduit Obtained from: FreeBSD Haskell
-rw-r--r--lang/ghc/bsd.hackage.mk1
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/hs-tagstream-conduit/Makefile23
-rw-r--r--textproc/hs-tagstream-conduit/distinfo2
-rw-r--r--textproc/hs-tagstream-conduit/pkg-descr6
5 files changed, 33 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 1ba41b2b705c..da354ed4491e 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -267,6 +267,7 @@ system-fileio_port= devel/hs-system-fileio
system-filepath_port= devel/hs-system-filepath
tagged_port= devel/hs-tagged
tagsoup_port= textproc/hs-tagsoup # executable
+tagstream-conduit_port= textproc/hs-tagstream-conduit
tar_port= archivers/hs-tar
temporary_port= devel/hs-temporary
Tensor_port= devel/hs-Tensor
diff --git a/textproc/Makefile b/textproc/Makefile
index 72efdb688ebf..ae43d27ad026 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -268,6 +268,7 @@
SUBDIR += hs-regex-posix
SUBDIR += hs-stringsearch
SUBDIR += hs-tagsoup
+ SUBDIR += hs-tagstream-conduit
SUBDIR += hs-texmath
SUBDIR += hs-xhtml
SUBDIR += hs-xml
diff --git a/textproc/hs-tagstream-conduit/Makefile b/textproc/hs-tagstream-conduit/Makefile
new file mode 100644
index 000000000000..77431a331154
--- /dev/null
+++ b/textproc/hs-tagstream-conduit/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: hs-tagstream-conduit
+# Date created: June 10, 2012
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tagstream-conduit
+PORTVERSION= 0.3.2
+CATEGORIES= textproc haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= streamlined html tag parser
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= attoparsec blaze-builder blaze-builder-conduit>=0.4 \
+ conduit>=0.4
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/textproc/hs-tagstream-conduit/distinfo b/textproc/hs-tagstream-conduit/distinfo
new file mode 100644
index 000000000000..b7827564c630
--- /dev/null
+++ b/textproc/hs-tagstream-conduit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/tagstream-conduit-0.3.2.tar.gz) = ae66739ab4b7999f0f8476c68c21e31d780c5d7d2803f7e1ac17a17fb2b3c8cc
+SIZE (cabal/tagstream-conduit-0.3.2.tar.gz) = 6543
diff --git a/textproc/hs-tagstream-conduit/pkg-descr b/textproc/hs-tagstream-conduit/pkg-descr
new file mode 100644
index 000000000000..2c664793c988
--- /dev/null
+++ b/textproc/hs-tagstream-conduit/pkg-descr
@@ -0,0 +1,6 @@
+Tag-stream is a library for parsing HTML//XML to a token stream. It can
+parse unstructured and malformed HTML from the web. It also provides an
+Enumeratee which can parse streamline html, which means it consumes constant
+memory.
+
+WWW: http://github.com/yihuang/tagstream-conduit