aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornik <nik@FreeBSD.org>2002-06-04 19:28:57 +0800
committernik <nik@FreeBSD.org>2002-06-04 19:28:57 +0800
commit5d172d651718b74144a01c7fc2a19d3e4767389c (patch)
tree1dbb1589a8e11129d9306c84b50ee33f82781891
parent77578d32ee3b7d666f0da437ed64da7e3ba90d89 (diff)
downloadfreebsd-ports-gnome-5d172d651718b74144a01c7fc2a19d3e4767389c.tar.gz
freebsd-ports-gnome-5d172d651718b74144a01c7fc2a19d3e4767389c.tar.zst
freebsd-ports-gnome-5d172d651718b74144a01c7fc2a19d3e4767389c.zip
Add PassiveTeX. PassiveTeX is an XML Formatting Objects processor,
written in TeX (!). To produce high quality PS or PDF output from XML files, you first convert them to the FO standard, and then run PassiveTeX over them.
-rw-r--r--print/Makefile1
-rw-r--r--print/passivetex/Makefile47
-rw-r--r--print/passivetex/distinfo1
-rw-r--r--print/passivetex/pkg-comment1
-rw-r--r--print/passivetex/pkg-descr10
-rw-r--r--print/passivetex/pkg-message8
-rw-r--r--print/passivetex/pkg-plist10
7 files changed, 78 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index bf0311d5ac32..fb4fcc92d7aa 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -103,6 +103,7 @@
SUBDIR += p5-PDFLib
SUBDIR += p5-Text-PDF
SUBDIR += panda
+ SUBDIR += passivetex
SUBDIR += pcal
SUBDIR += pclprint
SUBDIR += pdflib
diff --git a/print/passivetex/Makefile b/print/passivetex/Makefile
new file mode 100644
index 000000000000..55fef59a4352
--- /dev/null
+++ b/print/passivetex/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: passivetex
+# Date created: 9 May 2002
+# Whom: Nik Clayton <nik@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= passivetex
+PORTVERSION= 1.0
+CATEGORIES= print
+MASTER_SITES= http://www.hcu.ox.ac.uk/TEI/Software/passivetex/
+DISTFILES= passivetex.zip
+
+MAINTAINER= nik@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/share/texmf/web2c/xmltex.fmt:${PORTSDIR}/print/xmltex
+
+DIST_SUBDIR= passivetex
+NO_BUILD= yes
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/passivetex
+
+MAKE_ENV= TEXMFCNF=${FILESDIR}:${LOCALBASE}/share/texmf/web2c
+
+MESSAGE= ${PKGDIR}/pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-patch: patch-message
+
+patch-message:
+ @${SED} -e 's,%%LOCALBASE%%,${LOCALBASE},' ${MESSAGE} > ${PKGMESSAGE}
+
+do-install:
+ @cd ${WRKSRC}; TEXMFMAIN=$$(kpsewhich -expand-var '$$TEXMFMAIN'); \
+ ${MKDIR} -m 555 $$TEXMFMAIN/tex/passivetex; \
+ ${INSTALL_DATA} dummyels.sty fotex.xmt fotex.sty mlnames.sty ucharacters.sty unicode.sty $$TEXMFMAIN/tex/passivetex;
+
+post-install: rebuild-tex-database display-message
+
+rebuild-tex-database:
+ ${LOCALBASE}/bin/mktexlsr
+
+display-message:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/print/passivetex/distinfo b/print/passivetex/distinfo
new file mode 100644
index 000000000000..569509d19460
--- /dev/null
+++ b/print/passivetex/distinfo
@@ -0,0 +1 @@
+MD5 (passivetex/passivetex.zip) = a1f9667ccd3ec733193331edbf0cbbac
diff --git a/print/passivetex/pkg-comment b/print/passivetex/pkg-comment
new file mode 100644
index 000000000000..00a8801651c2
--- /dev/null
+++ b/print/passivetex/pkg-comment
@@ -0,0 +1 @@
+XSL FO processor, written in TeX
diff --git a/print/passivetex/pkg-descr b/print/passivetex/pkg-descr
new file mode 100644
index 000000000000..7947778672f9
--- /dev/null
+++ b/print/passivetex/pkg-descr
@@ -0,0 +1,10 @@
+PassiveTeX is a library of TeX macros which can be used to process
+an XML document conforming to the Formatting Objects (FO) spec.
+This provides a relatively easy mechanism to convert FO files to
+Postscript and PDF.
+
+For example, to generate a PDF file from an FO file, run
+
+ pdftex --interaction nonstopmode "&pdfxmltex" file.fo
+
+WWW: http://www.hcu.ox.ac.uk/TEI/Software/passivetex/
diff --git a/print/passivetex/pkg-message b/print/passivetex/pkg-message
new file mode 100644
index 000000000000..409dc8e0bb19
--- /dev/null
+++ b/print/passivetex/pkg-message
@@ -0,0 +1,8 @@
+PassiveTeX uses quite a lot of TeX's resources. You may find it
+necessary to increase the size of some of TeX's resource pools by
+editing the file %%LOCALBASE%%/share/texmf/web2c/texmf.cnf with any text
+editor.
+
+If you change %%LOCALBASE%%/share/texmf/web2c/texmf.cnf, delete the word
+"original" on line 1 of the file. This will prevent future
+installations of TeX from overwriting changes you've made.
diff --git a/print/passivetex/pkg-plist b/print/passivetex/pkg-plist
new file mode 100644
index 000000000000..d5eab1e43b0e
--- /dev/null
+++ b/print/passivetex/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+share/texmf/tex/passivetex/dummyels.sty
+share/texmf/tex/passivetex/fotex.xmt
+share/texmf/tex/passivetex/fotex.sty
+share/texmf/tex/passivetex/mlnames.sty
+share/texmf/tex/passivetex/ucharacters.sty
+share/texmf/tex/passivetex/unicode.sty
+@dirrm share/texmf/tex/passivetex
+@exec %D/bin/mktexlsr
+@unexec %D/bin/mktexlsr