aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2015-01-04 04:27:20 +0800
committerpawel <pawel@FreeBSD.org>2015-01-04 04:27:20 +0800
commit5dd230f975ca6557b765f18c4e483b955204f119 (patch)
treec3313114c6970120fd301926af091e91302adece
parent95167b580ce187ba1f4c32daf6a7343d295892ec (diff)
downloadfreebsd-ports-gnome-5dd230f975ca6557b765f18c4e483b955204f119.tar.gz
freebsd-ports-gnome-5dd230f975ca6557b765f18c4e483b955204f119.tar.zst
freebsd-ports-gnome-5dd230f975ca6557b765f18c4e483b955204f119.zip
Update to version 20141125
PR: 196397 Submitted by: aoyama@peach.ne.jp
-rw-r--r--net/istgt/Makefile3
-rw-r--r--net/istgt/distinfo4
-rw-r--r--net/istgt/files/patch-invalidcast84
-rw-r--r--net/istgt/files/patch-replacecrypto149
-rw-r--r--net/istgt/files/patch-src_Makefile.in13
5 files changed, 3 insertions, 250 deletions
diff --git a/net/istgt/Makefile b/net/istgt/Makefile
index 8619c626780d..e47feff30b4a 100644
--- a/net/istgt/Makefile
+++ b/net/istgt/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= istgt
-PORTVERSION= 20121028
-PORTREVISION= 2
+PORTVERSION= 20141125
CATEGORIES= net
MASTER_SITES= http://www.peach.ne.jp/archives/istgt/
diff --git a/net/istgt/distinfo b/net/istgt/distinfo
index 7fb7d9fcf657..eebf4d1a7cdf 100644
--- a/net/istgt/distinfo
+++ b/net/istgt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (istgt-20121028.tar.gz) = 2daa454767ca4b731c1eac10f095515119a09f3586fbbf1af70d344da6a7a4dc
-SIZE (istgt-20121028.tar.gz) = 274102
+SHA256 (istgt-20141125.tar.gz) = 8fa4120091ce9be694b5d2ff3d6d188386bec4921a3d0a837b6860ea3fdc79bf
+SIZE (istgt-20141125.tar.gz) = 276286
diff --git a/net/istgt/files/patch-invalidcast b/net/istgt/files/patch-invalidcast
deleted file mode 100644
index 9ae860b6c3c8..000000000000
--- a/net/istgt/files/patch-invalidcast
+++ /dev/null
@@ -1,84 +0,0 @@
---- src/istgt_iscsi.c.orig 2012-10-28 00:26:36.000000000 +0200
-+++ src/istgt_iscsi.c 2013-06-26 00:44:07.000000000 +0200
-@@ -670,16 +670,16 @@
- if (rc < 0) {
- now = time(NULL);
- if (errno == ECONNRESET) {
-- ISTGT_WARNLOG("Connection reset by peer (%s,time=%d)\n",
-- conn->initiator_name, (int)difftime(now, start));
-+ ISTGT_WARNLOG("Connection reset by peer (%s,time=%.0f)\n",
-+ conn->initiator_name, difftime(now, start));
- conn->state = CONN_STATE_EXITING;
- } else if (errno == ETIMEDOUT) {
-- ISTGT_WARNLOG("Operation timed out (%s,time=%d)\n",
-- conn->initiator_name, (int)difftime(now, start));
-+ ISTGT_WARNLOG("Operation timed out (%s,time=%.0f)\n",
-+ conn->initiator_name, difftime(now, start));
- conn->state = CONN_STATE_EXITING;
- } else {
-- ISTGT_ERRLOG("iscsi_read() failed (errno=%d,%s,time=%d)\n",
-- errno, conn->initiator_name, (int)difftime(now, start));
-+ ISTGT_ERRLOG("iscsi_read() failed (errno=%d,%s,time=%.0f)\n",
-+ errno, conn->initiator_name, difftime(now, start));
- }
- return -1;
- }
-@@ -762,8 +762,8 @@
- rc = readv(conn->sock, &iovec[0], 4);
- if (rc < 0) {
- now = time(NULL);
-- ISTGT_ERRLOG("readv() failed (%d,errno=%d,%s,time=%d)\n",
-- rc, errno, conn->initiator_name, (int)difftime(now, start));
-+ ISTGT_ERRLOG("readv() failed (%d,errno=%d,%s,time=%.0f)\n",
-+ rc, errno, conn->initiator_name, difftime(now, start));
- return -1;
- }
- if (rc == 0) {
-@@ -1257,8 +1257,8 @@
- rc = writev(conn->sock, &iovec[0], 5);
- if (rc < 0) {
- now = time(NULL);
-- ISTGT_ERRLOG("writev() failed (errno=%d,%s,time=%d)\n",
-- errno, conn->initiator_name, (int)difftime(now, start));
-+ ISTGT_ERRLOG("writev() failed (errno=%d,%s,time=%.0f)\n",
-+ errno, conn->initiator_name, difftime(now, start));
- return -1;
- }
- nbytes -= rc;
-@@ -3590,9 +3590,9 @@
- if (rc < 0) {
- now = time(NULL);
- ISTGT_ERRLOG("MCS: CmdSN(%u) error ExpCmdSN=%u "
-- "(time=%d)\n",
-+ "(time=%.0f)\n",
- CmdSN, conn->sess->ExpCmdSN,
-- (int)difftime(now, start));
-+ difftime(now, start));
- SESS_MTX_UNLOCK(conn);
- return -1;
- }
---- src/istgt_lu_disk.c.orig 2012-10-28 00:26:36.000000000 +0200
-+++ src/istgt_lu_disk.c 2013-06-26 00:44:05.000000000 +0200
-@@ -5288,9 +5288,9 @@
- MTX_UNLOCK(&lu_task->trans_mutex);
- now = time(NULL);
- ISTGT_ERRLOG("timeout trans_cond CmdSN=%u "
-- "(time=%d)\n",
-+ "(time=%.0f)\n",
- lu_task->lu_cmd.CmdSN,
-- (int)difftime(now, start));
-+ difftime(now, start));
- /* timeout */
- return -1;
- }
-@@ -5326,8 +5326,8 @@
- if (rc == ETIMEDOUT) {
- lu_task->error = 1;
- now = time(NULL);
-- ISTGT_ERRLOG("timeout trans_cond CmdSN=%u (time=%d)\n",
-- lu_task->lu_cmd.CmdSN, (int)difftime(now, start));
-+ ISTGT_ERRLOG("timeout trans_cond CmdSN=%u (time=%.0f)\n",
-+ lu_task->lu_cmd.CmdSN, difftime(now, start));
- return -1;
- }
- lu_task->error = 1;
diff --git a/net/istgt/files/patch-replacecrypto b/net/istgt/files/patch-replacecrypto
deleted file mode 100644
index 6c73138aa249..000000000000
--- a/net/istgt/files/patch-replacecrypto
+++ /dev/null
@@ -1,149 +0,0 @@
---- src/config.h.in.orig 2012-08-19 06:51:15.000000000 +0200
-+++ src/config.h.in 2013-06-26 01:30:15.000000000 +0200
-@@ -54,8 +54,8 @@
- /* Define to 1 if you have the `cam' library (-lcam). */
- #undef HAVE_LIBCAM
-
--/* Define to 1 if you have the `crypto' library (-lcrypto). */
--#undef HAVE_LIBCRYPTO
-+/* Define to 1 if you have the `md' library (-lmd). */
-+#undef HAVE_LIBMD
-
- /* Define to 1 if you have the `pthread' library (-lpthread). */
- #undef HAVE_LIBPTHREAD
---- src/istgt_md5.c.orig 2010-01-02 18:57:26.000000000 +0100
-+++ src/istgt_md5.c 2013-06-26 01:35:24.000000000 +0200
-@@ -33,7 +33,8 @@
- #include <stdint.h>
-
- #include <stddef.h>
--#include <openssl/md5.h>
-+#include <sys/types.h>
-+#include <md5.h>
-
- #include "istgt.h"
- #include "istgt_md5.h"
-@@ -41,34 +42,28 @@
- int
- istgt_md5init(ISTGT_MD5CTX *md5ctx)
- {
-- int rc;
--
- if (md5ctx == NULL)
- return -1;
-- rc = MD5_Init(&md5ctx->md5ctx);
-- return rc;
-+ MD5Init(&md5ctx->md5ctx);
-+ return 1;
- }
-
- int
- istgt_md5final(void *md5, ISTGT_MD5CTX *md5ctx)
- {
-- int rc;
--
- if (md5ctx == NULL || md5 == NULL)
- return -1;
-- rc = MD5_Final(md5, &md5ctx->md5ctx);
-- return rc;
-+ MD5Final(md5, &md5ctx->md5ctx);
-+ return 1;
- }
-
- int
- istgt_md5update(ISTGT_MD5CTX *md5ctx, const void *data, size_t len)
- {
-- int rc;
--
- if (md5ctx == NULL)
- return -1;
- if (data == NULL || len <= 0)
- return 0;
-- rc = MD5_Update(&md5ctx->md5ctx, data, len);
-- return rc;
-+ MD5Update(&md5ctx->md5ctx, data, len);
-+ return 1;
- }
---- src/istgt_md5.h.orig 2010-01-02 18:57:26.000000000 +0100
-+++ src/istgt_md5.h 2013-06-26 01:20:46.000000000 +0200
-@@ -30,7 +30,8 @@
-
- #include <stddef.h>
-
--#include <openssl/md5.h>
-+#include <sys/types.h>
-+#include <md5.h>
-
- #define ISTGT_MD5DIGEST_LEN MD5_DIGEST_LENGTH
-
---- configure.orig 2012-08-24 10:19:24 UTC
-+++ configure
-@@ -3403,7 +3403,7 @@ $as_echo "#define _GNU_SOURCE 1" >>confd
- rcdir='/etc/rc.d'
-
- ;;
--*freebsd*)
-+*dragonfly*|*freebsd*)
- tmp="/usr/ports/emulators/virtualbox-ose/work/*/include"
- if test -d "`echo $tmp`"; then
- vboxinc=$tmp
-@@ -3472,13 +3472,13 @@ _ACEOF
-
- fi
-
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for MD5_Update in -lcrypto" >&5
--$as_echo_n "checking for MD5_Update in -lcrypto... " >&6; }
--if ${ac_cv_lib_crypto_MD5_Update+:} false; then :
-+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for MD5Update in -lmd" >&5
-+$as_echo_n "checking for MD5Update in -lmd... " >&6; }
-+if ${ac_cv_lib_crypto_MD5Update+:} false; then :
- $as_echo_n "(cached) " >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lcrypto $LIBS"
-+LIBS="-lmd $LIBS"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
-
-@@ -3488,32 +3488,32 @@ cat confdefs.h - <<_ACEOF >conftest.$ac_
- #ifdef __cplusplus
- extern "C"
- #endif
--char MD5_Update ();
-+char MD5Update ();
- int
- main ()
- {
--return MD5_Update ();
-+return MD5Update ();
- ;
- return 0;
- }
- _ACEOF
- if ac_fn_c_try_link "$LINENO"; then :
-- ac_cv_lib_crypto_MD5_Update=yes
-+ ac_cv_lib_crypto_MD5Update=yes
- else
-- ac_cv_lib_crypto_MD5_Update=no
-+ ac_cv_lib_crypto_MD5Update=no
- fi
- rm -f core conftest.err conftest.$ac_objext \
- conftest$ac_exeext conftest.$ac_ext
- LIBS=$ac_check_lib_save_LIBS
- fi
--{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_crypto_MD5_Update" >&5
--$as_echo "$ac_cv_lib_crypto_MD5_Update" >&6; }
--if test "x$ac_cv_lib_crypto_MD5_Update" = xyes; then :
-+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_crypto_MD5Update" >&5
-+$as_echo "$ac_cv_lib_crypto_MD5Update" >&6; }
-+if test "x$ac_cv_lib_crypto_MD5Update" = xyes; then :
- cat >>confdefs.h <<_ACEOF
--#define HAVE_LIBCRYPTO 1
-+#define HAVE_LIBMD 1
- _ACEOF
-
-- LIBS="-lcrypto $LIBS"
-+ LIBS="-lmd $LIBS"
-
- fi
-
diff --git a/net/istgt/files/patch-src_Makefile.in b/net/istgt/files/patch-src_Makefile.in
deleted file mode 100644
index 0413898c061a..000000000000
--- a/net/istgt/files/patch-src_Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/Makefile.in.orig 2012-10-15 21:40:18.000000000 +0000
-+++ src/Makefile.in
-@@ -88,8 +88,8 @@ istgtcontrol: $(ISTGTCONTROL)
- $(CC) $(LDFLAGS) -o $@ $(ISTGTCONTROL) $(LIBS)
-
- install: install-dirs
-- $(INSTALL) -m 0755 istgt $(DESTDIR)$(bindir)
-- $(INSTALL) -m 0755 istgtcontrol $(DESTDIR)$(bindir)
-+ $(BSD_INSTALL_PROGRAM) istgt $(DESTDIR)$(bindir)
-+ $(BSD_INSTALL_PROGRAM) istgtcontrol $(DESTDIR)$(bindir)
-
- install-dirs:
- $(MKDIR_P) $(DESTDIR)$(bindir)