aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-05-15 21:44:43 +0800
committermiwi <miwi@FreeBSD.org>2013-05-15 21:44:43 +0800
commit60fba9d27a2da32ebdeb4b72c9b29e8b3653cd20 (patch)
tree0a972f0695a8618df58470927d704d213fd6e3ce
parentcbe09c6dcf7740cba355311664219689fd37b718 (diff)
downloadfreebsd-ports-gnome-60fba9d27a2da32ebdeb4b72c9b29e8b3653cd20.tar.gz
freebsd-ports-gnome-60fba9d27a2da32ebdeb4b72c9b29e8b3653cd20.tar.zst
freebsd-ports-gnome-60fba9d27a2da32ebdeb4b72c9b29e8b3653cd20.zip
- Update to 0.9.6
PR: 178584 Submitted by: Ports Fury
-rw-r--r--net/g2ipmsg/Makefile41
-rw-r--r--net/g2ipmsg/distinfo4
-rw-r--r--net/g2ipmsg/pkg-descr4
-rw-r--r--net/g2ipmsg/pkg-plist8
4 files changed, 36 insertions, 21 deletions
diff --git a/net/g2ipmsg/Makefile b/net/g2ipmsg/Makefile
index ccf34aadd283..2e55c37c3b94 100644
--- a/net/g2ipmsg/Makefile
+++ b/net/g2ipmsg/Makefile
@@ -2,31 +2,44 @@
# $FreeBSD$
PORTNAME= g2ipmsg
-PORTVERSION= 0.9.3
-PORTREVISION= 7
+PORTVERSION= 0.9.6
CATEGORIES= net gnome
-MASTER_SITES= http://www.ipmsg.org/archive/ \
- ${MASTER_SITE_LOCAL} \
- http://people.FreeBSD.org/~nork/distfiles/
-MASTER_SITE_SUBDIR= nork
-DIST_SUBDIR= gnome2
+MASTER_SITES= http://ipmsg.org/archive/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A popup style message communication tool for GNOME2
+COMMENT= Popup style message communication tool for GNOME2
-USE_GMAKE= yes
-USES= pathfix pkgconfig gettext iconv
-USE_GNOME= gnomeprefix intlhack intltool \
- libgnomeui libbonobo desktopfileutils gnomepanel
+LICENSE= GPLv2 # (or later)
+
+OPTIONS_DEFINE= GNOMEPANEL
+OPTIONS_DEFAULT= GNOMEPANEL
+GNOMEPANEL_DESC= GNOME Panel Applet
+
+USES= gettext pathfix pkgconfig
+USE_GNOME= desktopfileutils gnomeprefix libgnomeui
USE_GSTREAMER= vorbis
USE_OPENSSL= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-doxygen-doc \
+ --enable-systray \
+ --with-ssl=${OPENSSLBASE}
+MAKE_JOBS_SAFE= yes
+
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS= --enable-systray --with-ssl=${OPENSSLBASE}
+LDFLAGS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= g2ipmsg.schemas
-LDFLAGS+= "-L${LOCALBASE}/lib"
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGNOMEPANEL}
+USE_GNOME+= gnomepanel
+PLIST_SUB+= GNOMEPANEL=""
+.else
+CONFIGURE_ARGS+=--disable-applet
+PLIST_SUB+= GNOMEPANEL="@comment "
+.endif
post-install:
@update-desktop-database
diff --git a/net/g2ipmsg/distinfo b/net/g2ipmsg/distinfo
index 8e711c650290..d5b2070fdeeb 100644
--- a/net/g2ipmsg/distinfo
+++ b/net/g2ipmsg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/g2ipmsg-0.9.3.tar.gz) = aa61dac0c08eaa3d437b44ec28e11ef2852bd4ecf0452281e5ca200d8a911b19
-SIZE (gnome2/g2ipmsg-0.9.3.tar.gz) = 442872
+SHA256 (g2ipmsg-0.9.6.tar.gz) = 8a59064f42633982b11010ad44f22aa826e3c473e69eb14af43992a21ed61e7d
+SIZE (g2ipmsg-0.9.6.tar.gz) = 521263
diff --git a/net/g2ipmsg/pkg-descr b/net/g2ipmsg/pkg-descr
index 08a388ade68e..53a79c7a917c 100644
--- a/net/g2ipmsg/pkg-descr
+++ b/net/g2ipmsg/pkg-descr
@@ -1,7 +1,7 @@
IP Messenger is a pop up style message communication software for
multi platforms. It is based on TCP/IP(UDP).
- Win, Win16, Mac/MacOSX, X11R6/GTK/GNOME, Java, Div version and
+Win, Win16, Mac/MacOSX, X11R6/GTK/GNOME, Java, Div version and
all source is open to public.
-WWW: http://www.ipmsg.org/index.html.en
+WWW: http://ipmsg.org/index.html.en
diff --git a/net/g2ipmsg/pkg-plist b/net/g2ipmsg/pkg-plist
index b0288b1deeeb..5bac058e6a6a 100644
--- a/net/g2ipmsg/pkg-plist
+++ b/net/g2ipmsg/pkg-plist
@@ -1,13 +1,15 @@
bin/g2ipmsg
-bin/g2ipmsg_applet
+%%GNOMEPANEL%%bin/g2ipmsg_applet
libdata/bonobo/servers/g2ipmsg.server
share/applications/g2ipmsg.desktop
+share/locale/ja/LC_MESSAGES/g2ipmsg.mo
+share/locale/zh_CN/LC_MESSAGES/g2ipmsg.mo
share/gnome-2.0/ui/g2ipmsg.xml
-share/pixmaps/ipmsg.png
+share/pixmaps/g2ipmsg/ipmsg.png
share/pixmaps/g2ipmsg/ipmsg.xpm
share/pixmaps/g2ipmsg/ipmsgrev.xpm
+share/pixmaps/ipmsg.png
share/sounds/g2ipmsg/g2ipmsg.ogg
-share/locale/ja/LC_MESSAGES/g2ipmsg.mo
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@dirrm share/sounds/g2ipmsg