aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-03-21 19:13:49 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-03-21 19:13:49 +0800
commit610d7b81600075ec09cf66afa38ad6dbc7dd74a5 (patch)
tree93f9b09e807a0f7b3a1468c3f9ec5b4e81763475
parent364119e3b934ede4745c2bcead969d454bf4ab26 (diff)
downloadfreebsd-ports-gnome-610d7b81600075ec09cf66afa38ad6dbc7dd74a5.tar.gz
freebsd-ports-gnome-610d7b81600075ec09cf66afa38ad6dbc7dd74a5.tar.zst
freebsd-ports-gnome-610d7b81600075ec09cf66afa38ad6dbc7dd74a5.zip
- Fix dialog4ports missing when PREFIX!=LOCALBASE
PR: ports/177174 Reported by: Hirohisa Yamaguchi <umq@ueo.co.jp> With hat: portmgr
-rw-r--r--Mk/bsd.port.mk2
-rw-r--r--Tools/scripts/dialog4ports.sh4
2 files changed, 5 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 2fa3c44700ee..b0aabb50006e 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -6099,6 +6099,8 @@ D4P_ENV= PKGNAME="${PKGNAME}" \
OPTIONS_RADIO="${OPTIONS_RADIO}" \
OPTIONS_GROUP="${OPTIONS_GROUP}" \
DIALOG4PORTS="${DIALOG4PORTS}" \
+ PREFIX="${PREFIX}" \
+ LOCALBASE="${LOCALBASE}" \
PORTSDIR="${PORTSDIR}" \
MAKE="${MAKE}" \
D4PHEIGHT="${D4PHEIGHT}" \
diff --git a/Tools/scripts/dialog4ports.sh b/Tools/scripts/dialog4ports.sh
index b3303efb972a..77f3495cb668 100644
--- a/Tools/scripts/dialog4ports.sh
+++ b/Tools/scripts/dialog4ports.sh
@@ -15,7 +15,9 @@ OPTIONSFILE="$1"
if ! [ -e $DIALOG4PORTS ]; then
# If INSTALL_AS_USER is set then just build and use the WRKDIR version
- if [ -n "${INSTALL_AS_USER}" ]; then
+ # Also do this if PREFIX!=LOCALBASE to avoid missing file or double
+ # installs
+ if [ -n "${INSTALL_AS_USER}" -o "${PREFIX}" != "${LOCALBASE}" ]; then
if ! [ -d "${PORTSDIR}/${DIALOGPORT}" ]; then
echo "===> Skipping 'config' as ${DIALOGPORT} is not checked out" >&2
exit 1