aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2014-03-07 00:59:28 +0800
committerzi <zi@FreeBSD.org>2014-03-07 00:59:28 +0800
commit615897bea125722f58ee7a4b276fc4fb251fa33a (patch)
treecb66e6b61d07023ca2f95391375a3ee298059911
parentd45b2aa488fd47b1ea01bbac62c852c30c183d4b (diff)
downloadfreebsd-ports-gnome-615897bea125722f58ee7a4b276fc4fb251fa33a.tar.gz
freebsd-ports-gnome-615897bea125722f58ee7a4b276fc4fb251fa33a.tar.zst
freebsd-ports-gnome-615897bea125722f58ee7a4b276fc4fb251fa33a.zip
- Update to 5.00
- Convert to STAGE - Use new OPTIONS magic
-rw-r--r--security/stunnel/Makefile59
-rw-r--r--security/stunnel/distinfo4
-rw-r--r--security/stunnel/pkg-message5
-rw-r--r--security/stunnel/pkg-plist4
4 files changed, 31 insertions, 41 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index f05dd95cef38..d535e40daf78 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= stunnel
-PORTVERSION= 4.56
+PORTVERSION= 5.00
CATEGORIES= security
MASTER_SITES= https://www.stunnel.org/downloads/%SUBDIR%/ \
http://mirrors.zerg.biz/stunnel/%SUBDIR%/ \
@@ -17,7 +17,6 @@ MASTER_SITES= https://www.stunnel.org/downloads/%SUBDIR%/ \
http://stunnel.cybermirror.org/%SUBDIR%/ \
http://mirrors.zerg.biz/stunnel/%SUBDIR%/ \
http://mirrors.rit.edu/zi/
-MASTER_SITE_SUBDIR= . obsolete/4.x
MAINTAINER= zi@FreeBSD.org
COMMENT= SSL encryption wrapper for standard network daemons
@@ -31,20 +30,26 @@ USE_RC_SUBR= stunnel
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=/var/tmp \
- --enable-static --disable-fips
+CONFIGURE_ARGS= --localstatedir=/var/tmp --enable-static
+
+OPTIONS_DEFINE= IPV6 LIBWRAP SSL_PORT FIPS
+OPTIONS_SINGLE= THREAD
+OPTIONS_SINGLE_THREAD= FORK PTHREAD UCONTEXT
+OPTIONS_DEFAULT= PTHREAD
+
+IPV6_CONFIGURE_ENABLE= ipv6
+LIBWRAP_CONFIGURE_ENABLE= libwrap
+SSL_PORT_CONFIGURE_ON= --with-ssl="${OPENSSLBASE}"
+SSL_PORT_CONFIGURE_OFF= --with-ssl=/usr
+SSL_PORT_USE= OPENSSL=yes
+FIPS_CONFIGURE_ENABLE= fips
+
+SSL_PORT_DESC= Use OpenSSL from the ports collection
+FORK_DESC= Use the fork(3) threading model
+PTHREAD_DESC= Use the pthread(3) threading model
+UCONTEXT_DESC= Use the ucontext(3) threading model
+FIPS_DESC= Enable OpenSSL FIPS mode
-OPTIONS_DEFINE= IPV6 LIBWRAP SSL_PORT
-OPTIONS_SINGLE= THREAD
-OPTIONS_SINGLE_THREAD= FORK PTHREAD UCONTEXT
-OPTIONS_DEFAULT= PTHREAD
-
-SSL_PORT_DESC= Use OpenSSL from the ports collection
-FORK_DESC= Use the fork(3) threading model
-PTHREAD_DESC= Use the pthread(3) threading model
-UCONTEXT_DESC= Use the ucontext(3) threading model
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
STUNNEL_USER?= stunnel
@@ -53,29 +58,14 @@ STUNNEL_GROUP?= stunnel
USERS= ${STUNNEL_USER}
GROUPS= ${STUNNEL_GROUP}
-MAN8= stunnel.8 stunnel.fr.8 stunnel.pl.8
-
.if ${PORT_OPTIONS:MSSL_PORT}
-USE_OPENSSL= YES
WITH_OPENSSL_PORT= yes
-CONFIGURE_ARGS+= --with-ssl="${OPENSSLBASE}"
-.else
-CONFIGURE_ARGS+= --with-ssl=/usr
.endif
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --enable-ipv6
-.else
-CONFIGURE_ARGS+= --disable-ipv6
-.endif
-
.if ${PORT_OPTIONS:MLIBWRAP}
-CONFIGURE_ARGS+= --enable-libwrap
LDFLAGS+= -lwrap
-.else
-CONFIGURE_ARGS+= --disable-libwrap
.endif
.if ${PORT_OPTIONS:MUCONTEXT}
@@ -112,15 +102,6 @@ post-patch:
@${REINPLACE_CMD} -E -e 's|\$$\(docdir\)/examples|${EXAMPLESDIR}|g' ${WRKSRC}/tools/Makefile.in
.endif
-post-install:
- @${ECHO} ""
- @${ECHO} "**************************************************************************"
- @${ECHO} "To create and install a new certificate, type \"make cert\""
- @${ECHO} ""
- @${ECHO} "And don't forget to check out the FAQ at http://www.stunnel.org/"
- @${ECHO} "**************************************************************************"
- @${ECHO} ""
-
cert:
@${ECHO} ""
@${ECHO} "**************************************************************************"
diff --git a/security/stunnel/distinfo b/security/stunnel/distinfo
index 05e8798a05ff..e6484537e9b2 100644
--- a/security/stunnel/distinfo
+++ b/security/stunnel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (stunnel-4.56.tar.gz) = 9cae2cfbe26d87443398ce50d7d5db54e5ea363889d5d2ec8d2778a01c871293
-SIZE (stunnel-4.56.tar.gz) = 540032
+SHA256 (stunnel-5.00.tar.gz) = 88986d52a7ef1aff0cc26fc0a9830361c991baba7ee591d5cf1cc8baef75bc13
+SIZE (stunnel-5.00.tar.gz) = 586738
diff --git a/security/stunnel/pkg-message b/security/stunnel/pkg-message
new file mode 100644
index 000000000000..7bbd67faac7d
--- /dev/null
+++ b/security/stunnel/pkg-message
@@ -0,0 +1,5 @@
+**************************************************************************
+To create and install a new certificate, type "make cert"
+
+And don't forget to check out the FAQ at http://www.stunnel.org/
+**************************************************************************
diff --git a/security/stunnel/pkg-plist b/security/stunnel/pkg-plist
index f7a08d07596c..e0c975206ff9 100644
--- a/security/stunnel/pkg-plist
+++ b/security/stunnel/pkg-plist
@@ -1,9 +1,13 @@
+@comment $FreeBSD$
bin/stunnel
bin/stunnel3
%%ETCDIR%%/stunnel.conf-sample
lib/stunnel/libstunnel.a
lib/stunnel/libstunnel.la
lib/stunnel/libstunnel.so
+man/man8/stunnel.8.gz
+man/man8/stunnel.fr.8.gz
+man/man8/stunnel.pl.8.gz
%%PORTDOCS%%%%DOCSDIR%%/stunnel.html
%%PORTDOCS%%%%DOCSDIR%%/stunnel.fr.html
%%PORTDOCS%%%%DOCSDIR%%/stunnel.pl.html