aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2007-01-16 20:45:12 +0800
committerbsam <bsam@FreeBSD.org>2007-01-16 20:45:12 +0800
commit616d2a3731650ff1546916c03238cbef62dc7210 (patch)
tree8544ce7afed760e17ec6b4933b403a1e72fc8281
parent602345cea4be9602c7177d757e95ee759ae59298 (diff)
downloadfreebsd-ports-gnome-616d2a3731650ff1546916c03238cbef62dc7210.tar.gz
freebsd-ports-gnome-616d2a3731650ff1546916c03238cbef62dc7210.tar.zst
freebsd-ports-gnome-616d2a3731650ff1546916c03238cbef62dc7210.zip
. correct init scripts, [1] [2]
. bump PORTREVISIONs. PR: 107894 [1], 107895 [2] Submitted by: Paul Schmehl <pauls at utdallas.edu> (maintainer) [1], [2]
-rw-r--r--security/sguil-sensor/Makefile1
-rw-r--r--security/sguil-sensor/files/sensor_agent.sh.in17
-rw-r--r--security/sguil-server/Makefile1
-rw-r--r--security/sguil-server/files/sguild.sh.in17
4 files changed, 6 insertions, 30 deletions
diff --git a/security/sguil-sensor/Makefile b/security/sguil-sensor/Makefile
index 9643e2953548..2ef7ebfb891d 100644
--- a/security/sguil-sensor/Makefile
+++ b/security/sguil-sensor/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sguil-sensor
PORTVERSION= 0.6.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sguil
diff --git a/security/sguil-sensor/files/sensor_agent.sh.in b/security/sguil-sensor/files/sensor_agent.sh.in
index e87906716d25..cf3a66e3eb62 100644
--- a/security/sguil-sensor/files/sensor_agent.sh.in
+++ b/security/sguil-sensor/files/sensor_agent.sh.in
@@ -20,8 +20,8 @@ name="sensor_agent"
rcvar=`set_rcvar`
command="%%PREFIX%%/bin/%%SGUILDIR%%/sensor_agent.tcl"
procname="%%PREFIX%%/bin/tclsh8.4"
-check_process="${command} /bin/sh"
-stop_cmd="sensor_agent_stop"
+pidfile="/var/run/${name}.pid"
+check_pidfile="${pidfile} ${procname} /bin/sh"
[ -z "$sensor_agent_enable" ] && sensor_agent_enable="NO"
[ -z "$sensor_agent_conf" ] && sensor_agent_conf="%%PREFIX%%/etc/sensor_agent.conf"
@@ -29,18 +29,5 @@ stop_cmd="sensor_agent_stop"
[ -n "$sensor_agent_conf" ] && sensor_agent_flags="$sensor_agent_flags -c $sensor_agent_conf"
-sensor_agent_stop() {
- if [ -z "${rc_pid}" ]; then
- echo "${name} not running?"
- else
- echo "Stopping ${name}"
- kill ${sig_stop} ${rc_pid}
- wait_for_pids ${rc_pid}
- if [ -f "/var/run/${name}.pid" ]; then
- `rm -f /var/run/${name}.pid`
- fi
- fi
-}
-
load_rc_config $name
run_rc_command "$1"
diff --git a/security/sguil-server/Makefile b/security/sguil-server/Makefile
index 002ff4d25397..950a4093c5a4 100644
--- a/security/sguil-server/Makefile
+++ b/security/sguil-server/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sguil-server
PORTVERSION= 0.6.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sguil
diff --git a/security/sguil-server/files/sguild.sh.in b/security/sguil-server/files/sguild.sh.in
index 5b8255ee2e7a..9bc712efe3c3 100644
--- a/security/sguil-server/files/sguild.sh.in
+++ b/security/sguil-server/files/sguild.sh.in
@@ -19,26 +19,13 @@ rcvar=`set_rcvar`
command="%%PREFIX%%/bin/${name}"
procname="%%TCLSH%%"
-check_process="${command} /bin/sh"
-stop_cmd="sguild_stop"
+pidfile="/var/run/${name}.pid"
+check_pidfile="${pidfile} ${procname} /bin/sh"
sguild_enable=${sguild_enable-NO}
sguild_conf=${sguild_conf-%%PREFIX%%/etc/%%SGUILDIR%%/sguild.conf}
sguild_flags=${sguild_flags--D}
[ -n "$sguild_conf" ] && sguild_flags="$sguild_flags -c $sguild_conf"
-sguild_stop() {
- if [ -z "${rc_pid}" ]; then
- echo "${name} not running?"
- else
- echo "Stopping ${name}."
- `/bin/kill -9 ${rc_pid}`
- wait_for_pids "${rc_pid}"
- if [ -f "/var/run/${name}.pid" ]; then
- `rm -f /var/run/${name}.pid`
- fi
- fi
-}
-
load_rc_config ${name}
run_rc_command "$1"