aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-07-07 20:55:49 +0800
committerkoobs <koobs@FreeBSD.org>2014-07-07 20:55:49 +0800
commit6216fc0124a6b1ba30d441906bd6e9fbad28f875 (patch)
treea703390698a2b196445aa94157a00c2e76571b4d
parent71b08ae1bbc2f17754b4fd2addcdd7204e4485fa (diff)
downloadfreebsd-ports-gnome-6216fc0124a6b1ba30d441906bd6e9fbad28f875.tar.gz
freebsd-ports-gnome-6216fc0124a6b1ba30d441906bd6e9fbad28f875.tar.zst
freebsd-ports-gnome-6216fc0124a6b1ba30d441906bd6e9fbad28f875.zip
[NEW] sysutils/py-execnet: Distributed Python deployment and communication
execnet provides a share-nothing model with channel-send/receive communication for distributing execution across many Python interpreters across version, platform and network barriers. It has a minimal and fast API targetting the following uses: * Distribute tasks to (many) local or remote CPUs * Write and deploy hybrid multi-process applications * Write scripts to administer multiple environments WWW: https://codespeak.net/execnet
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-execnet/Makefile19
-rw-r--r--sysutils/py-execnet/distinfo2
-rw-r--r--sysutils/py-execnet/pkg-descr10
4 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 1f1dd0e160e1..b4ac55ff63aa 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -726,6 +726,7 @@
SUBDIR += py-bcfg2
SUBDIR += py-danzfs
SUBDIR += py-drmaa
+ SUBDIR += py-execnet
SUBDIR += py-ezjailremote
SUBDIR += py-filelike
SUBDIR += py-glances
diff --git a/sysutils/py-execnet/Makefile b/sysutils/py-execnet/Makefile
new file mode 100644
index 000000000000..fdea9dca9b21
--- /dev/null
+++ b/sysutils/py-execnet/Makefile
@@ -0,0 +1,19 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= execnet
+PORTVERSION= 1.2.0
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Distributed Python deployment and communication
+
+LICENSE= MIT
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-execnet/distinfo b/sysutils/py-execnet/distinfo
new file mode 100644
index 000000000000..08a2bcc15b1b
--- /dev/null
+++ b/sysutils/py-execnet/distinfo
@@ -0,0 +1,2 @@
+SHA256 (execnet-1.2.0.tar.gz) = 951714caa0ae80237f4ffc1f08450e9e2e5f8f902beaf1ad294020875d6f8c2c
+SIZE (execnet-1.2.0.tar.gz) = 163876
diff --git a/sysutils/py-execnet/pkg-descr b/sysutils/py-execnet/pkg-descr
new file mode 100644
index 000000000000..6b93a0b862ff
--- /dev/null
+++ b/sysutils/py-execnet/pkg-descr
@@ -0,0 +1,10 @@
+execnet provides a share-nothing model with channel-send/receive communication
+for distributing execution across many Python interpreters across version,
+platform and network barriers. It has a minimal and fast API targetting the
+following uses:
+
+ * Distribute tasks to (many) local or remote CPUs
+ * Write and deploy hybrid multi-process applications
+ * Write scripts to administer multiple environments
+
+WWW: https://codespeak.net/execnet