aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-10-27 20:08:02 +0800
committerwg <wg@FreeBSD.org>2013-10-27 20:08:02 +0800
commit630f271a9f9ab394316da3b5c8228aeaf2ef2f9b (patch)
tree2065cec7fa09108df8b930e2a21aa62d11211d13
parentffc054dbe48a1d07fb4a32c18935f13287ef03f4 (diff)
downloadfreebsd-ports-gnome-630f271a9f9ab394316da3b5c8228aeaf2ef2f9b.tar.gz
freebsd-ports-gnome-630f271a9f9ab394316da3b5c8228aeaf2ef2f9b.tar.zst
freebsd-ports-gnome-630f271a9f9ab394316da3b5c8228aeaf2ef2f9b.zip
multimedia/tvheadend: link against ffmpeg
- Link using ffmpeg instead of ffmpeg1 Approved by: portmgr (bapt, implicit)
-rw-r--r--multimedia/tvheadend/Makefile2
-rw-r--r--multimedia/tvheadend/files/patch-configure36
2 files changed, 1 insertions, 37 deletions
diff --git a/multimedia/tvheadend/Makefile b/multimedia/tvheadend/Makefile
index 9355b7f97025..b04ab4dc202e 100644
--- a/multimedia/tvheadend/Makefile
+++ b/multimedia/tvheadend/Makefile
@@ -68,7 +68,7 @@ DVBCSA_LIB_DEPENDS= libdvbcsa.so:${PORTSDIR}/multimedia/libdvbcsa
DVBCSA_CONFIGURE_ON= --enable-dvbcsa
DVBCSA_CONFIGURE_OFF= --disable-dvbcsa
-FFMPEG_LIB_DEPENDS= libavcodec1.so:${PORTSDIR}/multimedia/ffmpeg1
+FFMPEG_LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
FFMPEG_CONFIGURE_ON= --enable-libav
FFMPEG_CONFIGURE_OFF= --disable-libav
diff --git a/multimedia/tvheadend/files/patch-configure b/multimedia/tvheadend/files/patch-configure
deleted file mode 100644
index dc88c0c2bcfe..000000000000
--- a/multimedia/tvheadend/files/patch-configure
+++ /dev/null
@@ -1,36 +0,0 @@
---- configure.bak 2013-07-26 18:17:22.000000000 +0200
-+++ configure 2013-08-11 16:45:03.066835565 +0200
-@@ -122,27 +122,27 @@
- if enabled_or_auto libav; then
- has_libav=true
-
-- if $has_libav && ! check_pkg libavcodec "<=55.0.0"; then
-+ if $has_libav && ! check_pkg libavcodec1 "<=55.0.0"; then
- has_libav=false
- fi
-
-- if $has_libav && ! check_pkg libavcodec ">=52.96.0"; then
-+ if $has_libav && ! check_pkg libavcodec1 ">=52.96.0"; then
- has_libav=false
- fi
-
-- if $has_libav && ! check_pkg libavutil ">=50.43.0"; then
-+ if $has_libav && ! check_pkg libavutil1 ">=50.43.0"; then
- has_libav=false
- fi
-
-- if $has_libav && ! check_pkg libavformat "<=55.0.0"; then
-+ if $has_libav && ! check_pkg libavformat1 "<=55.0.0"; then
- has_libav=false
- fi
-
-- if $has_libav && ! check_pkg libavformat ">=53.10.0"; then
-+ if $has_libav && ! check_pkg libavformat1 ">=53.10.0"; then
- has_libav=false
- fi
-
-- if $has_libav && ! check_pkg libswscale ">=0.13.0"; then
-+ if $has_libav && ! check_pkg libswscale1 ">=0.13.0"; then
- has_libav=false
- fi
-