aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2008-04-09 02:29:46 +0800
committerahze <ahze@FreeBSD.org>2008-04-09 02:29:46 +0800
commit6318a1a55adce038131116af344a47ebff181368 (patch)
tree0fbc316bec3b676fe65db0ca2d7606683314e6f2
parente2334a5121414a4044371a7a306fa5b850b33150 (diff)
downloadfreebsd-ports-gnome-6318a1a55adce038131116af344a47ebff181368.tar.gz
freebsd-ports-gnome-6318a1a55adce038131116af344a47ebff181368.tar.zst
freebsd-ports-gnome-6318a1a55adce038131116af344a47ebff181368.zip
Add ion3
Ion is a simple but extensible Window Manager that is closer to Ratpoison and PWM than to anything else. With Ion, the screen is divided into frames, and each program simply lives in the frame it's provided. All Ion commands are keyboard-based. Ion is also highly configurable and extensible through Lua. Think of Ion like an X11 version of Screen. WWW: http://modeemi.cs.tut.fi/~tuomov/ion/ Submitted by: adamw Repocopied by: marcus Repocopied from: x11-wm/ion-2
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/ion3/Makefile31
-rw-r--r--x11-wm/ion3/distinfo9
-rw-r--r--x11-wm/ion3/files/patch-rules.mk10
-rw-r--r--x11-wm/ion3/files/patch-system.mk111
-rw-r--r--x11-wm/ion3/pkg-descr26
-rw-r--r--x11-wm/ion3/pkg-plist147
7 files changed, 168 insertions, 167 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index ae85abe44cf7..b2affe2b2066 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -75,6 +75,7 @@
SUBDIR += icewm
SUBDIR += ion
SUBDIR += ion-2
+ SUBDIR += ion3
SUBDIR += jewel
SUBDIR += jwm
SUBDIR += kahakai
diff --git a/x11-wm/ion3/Makefile b/x11-wm/ion3/Makefile
index 7f140e932064..4c3149d10440 100644
--- a/x11-wm/ion3/Makefile
+++ b/x11-wm/ion3/Makefile
@@ -6,32 +6,23 @@
# $FreeBSD$
#
-PORTNAME= ion-2
-PORTVERSION= 20040729
-PORTREVISION= 2
+PORTNAME= ion3
+PORTVERSION= 20080207
CATEGORIES= x11-wm
MASTER_SITES= http://modeemi.fi/~tuomov/dl/
+DISTNAME= ${PORTNAME:C/([0-9])/-\1/}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= adamw@FreeBSD.org
COMMENT= A tiling tabbed window manager
-CONFLICTS= ion-2002* ion-devel-* pwm-*
-
-USE_X_PREFIX= yes
-USE_AUTOTOOLS= libtool:15 libltdl:15
-USE_LUA= 5.0
+USE_XORG= x11 xext
+USE_LUA= 5.1
USE_GMAKE= yes
-MAKE_ENV= DEFINES="${IONDEFINES}"
-GNU_CONFIGURE= yes
-
-.if !defined(WITH_MULTIBYTE)
-IONDEFINES+= -DCF_NO_MB_SUPPORT
-.endif
-
-MAN1= ion.1 pwm.1
-DOCSDIR= share/doc/ion
+USE_GETTEXT=yes
+# ion3 clobbers $CFLAGS because it hates puppies
+MAKE_ENV= PORT_CFLAGS="${CFLAGS}"
-# NO, I don't want to use configure but ion's author system.mk
-do-configure:
+MANLANG= "" cs fi
+MAN1= ion3.1 pwm3.1
.include <bsd.port.mk>
diff --git a/x11-wm/ion3/distinfo b/x11-wm/ion3/distinfo
index 9b911ec5512d..75a52a624a5d 100644
--- a/x11-wm/ion3/distinfo
+++ b/x11-wm/ion3/distinfo
@@ -1,3 +1,6 @@
-MD5 (ion-2-20040729.tar.gz) = d7d98baa41635c1989e423adf76eb2ac
-SHA256 (ion-2-20040729.tar.gz) = 8c8b7ef0cc6a98d409bde1b9b3f5159a2e632b4e78768e13cca0da174649a162
-SIZE (ion-2-20040729.tar.gz) = 399367
+MD5 (ion-3-20080207.tar.gz) = a3673c29c367106e5c4919ac33726eec
+SHA256 (ion-3-20080207.tar.gz) = 8e2cfe11ac762290eb6dfdaa0c91947f5f5ee15a8860caf3769f525087a1846f
+SIZE (ion-3-20080207.tar.gz) = 653316
+MD5 (ion-doc-3-20080207.tar.gz) = bfdcea5964177ca077ebe0ddb935b849
+SHA256 (ion-doc-3-20080207.tar.gz) = 66dc41e686899bb37462c981b3adc4dccd40e61d5771d476466f228bcbca47ac
+SIZE (ion-doc-3-20080207.tar.gz) = 937819
diff --git a/x11-wm/ion3/files/patch-rules.mk b/x11-wm/ion3/files/patch-rules.mk
deleted file mode 100644
index 5e7292efdd52..000000000000
--- a/x11-wm/ion3/files/patch-rules.mk
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./rules.mk.orig Thu Jul 29 00:10:32 2004
-+++ ./rules.mk Mon Jul 17 21:50:19 2006
-@@ -91,6 +91,7 @@
- module_install:
- $(INSTALLDIR) $(MODULEDIR)
- $(LIBTOOL) --mode=install $(INSTALL) -s -m $(BIN_MODE) $(MODULE).la $(MODULEDIR)
-+ $(INSTALL) -m $(BIN_MODE) $(MODULE).la $(MODULEDIR)
-
- clean_objs:
- $(RM) -f $(OBJS)
diff --git a/x11-wm/ion3/files/patch-system.mk b/x11-wm/ion3/files/patch-system.mk
index 80061f5ff69e..838d03207f58 100644
--- a/x11-wm/ion3/files/patch-system.mk
+++ b/x11-wm/ion3/files/patch-system.mk
@@ -1,75 +1,94 @@
---- ./system.mk.orig Thu Jul 29 00:10:32 2004
-+++ ./system.mk Mon Jul 17 21:53:01 2006
-@@ -7,7 +7,7 @@
- ## Installation paths
- ##
+--- system.mk.orig 2008-02-05 12:42:06.000000000 -0500
++++ system.mk 2008-04-08 00:14:27.000000000 -0400
+@@ -8,7 +8,7 @@
+ # Installation path prefix. Unless you know what you're doing, the default
+ # of /usr/local is likely the correct choice.
-PREFIX=/usr/local
+#PREFIX=/usr/local
# Unless you are creating a package conforming to some OS's standards, you
# probably do not want to modify the following directories:
-@@ -19,7 +19,7 @@
+@@ -20,7 +20,7 @@
# Some .lua files and ion-* shell scripts
- SHAREDIR=$(PREFIX)/share/ion
+ SHAREDIR=$(PREFIX)/share/ion3
# Manual pages
-MANDIR=$(PREFIX)/share/man
+MANDIR=$(PREFIX)/man
# Some documents
- DOCDIR=$(PREFIX)/share/doc/ion
+ DOCDIR=$(PREFIX)/share/doc/ion3
# Nothing at the moment
-@@ -42,11 +42,11 @@
- # libtool because even more-recent-than-libtool-1.4.3 releases of those
- # OSes only have an _ancient_ 1.3.x libtool that _will_ _not_ _work even
- # though a lot of libltdl-using apps require 1.4.3.
--LIBTOOL=libtool
-+LIBTOOL=$(LOCALBASE)/bin/libtool --tag=CC
-
- # Settings for compiling and linking to ltdl
--LTDL_INCLUDES=
--LTDL_LIBS=-lltdl
-+LTDL_INCLUDES=-I$(LOCALBASE)/include
-+LTDL_LIBS=-L$(LOCALBASE)/lib -lltdl
-
- # The following should do it if you have manually installed libtool 1.5 in
- # $(LIBTOOLDIR).
-@@ -72,11 +72,11 @@
-
- # If you have installed Lua 5.0 from the official tarball without changing
+@@ -53,7 +53,7 @@
+
+ # Flags to link with libdl. Even if PRELOAD_MODULES=1, you may need this
+ # setting (for e.g. Lua, when not instructed by pkg-config).
+-DL_LIBS=-ldl
++#DL_LIBS=-ldl
+
+
+ ##
+@@ -62,11 +62,11 @@
+
+ # If you have installed Lua 5.1 from the official tarball without changing
# paths, this should do it.
-LUA_DIR=/usr/local
--LUA_LIBS = -L$(LUA_DIR)/lib -R$(LUA_DIR)/lib -llua -llualib
+-LUA_LIBS = -L$(LUA_DIR)/lib -llua
-LUA_INCLUDES = -I$(LUA_DIR)/include
-LUA=$(LUA_DIR)/bin/lua
-LUAC=$(LUA_DIR)/bin/luac
+LUA_DIR=$(LOCALBASE)
-+LUA_LIBS = -L$(LUA_LIBDIR) -R$(LUA_LIBDIR) -llua -llualib
++LUA_LIBS = -L$(LUA_LIBDIR) -llua
+LUA_INCLUDES = -I$(LUA_INCDIR)
+LUA=$(LUA_BINDIR)/lua
+LUAC=$(LUA_BINDIR)/luac
# If you are using the Debian packages, the following settings should be
# what you want.
-@@ -90,7 +90,7 @@
- ## X libraries, includes and options
+@@ -81,7 +81,7 @@
##
+ # Paths
-X11_PREFIX=/usr/X11R6
+X11_PREFIX=$(X11BASE)
# SunOS/Solaris
#X11_PREFIX=/usr/openwin
-@@ -119,7 +119,7 @@
- # asprintf and vasprintf in the c library. (gnu libc has.)
- # If HAS_SYSTEM_ASPRINTF is not defined, an implementation
- # in sprintf_2.2/ is used.
+@@ -90,7 +90,7 @@
+
+ # XFree86 libraries up to 4.3.0 have a bug that can cause a segfault.
+ # The following setting should work around that situation.
+-DEFINES += -DCF_XFREE86_TEXTPROP_BUG_WORKAROUND
++#DEFINES += -DCF_XFREE86_TEXTPROP_BUG_WORKAROUND
+
+ # Use the Xutf8 routines (XFree86 extension) instead of the Xmb routines
+ # in an UTF-8 locale. (No, you don't need this in UTF-8 locales, and
+@@ -113,12 +113,14 @@
+ #DEFINES += -DCF_NO_LOCALE -DCF_NO_GETTEXT
+
+ # On some other systems you may need to explicitly link against libintl.
+-#EXTRA_LIBS += -lintl
++EXTRA_LIBS += -lintl
+ # You may also need to give the location of its headers. The following
+ # should work on Mac OS X (which needs the above option as well) with
+ # macports.
+ #EXTRA_INCLUDES += -I/opt/local/include
+
++EXTRA_INCLUDES+= -I$(LOCALBASE)/include $(PORT_CFLAGS)
++EXTRA_LIBS+= -L$(LOCALBASE)/lib
+
+ ##
+ ## libc
+@@ -127,7 +129,7 @@
+ # You may uncomment this if you know that your system C libary provides
+ # asprintf and vasprintf. (GNU libc does.) If HAS_SYSTEM_ASPRINTF is not
+ # defined, an implementation provided in libtu/sprintf_2.2/ is used.
-#HAS_SYSTEM_ASPRINTF=1
+HAS_SYSTEM_ASPRINTF=1
-
- # If you're on an archaic system (such as relatively recent *BSD releases)
-@@ -132,16 +132,16 @@
- ## C compiler
+ # The following setting is needed with GNU libc for clock_gettime and the
+ # monotonic clock. Other systems may not need it, or may not provide a
+@@ -149,15 +151,15 @@
+ ## C compiler.
##
-CC=gcc
@@ -80,17 +99,15 @@
WARN= -W -Wimplicit -Wreturn-type -Wswitch -Wcomment \
-Wtrigraphs -Wformat -Wchar-subscripts \
- -Wparentheses -pedantic -Wuninitialized
-+ -Wparentheses -Wuninitialized
++ -Wparentheses
--CFLAGS=-g -Os $(WARN) $(DEFINES) $(EXTRA_INCLUDES) $(INCLUDES)
--LDFLAGS=-g -Os $(EXTRA_LIBS) $(LIBS)
-+CFLAGS+= $(WARN) $(DEFINES) $(EXTRA_INCLUDES) $(INCLUDES)
-+LDFLAGS= $(EXTRA_LIBS) $(LIBS)
+-CFLAGS=-Os $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
++CFLAGS= $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
+ LDFLAGS=$(LIBS) $(EXTRA_LIBS)
+ EXPORT_DYNAMIC=-Xlinker --export-dynamic
- # The following options are mainly for development use and can be used
- # to check that the code seems to conform to some standards. Depending
-@@ -154,7 +154,7 @@
- #POSIX_SOURCE=-D_POSIX_SOURCE
+@@ -172,7 +174,7 @@
+ #POSIX_SOURCE=-D_POSIX_C_SOURCE=200112L
# Most systems
-#XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
diff --git a/x11-wm/ion3/pkg-descr b/x11-wm/ion3/pkg-descr
index 20d61b9ef91b..2547e50851ca 100644
--- a/x11-wm/ion3/pkg-descr
+++ b/x11-wm/ion3/pkg-descr
@@ -1,20 +1,10 @@
-Ion (based on PWM) is a new kind of window manager that brings a
-text-editorish, keyboard friendly user interface to window management.
-
-Modern GUIs are unusable. Overlapping windows are hard to manage, especially
-from the keyboard, and the user often ends up in a jungle. Not to mention the
-application programs, which are even worse. Mouse-based search-and-click
-interfaces are slow - keyboard is fast having learnt the commands. Ion (the
-last three letters of vision =-) was written as an example and an experiment of
-something presumably better (just the window manager, though).
-
-Ion simply divides the screen into frames that take the whole screen. Big
-displays have so much space that this is convenient and smaller displays
-couldn't show more than one window at a time anyway. The frames can be split
-and growing the size of one will shrink others. Alike in PWM, clients can be
-moved between frames and multiple clients can be attached to one frame.
-
-With Ion you will hardly ever have to touch the mouse again for navigation
-between windows and the windows are always in order.
+Ion is a simple but extensible Window Manager that is closer to
+Ratpoison and PWM than to anything else.
+
+With Ion, the screen is divided into frames, and each program simply
+lives in the frame it's provided. All Ion commands are keyboard-based.
+Ion is also highly configurable and extensible through Lua.
+
+Think of Ion like an X11 version of Screen.
WWW: http://modeemi.cs.tut.fi/~tuomov/ion/
diff --git a/x11-wm/ion3/pkg-plist b/x11-wm/ion3/pkg-plist
index beaa7ec4b33e..1a9b9fa6ab35 100644
--- a/x11-wm/ion3/pkg-plist
+++ b/x11-wm/ion3/pkg-plist
@@ -1,69 +1,78 @@
-bin/ion
-bin/pwm
-etc/ion/dock-draw.lua
-etc/ion/dock.lua
-etc/ion/draw.lua
-etc/ion/floatws.lua
-etc/ion/ion-bindings.lua
-etc/ion/ion-menus.lua
-etc/ion/ion.lua
-etc/ion/ionws.lua
-etc/ion/kludges.lua
-etc/ion/look-brownsteel.lua
-etc/ion/look-clean.lua
-etc/ion/look-cleanios.lua
-etc/ion/look-cleanviolet.lua
-etc/ion/look-dusky.lua
-etc/ion/look-greyviolet.lua
-etc/ion/look-ios.lua
-etc/ion/look-simpleblue.lua
-etc/ion/look-wheat2.lua
-etc/ion/menu.lua
-etc/ion/pwm-bindings.lua
-etc/ion/pwm-menus.lua
-etc/ion/pwm.lua
-etc/ion/query.lua
-lib/ion/de.a
-lib/ion/de.la
-lib/ion/de.so
-lib/ion/dock.a
-lib/ion/dock.la
-lib/ion/dock.so
-lib/ion/floatws.a
-lib/ion/floatws.la
-lib/ion/floatws.so
-lib/ion/ion-completefile
-lib/ion/ionws.a
-lib/ion/ionws.la
-lib/ion/ionws.so
-lib/ion/menu.a
-lib/ion/menu.la
-lib/ion/menu.so
-lib/ion/query.a
-lib/ion/query.la
-lib/ion/query.so
-lib/ion/lc/ioncore-efbb.lc
-lib/ion/lc/ioncorelib.lc
-lib/ion/lc/ioncorelib-mplexfns.lc
-lib/ion/lc/menulib.lc
-lib/ion/lc/querylib.lc
-share/ion/delib.lua
-share/ion/ion-edit
-share/ion/ion-man
-share/ion/ion-runinxterm
-share/ion/ion-ssh
-share/ion/ion-view
-share/ion/ioncore-efbb.lua
-share/ion/ioncorelib-mplexfns.lua
-share/ion/ioncorelib.lua
-share/ion/menulib.lua
-share/ion/querylib.lua
-share/ion/welcome_message.txt
-share/doc/ion/README
-share/doc/ion/LICENSE
-share/doc/ion/ChangeLog
-@dirrm lib/ion/lc
-@dirrm lib/ion
-@dirrm share/ion
-@dirrm share/doc/ion
-@dirrmtry etc/ion
+bin/ion3
+bin/pwm3
+etc/ion3/cfg_defaults.lua
+etc/ion3/cfg_dock.lua
+etc/ion3/cfg_ion.lua
+etc/ion3/cfg_ioncore.lua
+etc/ion3/cfg_kludges.lua
+etc/ion3/cfg_layouts.lua
+etc/ion3/cfg_menu.lua
+etc/ion3/cfg_pwm.lua
+etc/ion3/cfg_query.lua
+etc/ion3/cfg_sp.lua
+etc/ion3/cfg_statusbar.lua
+etc/ion3/cfg_tiling.lua
+etc/ion3/look.lua
+etc/ion3/look_brownsteel.lua
+etc/ion3/look_clean.lua
+etc/ion3/look_cleanios.lua
+etc/ion3/look_cleanviolet.lua
+etc/ion3/look_dusky.lua
+etc/ion3/look_greenlight.lua
+etc/ion3/look_greyviolet.lua
+etc/ion3/look_ios.lua
+etc/ion3/look_newviolet.lua
+etc/ion3/look_simpleblue.lua
+etc/ion3/lookcommon_clean.lua
+etc/ion3/lookcommon_emboss.lua
+lib/ion3/bin/ion-completefile
+lib/ion3/bin/ion-statusd
+lib/ion3/lc/de.lc
+lib/ion3/lc/ioncore_bindings.lc
+lib/ion3/lc/ioncore_efbb.lc
+lib/ion3/lc/ioncore_ext.lc
+lib/ion3/lc/ioncore_luaext.lc
+lib/ion3/lc/ioncore_menudb.lc
+lib/ion3/lc/ioncore_misc.lc
+lib/ion3/lc/ioncore_quasiact.lc
+lib/ion3/lc/ioncore_tabnum.lc
+lib/ion3/lc/ioncore_wd.lc
+lib/ion3/lc/ioncore_winprops.lc
+lib/ion3/lc/mod_dock.lc
+lib/ion3/lc/mod_menu.lc
+lib/ion3/lc/mod_query.lc
+lib/ion3/lc/mod_query_chdir.lc
+lib/ion3/lc/mod_sm.lc
+lib/ion3/lc/mod_sp.lc
+lib/ion3/lc/mod_statusbar.lc
+lib/ion3/lc/mod_tiling.lc
+lib/ion3/lc/statusd_date.lc
+lib/ion3/lc/statusd_load.lc
+lib/ion3/lc/statusd_mail.lc
+lib/ion3/mod/de.so
+lib/ion3/mod/mod_dock.so
+lib/ion3/mod/mod_menu.so
+lib/ion3/mod/mod_query.so
+lib/ion3/mod/mod_sm.so
+lib/ion3/mod/mod_sp.so
+lib/ion3/mod/mod_statusbar.so
+lib/ion3/mod/mod_tiling.so
+%%DOCSDIR%%/ChangeLog
+%%DOCSDIR%%/LICENSE
+%%DOCSDIR%%/README
+%%DOCSDIR%%/RELNOTES
+%%DATADIR%%/ion-completeman
+%%DATADIR%%/ion-runinxterm
+%%DATADIR%%/welcome.cs.txt
+%%DATADIR%%/welcome.fi.txt
+%%DATADIR%%/welcome.txt
+share/locale/cs/LC_MESSAGES/ion3.mo
+share/locale/fi/LC_MESSAGES/ion3.mo
+share/locale/fr/LC_MESSAGES/ion3.mo
+@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%
+@dirrm lib/ion3/mod
+@dirrm lib/ion3/lc
+@dirrm lib/ion3/bin
+@dirrm lib/ion3
+@dirrm etc/ion3