aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-29 22:45:36 +0800
committerpav <pav@FreeBSD.org>2006-04-29 22:45:36 +0800
commit636094c0ad568ff4f28d7724dff209d1e1e0a2c8 (patch)
tree17b84a1c2deff080edba9930fecad9cf12057436
parent4dd9813eb1af743551ba202e035a88b7859adac5 (diff)
downloadfreebsd-ports-gnome-636094c0ad568ff4f28d7724dff209d1e1e0a2c8.tar.gz
freebsd-ports-gnome-636094c0ad568ff4f28d7724dff209d1e1e0a2c8.tar.zst
freebsd-ports-gnome-636094c0ad568ff4f28d7724dff209d1e1e0a2c8.zip
This plugin saves the caches every 60 seconds (or user-defined period).
It helps avoiding the loss of metadata on crashes. PR: ports/95445 Submitted by: Pawel Pekala <c0rn@o2.pl>
-rw-r--r--mail/Makefile1
-rw-r--r--mail/claws-mail-cachesaver/Makefile28
-rw-r--r--mail/claws-mail-cachesaver/distinfo3
-rw-r--r--mail/claws-mail-cachesaver/files/patch-configure.ac15
-rw-r--r--mail/claws-mail-cachesaver/pkg-descr2
-rw-r--r--mail/sylpheed-claws-cachesaver/Makefile28
-rw-r--r--mail/sylpheed-claws-cachesaver/distinfo3
-rw-r--r--mail/sylpheed-claws-cachesaver/files/patch-configure.ac15
-rw-r--r--mail/sylpheed-claws-cachesaver/pkg-descr2
9 files changed, 97 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 4731e3837ff6..b72dfbbff767 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -523,6 +523,7 @@
SUBDIR += swaks
SUBDIR += sylpheed
SUBDIR += sylpheed-claws
+ SUBDIR += sylpheed-claws-cachesaver
SUBDIR += sylpheed-claws-fetchinfo
SUBDIR += sylpheed-claws-mailmbox
SUBDIR += sylpheed-claws-perl
diff --git a/mail/claws-mail-cachesaver/Makefile b/mail/claws-mail-cachesaver/Makefile
new file mode 100644
index 000000000000..3c91da4a156a
--- /dev/null
+++ b/mail/claws-mail-cachesaver/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: sylpheed-claws-cachesaver
+# Date created: 3 April 2006
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cachesaver
+PORTVERSION= 0.7
+CATEGORIES= mail
+MASTER_SITES= http://claws.sylpheed.org/downloads/
+PKGNAMEPREFIX= sylpheed-claws-
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= Cache saving plugin for sylpheed-claws
+
+BUILD_DEPENDS= sylpheed-claws:${PORTSDIR}/mail/sylpheed-claws
+RUN_DEPENDS= sylpheed-claws:${PORTSDIR}/mail/sylpheed-claws
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= autoconf:259
+
+PLIST_FILES= lib/sylpheed-claws/plugins/cachesaver.a \
+ lib/sylpheed-claws/plugins/cachesaver.la \
+ lib/sylpheed-claws/plugins/cachesaver.so
+
+.include <bsd.port.mk>
diff --git a/mail/claws-mail-cachesaver/distinfo b/mail/claws-mail-cachesaver/distinfo
new file mode 100644
index 000000000000..0638c68c497e
--- /dev/null
+++ b/mail/claws-mail-cachesaver/distinfo
@@ -0,0 +1,3 @@
+MD5 (cachesaver-0.7.tar.gz) = 314c18a0113e9008843bfb352b72465c
+SHA256 (cachesaver-0.7.tar.gz) = 3a5d0ba997d058b1291db61017740b1614961c76ac1f6f3c92eab74fb9287344
+SIZE (cachesaver-0.7.tar.gz) = 318917
diff --git a/mail/claws-mail-cachesaver/files/patch-configure.ac b/mail/claws-mail-cachesaver/files/patch-configure.ac
new file mode 100644
index 000000000000..f29e22fc7dd6
--- /dev/null
+++ b/mail/claws-mail-cachesaver/files/patch-configure.ac
@@ -0,0 +1,15 @@
+--- configure.ac.orig Wed Apr 5 20:04:28 2006
++++ configure.ac Wed Apr 5 20:06:27 2006
+@@ -30,7 +30,11 @@
+ PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 1.9.100.93)
+ AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
+ AC_SUBST(SYLPHEED_CLAWS_LIBS)
+-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++if test -z $prefix ; then
++ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++else
++ SYLPHEED_CLAWS_PLUGINDIR=$prefix/lib/sylpheed-claws/plugins
++fi
+ AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)
+
+ #
diff --git a/mail/claws-mail-cachesaver/pkg-descr b/mail/claws-mail-cachesaver/pkg-descr
new file mode 100644
index 000000000000..f3f505262254
--- /dev/null
+++ b/mail/claws-mail-cachesaver/pkg-descr
@@ -0,0 +1,2 @@
+This plugin saves the caches every 60 seconds (or user-defined period).
+It helps avoiding the loss of metadata on crashes.
diff --git a/mail/sylpheed-claws-cachesaver/Makefile b/mail/sylpheed-claws-cachesaver/Makefile
new file mode 100644
index 000000000000..3c91da4a156a
--- /dev/null
+++ b/mail/sylpheed-claws-cachesaver/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: sylpheed-claws-cachesaver
+# Date created: 3 April 2006
+# Whom: Pawel Pekala <c0rn@o2.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cachesaver
+PORTVERSION= 0.7
+CATEGORIES= mail
+MASTER_SITES= http://claws.sylpheed.org/downloads/
+PKGNAMEPREFIX= sylpheed-claws-
+
+MAINTAINER= c0rn@o2.pl
+COMMENT= Cache saving plugin for sylpheed-claws
+
+BUILD_DEPENDS= sylpheed-claws:${PORTSDIR}/mail/sylpheed-claws
+RUN_DEPENDS= sylpheed-claws:${PORTSDIR}/mail/sylpheed-claws
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= autoconf:259
+
+PLIST_FILES= lib/sylpheed-claws/plugins/cachesaver.a \
+ lib/sylpheed-claws/plugins/cachesaver.la \
+ lib/sylpheed-claws/plugins/cachesaver.so
+
+.include <bsd.port.mk>
diff --git a/mail/sylpheed-claws-cachesaver/distinfo b/mail/sylpheed-claws-cachesaver/distinfo
new file mode 100644
index 000000000000..0638c68c497e
--- /dev/null
+++ b/mail/sylpheed-claws-cachesaver/distinfo
@@ -0,0 +1,3 @@
+MD5 (cachesaver-0.7.tar.gz) = 314c18a0113e9008843bfb352b72465c
+SHA256 (cachesaver-0.7.tar.gz) = 3a5d0ba997d058b1291db61017740b1614961c76ac1f6f3c92eab74fb9287344
+SIZE (cachesaver-0.7.tar.gz) = 318917
diff --git a/mail/sylpheed-claws-cachesaver/files/patch-configure.ac b/mail/sylpheed-claws-cachesaver/files/patch-configure.ac
new file mode 100644
index 000000000000..f29e22fc7dd6
--- /dev/null
+++ b/mail/sylpheed-claws-cachesaver/files/patch-configure.ac
@@ -0,0 +1,15 @@
+--- configure.ac.orig Wed Apr 5 20:04:28 2006
++++ configure.ac Wed Apr 5 20:06:27 2006
+@@ -30,7 +30,11 @@
+ PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 1.9.100.93)
+ AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
+ AC_SUBST(SYLPHEED_CLAWS_LIBS)
+-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++if test -z $prefix ; then
++ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
++else
++ SYLPHEED_CLAWS_PLUGINDIR=$prefix/lib/sylpheed-claws/plugins
++fi
+ AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)
+
+ #
diff --git a/mail/sylpheed-claws-cachesaver/pkg-descr b/mail/sylpheed-claws-cachesaver/pkg-descr
new file mode 100644
index 000000000000..f3f505262254
--- /dev/null
+++ b/mail/sylpheed-claws-cachesaver/pkg-descr
@@ -0,0 +1,2 @@
+This plugin saves the caches every 60 seconds (or user-defined period).
+It helps avoiding the loss of metadata on crashes.