aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2009-10-19 22:44:51 +0800
committerale <ale@FreeBSD.org>2009-10-19 22:44:51 +0800
commit6399eb9793ade844205857981efd208aa480fc62 (patch)
tree10073389c03107cbb7f7491280d1da80af5a5dc8
parente92bbb937b450ddf0a99f4e89caf3410f88e4ee7 (diff)
downloadfreebsd-ports-gnome-6399eb9793ade844205857981efd208aa480fc62.tar.gz
freebsd-ports-gnome-6399eb9793ade844205857981efd208aa480fc62.tar.zst
freebsd-ports-gnome-6399eb9793ade844205857981efd208aa480fc62.zip
Fix subtle (cut'n'paste) bug.
-rw-r--r--security/nss/Makefile2
-rw-r--r--security/nss/files/patch-lib_softoken_legacydb_lgfind.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/security/nss/Makefile b/security/nss/Makefile
index 9ca04dca35e0..97eec7172fcd 100644
--- a/security/nss/Makefile
+++ b/security/nss/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nss
PORTVERSION= ${_MAJOR}.${_MINOR}.${_PATCH}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= security/nss/releases/NSS_${PORTVERSION:S/./_/g}_RTM/src
diff --git a/security/nss/files/patch-lib_softoken_legacydb_lgfind.c b/security/nss/files/patch-lib_softoken_legacydb_lgfind.c
new file mode 100644
index 000000000000..719fb840bded
--- /dev/null
+++ b/security/nss/files/patch-lib_softoken_legacydb_lgfind.c
@@ -0,0 +1,11 @@
+--- lib/softoken/legacydb/lgfind.c.orig 2009-10-19 16:07:48.000000000 +0200
++++ lib/softoken/legacydb/lgfind.c 2009-10-19 16:08:04.000000000 +0200
+@@ -778,7 +778,7 @@
+ classFlags &= LG_TRUST;
+ copy = &cert_md5_hash; break;
+ case CKA_CERTIFICATE_TYPE:
+- crv = lg_GetULongAttribute(CKA_CLASS,&pTemplate[i],1,&certType);
++ crv = lg_GetULongAttribute(CKA_CERTIFICATE_TYPE,&pTemplate[i],1,&certType);
+ if (crv != CKR_OK) {
+ classFlags = 0;
+ }