aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-09-10 21:16:16 +0800
committermat <mat@FreeBSD.org>2018-09-10 21:16:16 +0800
commit641ecfafeeaa73266052bf94226bd674b850b45f (patch)
treec43d60918160ea286daad1d484fdacaaded3df88
parented6a90e2e9b645590dd7e6e43cd9ed313b094c13 (diff)
downloadfreebsd-ports-gnome-641ecfafeeaa73266052bf94226bd674b850b45f.tar.gz
freebsd-ports-gnome-641ecfafeeaa73266052bf94226bd674b850b45f.tar.zst
freebsd-ports-gnome-641ecfafeeaa73266052bf94226bd674b850b45f.zip
Various cleanup & fixes post-DOCS/EXAMPLES cleanup.
PR: 230864 Submitted by: mat exp-runs by: antoine
-rw-r--r--cad/calculix-ccx/Makefile10
-rw-r--r--devel/critcl/Makefile2
-rw-r--r--devel/libiqxmlrpc/Makefile1
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind912/Makefile4
-rw-r--r--dns/bind913/Makefile4
-rw-r--r--editors/the/pkg-plist2
-rw-r--r--games/connectfive/Makefile2
-rw-r--r--japanese/lookup/Makefile2
-rw-r--r--math/nfft/Makefile2
-rw-r--r--math/reduce-psl/Makefile2
-rw-r--r--math/reduce/Makefile2
-rw-r--r--net/sflowtool/Makefile2
-rw-r--r--net/tcludp/Makefile2
-rw-r--r--sysutils/tkdvd/Makefile2
-rw-r--r--textproc/libxml++26-reference/pkg-plist2
-rw-r--r--www/mod_auth_cas/Makefile4
-rw-r--r--www/mod_rpaf2/Makefile4
-rw-r--r--www/varnish6/Makefile2
19 files changed, 18 insertions, 37 deletions
diff --git a/cad/calculix-ccx/Makefile b/cad/calculix-ccx/Makefile
index fd94bfd91345..ce918d97726c 100644
--- a/cad/calculix-ccx/Makefile
+++ b/cad/calculix-ccx/Makefile
@@ -34,6 +34,7 @@ ALL_TARGET= #Empty
CCX_VER= ccx_${PORTVERSION}
WRKSRC= ${WRKDIR}/CalculiX/${CCX_VER}/src
+DOCSDIR= ${PREFIX}/share/doc/CalculiX
OPTIONS_DEFINE= DOCS EXAMPLES
@@ -42,7 +43,6 @@ OPTIONS_DEFINE= DOCS EXAMPLES
.if ${PORT_OPTIONS:MDOCS}
DISTFILES+= ${DIST_HTM} ${DIST_PS}
EXTRACT_ONLY+= ${DIST_HTM} ${DIST_PS}
-DOCSDIR= ${PREFIX}/share/doc/CalculiX
.endif
.if $(PORT_OPTIONS:MEXAMPLES)
@@ -68,18 +68,18 @@ pre-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${CCX_VER} \
${STAGEDIR}${PREFIX}/bin/ccx
-.if ${PORT_OPTIONS:MDOCS}
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@(cd ${WRKDIR}/CalculiX/${CCX_VER}/doc/ccx && ${COPYTREE_SHARE} . \
${STAGEDIR}${DOCSDIR}/ccx)
${INSTALL_DATA} ${WRKDIR}/CalculiX/${CCX_VER}/doc/${CCX_VER}.ps \
${STAGEDIR}${DOCSDIR}
@${GZIP_CMD} ${STAGEDIR}${DOCSDIR}/${CCX_VER}.ps
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
+
+do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@(cd ${WRKDIR}/CalculiX/${CCX_VER}/test && ${COPYTREE_SHARE} . \
${STAGEDIR}${EXAMPLESDIR})
-.endif
.include <bsd.port.mk>
diff --git a/devel/critcl/Makefile b/devel/critcl/Makefile
index 0aacf943890a..92379046ddeb 100644
--- a/devel/critcl/Makefile
+++ b/devel/critcl/Makefile
@@ -31,8 +31,6 @@ NO_BUILD= yes
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-patch:
${REINPLACE_CMD} -e 's|dtplite|${LOCALBASE}/bin/dtplite|g' ${WRKSRC}/build.tcl
${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g' ${WRKSRC}/lib/critcl/Config
diff --git a/devel/libiqxmlrpc/Makefile b/devel/libiqxmlrpc/Makefile
index 1341ed43c69e..bc426d7acf0c 100644
--- a/devel/libiqxmlrpc/Makefile
+++ b/devel/libiqxmlrpc/Makefile
@@ -15,7 +15,6 @@ LICENSE= BSD2CLAUSE
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
OPTIONS_DEFINE= DOXYGEN DOCS
-OPTIONS_DEFAULT=
DOXYGEN_IMPLIES= DOCS
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index b00b0490149d..cc208de236d6 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -75,12 +75,12 @@ CONFLICTS+= bind9-devel
USE_RC_SUBR= named
SUB_FILES= pkg-message named.conf
CONFLICTS+= bind-tools
+
+PORTDOCS= *
.endif # BIND_TOOLS_SLAVE
MAKE_JOBS_UNSAFE= yes
-PORTDOCS= *
-
OPTIONS_DEFAULT= SIGCHASE IDN GSSAPI_NONE JSON PYTHON
OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
FIXED_RRSET SIGCHASE IPV6
diff --git a/dns/bind912/Makefile b/dns/bind912/Makefile
index 0b3deebf52ed..e221932e4366 100644
--- a/dns/bind912/Makefile
+++ b/dns/bind912/Makefile
@@ -62,12 +62,12 @@ CONFLICTS+= bind912
USE_RC_SUBR= named
SUB_FILES= pkg-message named.conf
CONFLICTS+= bind-tools
+
+PORTDOCS= *
.endif # BIND_TOOLS_SLAVE
MAKE_JOBS_UNSAFE= yes
-PORTDOCS= *
-
OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE JSON PYTHON
OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
FIXED_RRSET SIGCHASE IPV6 THREADS
diff --git a/dns/bind913/Makefile b/dns/bind913/Makefile
index a6ff8ef2473f..00379cb1925e 100644
--- a/dns/bind913/Makefile
+++ b/dns/bind913/Makefile
@@ -61,12 +61,12 @@ CONFLICTS+= bind913
USE_RC_SUBR= named
SUB_FILES= pkg-message named.conf
CONFLICTS+= bind-tools
+
+PORTDOCS= *
.endif # BIND_TOOLS_SLAVE
MAKE_JOBS_UNSAFE= yes
-PORTDOCS= *
-
OPTIONS_DEFAULT= THREADS SIGCHASE IDN GSSAPI_NONE JSON PYTHON
OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
FIXED_RRSET SIGCHASE IPV6 THREADS
diff --git a/editors/the/pkg-plist b/editors/the/pkg-plist
index 3109b56ec9f4..2a13a37300d9 100644
--- a/editors/the/pkg-plist
+++ b/editors/the/pkg-plist
@@ -2,7 +2,6 @@
bin/the
%%XCURSES%%bin/xthe
man/man1/the.1.gz
-@dir %%DATADIR%%
%%DATADIR%%/THE_Help.txt
%%DATADIR%%/abf.tld
%%DATADIR%%/append.the
@@ -48,7 +47,6 @@ man/man1/the.1.gz
%%DATADIR%%/udiff.tld
%%DATADIR%%/uncomm.the
%%DATADIR%%/words.the
-@dir %%PORTDOCS%%%%DOCSDIR%%
%%PORTDOCS%%%%DOCSDIR%%/app1.html
%%PORTDOCS%%%%DOCSDIR%%/app2.html
%%PORTDOCS%%%%DOCSDIR%%/app3.html
diff --git a/games/connectfive/Makefile b/games/connectfive/Makefile
index 3058f77aa4a1..217287625cf5 100644
--- a/games/connectfive/Makefile
+++ b/games/connectfive/Makefile
@@ -30,8 +30,6 @@ PORTDATA= *
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/Makefile.linux
@${REINPLACE_CMD} -e 's|data/|${DATADIR}/|' ${WRKSRC}/connect.cpp
diff --git a/japanese/lookup/Makefile b/japanese/lookup/Makefile
index 006113deed90..c82ef30f1b97 100644
--- a/japanese/lookup/Makefile
+++ b/japanese/lookup/Makefile
@@ -28,7 +28,7 @@ OPTIONS_DEFINE= DOCS
PORTDOCS= AUTHORS ChangeLog NEWS README.md
- post-install:
+post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
diff --git a/math/nfft/Makefile b/math/nfft/Makefile
index ccecccb94e31..17b7be82429b 100644
--- a/math/nfft/Makefile
+++ b/math/nfft/Makefile
@@ -22,7 +22,7 @@ USE_GITHUB= yes
GH_ACCOUNT= NFFT
OPTIONS_DEFINE= DOCS DOXYGEN
-OPTIONS_SUB= DOXYGEN
+OPTIONS_SUB= yes
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
DOXYGEN_ALL_TARGET= all doc
diff --git a/math/reduce-psl/Makefile b/math/reduce-psl/Makefile
index c414070a1f95..db05bc78116c 100644
--- a/math/reduce-psl/Makefile
+++ b/math/reduce-psl/Makefile
@@ -37,8 +37,6 @@ REDUCE_BINS= ${WRKSRC}/pslbuild/${TARGET_SDIR}
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_SCRIPT} ${FILESDIR}/runpsl.sh ${STAGEDIR}${PREFIX}/bin/redpsl
diff --git a/math/reduce/Makefile b/math/reduce/Makefile
index 27de2a16d776..43430f7e5f33 100644
--- a/math/reduce/Makefile
+++ b/math/reduce/Makefile
@@ -46,8 +46,6 @@ REDUCE_BINS= ${WRKSRC}/cslbuild/${TARGET_SDIR}
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${REDUCE_BINS}/csl/reduce.img ${STAGEDIR}${DATADIR}
diff --git a/net/sflowtool/Makefile b/net/sflowtool/Makefile
index 1407087af4b7..b48372ac7af0 100644
--- a/net/sflowtool/Makefile
+++ b/net/sflowtool/Makefile
@@ -23,8 +23,6 @@ PORTEXAMPLES= README ipTopTalkers ipTrafficMatrix sflowRRDChart.cgi \
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
-
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/net/tcludp/Makefile b/net/tcludp/Makefile
index 2ec91cad21b7..ecd9d833b4b9 100644
--- a/net/tcludp/Makefile
+++ b/net/tcludp/Makefile
@@ -22,6 +22,6 @@ TEST_TARGET= test
PLIST_FILES= lib/${TCL_PKG}/lib${TCL_PKG}.so \
lib/${TCL_PKG}/pkgIndex.tcl \
- %%PORTDOCS%%man/mann/udp.n.gz
+ man/mann/udp.n.gz
.include <bsd.port.mk>
diff --git a/sysutils/tkdvd/Makefile b/sysutils/tkdvd/Makefile
index ee7d7eea5142..30555c3de6c2 100644
--- a/sysutils/tkdvd/Makefile
+++ b/sysutils/tkdvd/Makefile
@@ -30,8 +30,6 @@ DESKTOP_ENTRIES="TkDVD" \
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|tclsh|${TCLSH}|' ${WRKSRC}/install.tcl \
${WRKSRC}/configure
diff --git a/textproc/libxml++26-reference/pkg-plist b/textproc/libxml++26-reference/pkg-plist
index cce2f0a79f99..f690fea54084 100644
--- a/textproc/libxml++26-reference/pkg-plist
+++ b/textproc/libxml++26-reference/pkg-plist
@@ -1 +1 @@
-%%PORTDOCS%%share/devhelp/books/libxml++-%%API_VERSION%%/libxml++-%%API_VERSION%%.devhelp2
+share/devhelp/books/libxml++-%%API_VERSION%%/libxml++-%%API_VERSION%%.devhelp2
diff --git a/www/mod_auth_cas/Makefile b/www/mod_auth_cas/Makefile
index f617e7899ce8..d8edcb2123e4 100644
--- a/www/mod_auth_cas/Makefile
+++ b/www/mod_auth_cas/Makefile
@@ -37,8 +37,6 @@ PLIST_SUB+= APMOD_FILE=${APMOD_FILE}
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR} ${STAGEDIR}${DOCSDIR}
${APXS} -S LIBEXECDIR=${STAGEDIR}${PREFIX}/${APACHEMODDIR} \
@@ -48,4 +46,4 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/${APMOD_FILE} ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/modules.d
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/mod_rpaf2/Makefile b/www/mod_rpaf2/Makefile
index 6c9618c9f071..ebff3429f91b 100644
--- a/www/mod_rpaf2/Makefile
+++ b/www/mod_rpaf2/Makefile
@@ -33,11 +33,9 @@ PORTDOCS= README.md
OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
-
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/modules.d ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/${APMOD_FILE} ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/modules.d
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/varnish6/Makefile b/www/varnish6/Makefile
index ae3a8ab4befe..8898c63d13ba 100644
--- a/www/varnish6/Makefile
+++ b/www/varnish6/Makefile
@@ -45,8 +45,8 @@ EXTRA_PATCHES+= ${FILESDIR}/no-inet6.patch
OPTIONS_DEFINE= DOCS
-post-patch:
.if defined(BAD_TESTS)
+post-patch:
${RM} ${BAD_TESTS:C|.+|${WRKSRC}/bin/varnishtest/tests/\0.vtc|}
.endif