aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-04-06 00:21:01 +0800
committerbapt <bapt@FreeBSD.org>2011-04-06 00:21:01 +0800
commit64b83d19057ab5af075e511132d0b851dc355ad9 (patch)
tree250e973f7cc76c42285c0bb68145d3e64b541cc6
parent1a02d008aaf7acc1c8a2e34077fc93ab8c9f8a1e (diff)
downloadfreebsd-ports-gnome-64b83d19057ab5af075e511132d0b851dc355ad9.tar.gz
freebsd-ports-gnome-64b83d19057ab5af075e511132d0b851dc355ad9.tar.zst
freebsd-ports-gnome-64b83d19057ab5af075e511132d0b851dc355ad9.zip
This is Net::Bonjour, a set of perl modules to utilize DNS for service
discovery. This method of service discovery is branded as Bonjour by Apple Computer. WWW: http://search.cpan.org/dist/Net-Bonjour/
-rw-r--r--dns/Makefile1
-rw-r--r--dns/p5-Net-Bonjour/Makefile35
-rw-r--r--dns/p5-Net-Bonjour/distinfo2
-rw-r--r--dns/p5-Net-Bonjour/pkg-descr5
-rw-r--r--dns/p5-Net-Bonjour/pkg-plist8
5 files changed, 51 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 84f10793afc4..68146327fc59 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -92,6 +92,7 @@
SUBDIR += p5-DNS-Zone
SUBDIR += p5-DNS-ZoneParse
SUBDIR += p5-Data-Validate-Domain
+ SUBDIR += p5-Net-Bonjour
SUBDIR += p5-Net-DNS
SUBDIR += p5-Net-DNS-Async
SUBDIR += p5-Net-DNS-Codes
diff --git a/dns/p5-Net-Bonjour/Makefile b/dns/p5-Net-Bonjour/Makefile
new file mode 100644
index 000000000000..2e65e75cce9b
--- /dev/null
+++ b/dns/p5-Net-Bonjour/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Net-Bonjour
+# Date created: 2011-04-05
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Bonjour
+PORTVERSION= 0.96
+CATEGORIES= dns net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:CHLIGE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Module for DNS service discovery
+
+LICENSE_COMB= dual
+LICENSE= ART20 GPLv1
+
+PERL_CONFIGURE= yes
+
+BUILD_DEPENDS= p5-Net-DNS>=0.5:${PORTSDIR}/dns/p5-Net-DNS
+
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+MAN3= Net::Rendezvous.3 \
+ Net::Bonjour::Entry.3 \
+ Net::Rendezvous::Entry.3 \
+ Net::Bonjour.3
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/my $$ans = .*/my $$ans = "n";/g' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-Bonjour/distinfo b/dns/p5-Net-Bonjour/distinfo
new file mode 100644
index 000000000000..ff168a6cc0ad
--- /dev/null
+++ b/dns/p5-Net-Bonjour/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Bonjour-0.96.tar.gz) = c38a1f3ab200b08208d0c3a02b23d30653dfc62c09c6a12561c6ea08a69b1f97
+SIZE (Net-Bonjour-0.96.tar.gz) = 8323
diff --git a/dns/p5-Net-Bonjour/pkg-descr b/dns/p5-Net-Bonjour/pkg-descr
new file mode 100644
index 000000000000..d31d7a95bde0
--- /dev/null
+++ b/dns/p5-Net-Bonjour/pkg-descr
@@ -0,0 +1,5 @@
+This is Net::Bonjour, a set of perl modules to utilize DNS for service
+discovery. This method of service discovery is branded as Bonjour by
+Apple Computer.
+
+WWW: http://search.cpan.org/dist/Net-Bonjour/
diff --git a/dns/p5-Net-Bonjour/pkg-plist b/dns/p5-Net-Bonjour/pkg-plist
new file mode 100644
index 000000000000..22e338930e7b
--- /dev/null
+++ b/dns/p5-Net-Bonjour/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Bonjour/.packlist
+%%SITE_PERL%%/Net/Bonjour.pm
+%%SITE_PERL%%/Net/Bonjour/Entry.pm
+%%SITE_PERL%%/Net/Rendezvous/Entry.pm
+%%SITE_PERL%%/Net/Rendezvous.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Bonjour
+@dirrmtry %%SITE_PERL%%/Net/Rendezvous
+@dirrmtry %%SITE_PERL%%/Net/Bonjour