aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-02-27 13:29:07 +0800
committermarcus <marcus@FreeBSD.org>2009-02-27 13:29:07 +0800
commit64fafcc6a920ee60be4981866277dd9112025f59 (patch)
tree26f7cb39b736c805521b20203ed8c09fb9dd133a
parent1059fd4ebf6cf8f1015eca98d41932b4e844072e (diff)
downloadfreebsd-ports-gnome-64fafcc6a920ee60be4981866277dd9112025f59.tar.gz
freebsd-ports-gnome-64fafcc6a920ee60be4981866277dd9112025f59.tar.zst
freebsd-ports-gnome-64fafcc6a920ee60be4981866277dd9112025f59.zip
Add libproxy-kde, a plug-in which allows KDE applications to make use
of libproxy.
-rw-r--r--net/Makefile1
-rw-r--r--net/libproxy-kde/Makefile29
-rw-r--r--net/libproxy-kde/pkg-descr7
-rw-r--r--net/libproxy-kde/pkg-plist1
4 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 9afe78504f8e..72d66377ee7e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -303,6 +303,7 @@
SUBDIR += libpcapnav
SUBDIR += libproxy
SUBDIR += libproxy-gnome
+ SUBDIR += libproxy-kde
SUBDIR += librsync
SUBDIR += libsocket++
SUBDIR += libsocketcpp
diff --git a/net/libproxy-kde/Makefile b/net/libproxy-kde/Makefile
new file mode 100644
index 000000000000..d1a4d51851df
--- /dev/null
+++ b/net/libproxy-kde/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libproxy-kde
+# Date created: 26 February 2009
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= net devel
+PKGNAMESUFFIX= -kde
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= KDE plug-in for libproxy
+
+LIB_DEPENDS= proxy.0:${PORTSDIR}/net/libproxy
+
+MASTERDIR= ${.CURDIR}/../libproxy
+BUILD_WRKSRC= ${WRKSRC}/src/plugins
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+USE_XORG= xmu x11
+CONFIGURE_ARGS=--without-gnome --with-kde --without-webkit \
+ --without-mozjs --without-networkmanager --without-python \
+ --without-envvar --without-file
+
+LIBPROXY_SLAVE= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/libproxy-kde/pkg-descr b/net/libproxy-kde/pkg-descr
new file mode 100644
index 000000000000..af1779a74cf3
--- /dev/null
+++ b/net/libproxy-kde/pkg-descr
@@ -0,0 +1,7 @@
+Libproxy exists to answer the question: Given a network resource, how do I
+reach it? It handles all the details, enabling you to get back to
+programming.
+
+This plug-in allows the KDE Desktop to make use of libproxy.
+
+WWW: http://code.google.com/p/libproxy/
diff --git a/net/libproxy-kde/pkg-plist b/net/libproxy-kde/pkg-plist
new file mode 100644
index 000000000000..606024d13181
--- /dev/null
+++ b/net/libproxy-kde/pkg-plist
@@ -0,0 +1 @@
+lib/libproxy/%%VERSION%%/plugins/kde.so