aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>2002-01-17 04:31:11 +0800
committerandreas <andreas@FreeBSD.org>2002-01-17 04:31:11 +0800
commit6645c0f30da910b2508702c99c4a08198964f4a9 (patch)
tree55ab54b2748d0b23c1a85a1a75919d149b3f85e4
parentdbe3100a3d4598698dfdec64d1351eba47f934bc (diff)
downloadfreebsd-ports-gnome-6645c0f30da910b2508702c99c4a08198964f4a9.tar.gz
freebsd-ports-gnome-6645c0f30da910b2508702c99c4a08198964f4a9.tar.zst
freebsd-ports-gnome-6645c0f30da910b2508702c99c4a08198964f4a9.zip
Add new port:
utftpd is a TFTP server with fine-grained access control, support for blksize (RFC 2348), timeout options and support for revision control. You can assign three different kinds of rights to every client: - read: the right to read a file. - write: the right to write to an already existing file. - create: the right to create a file. Clients may be specified by a single ip address or a range of addresses or by ip address and mask. Revision control is optional and will never be turned on automatically for any file (you have to do the initial checkin into by hand). WWW: http://www.ohse.de/uwe/software/utftpd.html
-rw-r--r--net/Makefile1
-rw-r--r--net/utftpd/Makefile22
-rw-r--r--net/utftpd/distinfo1
-rw-r--r--net/utftpd/pkg-comment1
-rw-r--r--net/utftpd/pkg-descr15
-rw-r--r--net/utftpd/pkg-plist8
6 files changed, 48 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 62fb31c234a1..afac22615b87 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -472,6 +472,7 @@
SUBDIR += udptunnel
SUBDIR += unison
SUBDIR += urlendec
+ SUBDIR += utftpd
SUBDIR += vchat
SUBDIR += vicq
SUBDIR += vnc
diff --git a/net/utftpd/Makefile b/net/utftpd/Makefile
new file mode 100644
index 000000000000..5a453284425b
--- /dev/null
+++ b/net/utftpd/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: utftpd
+# Date created: 15 January 2002
+# Whom: andreas@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= utftpd
+PORTVERSION= 0.2.4
+CATEGORIES= net
+MASTER_SITES= http://www.ohse.de/uwe/releases/
+
+MAINTAINER= andreas@FreeBSD.org
+
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+
+MAN1= utftp.1
+MAN5= utftpd.conf.5
+MAN8= utftpd.8 utftpd_make.8
+
+.include <bsd.port.mk>
diff --git a/net/utftpd/distinfo b/net/utftpd/distinfo
new file mode 100644
index 000000000000..bf1bcb96926f
--- /dev/null
+++ b/net/utftpd/distinfo
@@ -0,0 +1 @@
+MD5 (utftpd-0.2.4.tar.gz) = 3adf5d86c7b6d83d8ec4099e54e8dede
diff --git a/net/utftpd/pkg-comment b/net/utftpd/pkg-comment
new file mode 100644
index 000000000000..678900ce8a10
--- /dev/null
+++ b/net/utftpd/pkg-comment
@@ -0,0 +1 @@
+secure tftpd server with fine grained access and revision control
diff --git a/net/utftpd/pkg-descr b/net/utftpd/pkg-descr
new file mode 100644
index 000000000000..7ba3a7b82d47
--- /dev/null
+++ b/net/utftpd/pkg-descr
@@ -0,0 +1,15 @@
+utftpd is a TFTP server with fine-grained access control, support for
+blksize (RFC 2348), timeout options and support for revision control.
+
+You can assign three different kinds of rights to every client:
+- read: the right to read a file.
+- write: the right to write to an already existing file.
+- create: the right to create a file.
+
+Clients may be specified by a single ip address or a range of
+addresses or by ip address and mask.
+
+Revision control is optional and will never be turned on automatically
+for any file (you have to do the initial checkin into by hand).
+
+WWW: http://www.ohse.de/uwe/software/utftpd.html
diff --git a/net/utftpd/pkg-plist b/net/utftpd/pkg-plist
new file mode 100644
index 000000000000..61cc185cfa1d
--- /dev/null
+++ b/net/utftpd/pkg-plist
@@ -0,0 +1,8 @@
+bin/utftp
+man/man1/utftp.1.gz
+man/man5/utftpd.conf.5.gz
+man/man8/utftpd.8.gz
+man/man8/utftpd_make.8.gz
+sbin/utftpd
+sbin/utftpd_dump
+sbin/utftpd_make