aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2006-05-17 22:34:29 +0800
committerahze <ahze@FreeBSD.org>2006-05-17 22:34:29 +0800
commit66c2ddb390bd0d1999d938db73a82853bd10b836 (patch)
tree088481f60f42358e4e016b18ff8310ccd8457504
parenta3d44e40da3674ccbf743509fb580ddd2c6ac8f2 (diff)
downloadfreebsd-ports-gnome-66c2ddb390bd0d1999d938db73a82853bd10b836.tar.gz
freebsd-ports-gnome-66c2ddb390bd0d1999d938db73a82853bd10b836.tar.zst
freebsd-ports-gnome-66c2ddb390bd0d1999d938db73a82853bd10b836.zip
- Readd gstreamer-plugins-xvid
-rw-r--r--MOVED1
-rw-r--r--Mk/bsd.gstreamer.mk2
-rw-r--r--multimedia/gstreamer-plugins-xvid/Makefile18
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common15
4 files changed, 34 insertions, 2 deletions
diff --git a/MOVED b/MOVED
index a5891fc28dec..0f9dc63d0180 100644
--- a/MOVED
+++ b/MOVED
@@ -2279,7 +2279,6 @@ audio/gstreamer-plugins-smoothwave|audio/gstreamer-plugins-smoothwave80|2006-04-
audio/gstreamer-plugins-sndfile|audio/gstreamer-plugins-sndfile80|2006-04-29|Not part of gstreamer 0.10 yet
graphics/gstreamer-plugins-swfdec|graphics/gstreamer-plugins-swfdec80|2006-04-29|Not part of gstreamer 0.10 yet
multimedia/gstreamer-plugins-x264|multimedia/gstreamer-plugins-x26480|2006-04-29|Not part of gstreamer 0.10 yet
-multimedia/gstreamer-plugins-xvid|multimedia/gstreamer-plugins-xvid80|2006-04-29|Not part of gstreamer 0.10 yet
graphics/gstreamer-plugins-jpeg-mmx|graphics/gstreamer-plugins-jpeg-mmx80|2006-04-29|Not part of gstreamer 0.10 yet
audio/gstreamer-plugins-polyp|audio/gstreamer-plugins-polyp80|2006-04-29|Not part of gstreamer 0.10 yet
www/evolution-caldav||2006-04-29|Now included in evolution-data-server and evolution
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index 42ac474d23dc..cf881f436371 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -65,7 +65,7 @@ _USE_GSTREAMER_ALL= a52dec aalib bad cairo cdparanoia dts \
gnonlin good gsm ivorbis jpeg ladspa lame libcaca \
libmms libpng libvisual mad mpeg2dec \
musepack ogg pango sdl shout2 sidplay \
- speex theora ugly vorbis wavpack
+ speex theora ugly vorbis wavpack xvid
_USE_GSTREAMER80_ALL= a52dec aalib artsd audiofile cairo cdaudio cdio cdparanoia \
dirac dts dv dvd esound faac faad ffmpeg flac \
gconf gdkpixbuf gnomevfs gsm hermes ivorbis jack jpeg \
diff --git a/multimedia/gstreamer-plugins-xvid/Makefile b/multimedia/gstreamer-plugins-xvid/Makefile
new file mode 100644
index 000000000000..894a26132eef
--- /dev/null
+++ b/multimedia/gstreamer-plugins-xvid/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: gstreamer-plugins-xvid
+# Date created: 3 Oct 2004
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/multimedia/gstreamer-plugins-xvid80/Makefile,v 1.1 2006/01/20 02:56:07 ahze Exp $
+#
+
+CATEGORIES= multimedia
+PORTREVISION= 0
+
+COMMENT= Gstreamer xvid plugin
+
+GST_PLUGIN= xvid
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index 6f3a10f2316a..3a7bf63d2f0a 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -244,6 +244,15 @@ LIB_DEPENDS+= vorbisidec.1:${PORTSDIR}/audio/libtremor
DIST= bad
.endif
+# hal
+.if ${GST_PLUGIN}=="hal"
+LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
+PLIST_FILES= ${GST_LIB_DIR}/libgsthalelements.a \
+ ${GST_LIB_DIR}/libgsthalelements.la \
+ ${GST_LIB_DIR}/libgsthalelements.so
+
+.endif
+
# jpeg
.if ${GST_PLUGIN}=="jpeg"
LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
@@ -376,6 +385,12 @@ EXTRA_LIBS+= -lgsttag-${VERSION} -lgstaudio-${VERSION}
DIST= base
.endif
+# xvid
+.if ${GST_PLUGIN}=="xvid"
+LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
+DIST= bad
+.endif
+
# wavpack
.if ${GST_PLUGIN}=="wavpack"
LIB_DEPENDS+= wavpack.0:${PORTSDIR}/audio/wavpack